aboutsummaryrefslogtreecommitdiffstats
path: root/shells
diff options
context:
space:
mode:
authorgarga <garga@FreeBSD.org>2008-05-21 19:55:18 +0800
committergarga <garga@FreeBSD.org>2008-05-21 19:55:18 +0800
commitbdb7b4077123b42d0e201a5adfa4210b1e8e067d (patch)
treedc38372f50e7688666a9a256ceb95c9a6c8ca4fd /shells
parentdcb91e8e88d146d60f8d6842ff6aabb7450fb271 (diff)
downloadfreebsd-ports-gnome-bdb7b4077123b42d0e201a5adfa4210b1e8e067d.tar.gz
freebsd-ports-gnome-bdb7b4077123b42d0e201a5adfa4210b1e8e067d.tar.zst
freebsd-ports-gnome-bdb7b4077123b42d0e201a5adfa4210b1e8e067d.zip
- Fix segmentation fault on completion
- Bump PORTREVISION PR: ports/123490 Submitted by: garga Approved by: maintainer timeout (2 weeks)
Diffstat (limited to 'shells')
-rw-r--r--shells/zsh/Makefile1
-rw-r--r--shells/zsh/files/patch-Src_Zle_compresult.c28
2 files changed, 29 insertions, 0 deletions
diff --git a/shells/zsh/Makefile b/shells/zsh/Makefile
index 48182f50650e..ac99eff352ba 100644
--- a/shells/zsh/Makefile
+++ b/shells/zsh/Makefile
@@ -22,6 +22,7 @@
PORTNAME= zsh
PORTVERSION= 4.3.6
+PORTREVISION= 1
CATEGORIES= shells
MASTER_SITES= SF
.if !defined(NOPORTDOCS)
diff --git a/shells/zsh/files/patch-Src_Zle_compresult.c b/shells/zsh/files/patch-Src_Zle_compresult.c
new file mode 100644
index 000000000000..a41e2c2c0938
--- /dev/null
+++ b/shells/zsh/files/patch-Src_Zle_compresult.c
@@ -0,0 +1,28 @@
+--- Src/Zle/compresult.c.orig 2008-05-07 10:19:11.000000000 -0300
++++ Src/Zle/compresult.c 2008-05-07 10:19:35.000000000 -0300
+@@ -1188,6 +1188,12 @@
+ {
+ int was_meta;
+
++ /* Just list the matches if the list was requested. */
++ if (lst == COMP_LIST_COMPLETE) {
++ showinglist = -2;
++ return;
++ }
++
+ /* Already metafied when called from domenuselect already */
+ if (zlemetaline == NULL) {
+ was_meta = 0;
+@@ -1195,12 +1201,6 @@
+ } else
+ was_meta = 1;
+
+- /* Just list the matches if the list was requested. */
+- if (lst == COMP_LIST_COMPLETE) {
+- showinglist = -2;
+- return;
+- }
+-
+ /* Otherwise go to the next match in the array... */
+ do {
+ if (!*++(minfo.cur)) {