aboutsummaryrefslogtreecommitdiffstats
path: root/shells
diff options
context:
space:
mode:
authormat <mat@FreeBSD.org>2015-05-12 02:34:57 +0800
committermat <mat@FreeBSD.org>2015-05-12 02:34:57 +0800
commitd843ecd4966c8a5bed60cf3aaeb27edb6b5b2389 (patch)
tree634e1ef4990207301493f26b46d80abe56b9f2b3 /shells
parent925f5606448b4e40652ba0a13bfb8cd44c8aac89 (diff)
downloadfreebsd-ports-gnome-d843ecd4966c8a5bed60cf3aaeb27edb6b5b2389.tar.gz
freebsd-ports-gnome-d843ecd4966c8a5bed60cf3aaeb27edb6b5b2389.tar.zst
freebsd-ports-gnome-d843ecd4966c8a5bed60cf3aaeb27edb6b5b2389.zip
Cleanup DIST* variables.
When appropriate: - Try to use DISTVERSION{SUF,PRE}FIX - Replace PORTNAME-PORTVERSION by DISTNAME - Convert MASTER_SITES to use macros - Other light cleanup With hat: portmgr Sponsored by: Absolight
Diffstat (limited to 'shells')
-rw-r--r--shells/bash/Makefile8
1 files changed, 3 insertions, 5 deletions
diff --git a/shells/bash/Makefile b/shells/bash/Makefile
index 4830ad82c7bc..6a2360ad00db 100644
--- a/shells/bash/Makefile
+++ b/shells/bash/Makefile
@@ -6,15 +6,13 @@ PATCHLEVEL= 33
PORTVERSION= 4.3.${PATCHLEVEL:S/^0//g}
PORTREVISION?= 0
CATEGORIES= shells
-MASTER_SITES= GNU
-MASTER_SITE_SUBDIR= ${PORTNAME}
+MASTER_SITES= GNU/${PORTNAME}
DISTNAME= ${PORTNAME}-${PORTVERSION:R}
DIST_SUBDIR= ${PORTNAME}
EXTRACT_ONLY= ${DISTNAME}${EXTRACT_SUFX}
-PATCH_SITES= ${MASTER_SITE_GNU} \
- ftp://ftp.cwru.edu/pub/%SUBDIR%/
-PATCH_SITE_SUBDIR= ${PORTNAME}/${DISTNAME}-patches/
+PATCH_SITES= GNU/${PORTNAME}/${DISTNAME}-patches/ \
+ ftp://ftp.cwru.edu/pub/${PORTNAME}/${DISTNAME}-patches/
PATCHFILES!= /usr/bin/jot -s " " -w \
${PORTNAME}${PORTVERSION:R:S/.//g}-%03d \
${PATCHLEVEL} 1 ${PATCHLEVEL}