aboutsummaryrefslogtreecommitdiffstats
path: root/shells
diff options
context:
space:
mode:
authorehaupt <ehaupt@FreeBSD.org>2016-10-01 01:19:50 +0800
committerehaupt <ehaupt@FreeBSD.org>2016-10-01 01:19:50 +0800
commitf6c26299353d3a2e088fe6b6b2c894dfe695533f (patch)
treee3288169d49b12b9fd1b848c7828c7cdbc628528 /shells
parente17f4f8ec1fa08d2506d6b4e1f558a2e593c8ce8 (diff)
downloadfreebsd-ports-gnome-f6c26299353d3a2e088fe6b6b2c894dfe695533f.tar.gz
freebsd-ports-gnome-f6c26299353d3a2e088fe6b6b2c894dfe695533f.tar.zst
freebsd-ports-gnome-f6c26299353d3a2e088fe6b6b2c894dfe695533f.zip
Update to 4.4
Differential Revision: https://reviews.freebsd.org/D8085
Diffstat (limited to 'shells')
-rw-r--r--shells/bash/Makefile40
-rw-r--r--shells/bash/distinfo98
-rw-r--r--shells/bash/files/extrapatch-implicitcd95
-rw-r--r--shells/bash/files/extrapatch-import-functions66
-rw-r--r--shells/bash/files/patch-config-top.h6
-rw-r--r--shells/bash/files/patch-doc_Makefile.in14
-rw-r--r--shells/bash/files/patch-doc_bash.18
-rw-r--r--shells/bash/files/patch-doc_bashref.texi8
-rw-r--r--shells/bash/files/patch-lib_readline_display.c10
-rw-r--r--shells/bash/pkg-plist88
10 files changed, 123 insertions, 310 deletions
diff --git a/shells/bash/Makefile b/shells/bash/Makefile
index f36c8b8a8015..c454259983bb 100644
--- a/shells/bash/Makefile
+++ b/shells/bash/Makefile
@@ -2,42 +2,30 @@
# $FreeBSD$
PORTNAME= bash
-PATCHLEVEL= 46
-PORTVERSION= 4.3.${PATCHLEVEL:S/^0//g}
-PORTREVISION?= 1
+PORTVERSION= 4.4
+PORTREVISION?= 0
CATEGORIES= shells
MASTER_SITES= GNU/${PORTNAME}
-DISTNAME= ${PORTNAME}-${PORTVERSION:R}
DIST_SUBDIR= ${PORTNAME}
EXTRACT_ONLY= ${DISTNAME}${EXTRACT_SUFX}
-PATCH_SITES= GNU/${PORTNAME}/${DISTNAME}-patches/ \
- ftp://ftp.cwru.edu/pub/${PORTNAME}/${DISTNAME}-patches/
-PATCHFILES!= /usr/bin/jot -s " " -w \
- ${PORTNAME}${PORTVERSION:R:S/.//g}-%03d \
- ${PATCHLEVEL} 1 ${PATCHLEVEL}
-
MAINTAINER= ehaupt@FreeBSD.org
-COMMENT= The GNU Project's Bourne Again SHell
+COMMENT= GNU Project's Bourne Again SHell
LICENSE= GPLv3
-OPTIONS_DEFINE= IMPLICITCD COLONBREAKSWORDS HELP NLS STATIC SYSLOG DOCS
-OPTIONS_DEFINE+= IMPORTFUNCTIONS
-OPTIONS_DEFAULT= IMPLICITCD COLONBREAKSWORDS HELP
-IMPLICITCD_DESC= Use directory name alone to cd into it
+OPTIONS_DEFINE= COLONBREAKSWORDS HELP NLS STATIC SYSLOG DOCS
COLONBREAKSWORDS_DESC= Colons break words
HELP_DESC= Enable builtin help
-IMPORTFUNCTIONS_DESC= Import function from env without --import-functions
-USES= bison cpe iconv makeinfo
+OPTIONS_DEFAULT= COLONBREAKSWORDS HELP
+
+USES= bison cpe iconv makeinfo pathfix
+GNU_CONFIGURE= yes
OPTIONS_SUB= yes
CPE_VENDOR= gnu
-IMPLICITCD_EXTRA_PATCHES= ${PATCHDIR}/extrapatch-implicitcd
COLONBREAKSWORDS_EXTRA_PATCHES= ${PATCHDIR}/extrapatch-colonbreakswords
-# Always apply this for now. The option will modify the default.
-EXTRA_PATCHES+= ${PATCHDIR}/extrapatch-import-functions
HELP_CONFIGURE_ENABLE= help-builtin
NLS_CONFIGURE_ENABLE= nls
@@ -45,8 +33,6 @@ NLS_USES= gettext
INFO= bash
-GNU_CONFIGURE= yes
-
PORTDOCS= FAQ INTRO CHANGES COMPAT NEWS POSIX RBASH README \
bash.html bashref.html
@@ -55,8 +41,6 @@ CONFIGURE_ARGS+= --without-bash-malloc \
--enable-disabled-builtins \
--with-libiconv-prefix=${ICONV_PREFIX}
-CFLAGS+= -DUSE_MKTEMP=1 -DUSE_MKSTEMP=1
-
.if empty(PKGNAMESUFFIX)
CONFLICTS+= bash-static-[0-9]*
.else
@@ -65,12 +49,6 @@ CONFLICTS+= bash-[0-9]*
.include <bsd.port.options.mk>
-.if ${PORT_OPTIONS:MIMPORTFUNCTIONS}
-CFLAGS+= -DIMPORT_FUNCTIONS_DEF=1
-.else
-CFLAGS+= -DIMPORT_FUNCTIONS_DEF=0
-.endif
-
.if ${PORT_OPTIONS:MSTATIC} || defined(NO_DYNAMICROOT) || (defined(NOSHARED) && ${NOSHARED:tl} != "no")
CONFIGURE_ARGS+= --enable-static-link
.else
@@ -118,7 +96,7 @@ cklatest:
@${ECHO} -n "Currently at: "
@${MAKE} -V PATCHLEVEL
-ncftpls \
- ftp://ftp.gnu.org/gnu/${PORTNAME}/${PORTNAME}-${PORTVERSION:C/\.[0-9a-z]*$//}-patches/ \
+ ftp://ftp.gnu.org/gnu/${PORTNAME}/${PORTNAME}-${PORTVERSION}-patches/ \
| fgrep -v .sig | ${TAIL}
.include <bsd.port.mk>
diff --git a/shells/bash/distinfo b/shells/bash/distinfo
index 539e6055b2f0..32a254443748 100644
--- a/shells/bash/distinfo
+++ b/shells/bash/distinfo
@@ -1,95 +1,3 @@
-TIMESTAMP = 1467096568
-SHA256 (bash/bash-4.3.tar.gz) = afc687a28e0e24dc21b988fa159ff9dbcf6b7caa92ade8645cc6d5605cd024d4
-SIZE (bash/bash-4.3.tar.gz) = 7955839
-SHA256 (bash/bash43-001) = ecb3dff2648667513e31554b3ad054ccd89fce38e33367c9459ac3a285153742
-SIZE (bash/bash43-001) = 1617
-SHA256 (bash/bash43-002) = eee7cd7062ab29a9e4f02924d9c367264dcb8b162703f74ff6eb8f175a91502b
-SIZE (bash/bash43-002) = 1594
-SHA256 (bash/bash43-003) = 000e6eac50cd9053ce0630db01239dcdead04a2c2c351c47e2b51dac1ac1087d
-SIZE (bash/bash43-003) = 1465
-SHA256 (bash/bash43-004) = 5ea0a42c6506720d26e6d3c5c358e9a0d49f6f189d69a8ed34d5935964821338
-SIZE (bash/bash43-004) = 1534
-SHA256 (bash/bash43-005) = 1ac83044032b9f5f11aeca8a344ae3c524ec2156185d3adbb8ad3e7a165aa3fa
-SIZE (bash/bash43-005) = 2636
-SHA256 (bash/bash43-006) = a0648ee72d15e4a90c8b77a5c6b19f8d89e28c1bc881657d22fe26825f040213
-SIZE (bash/bash43-006) = 1445
-SHA256 (bash/bash43-007) = 1113e321c59cf6a8648a36245bbe4217cf8acf948d71e67886dad7d486f8f3a3
-SIZE (bash/bash43-007) = 1331
-SHA256 (bash/bash43-008) = 9941a98a4987192cc5ce3d45afe879983cad2f0bec96d441a4edd9033767f95e
-SIZE (bash/bash43-008) = 4575
-SHA256 (bash/bash43-009) = c0226d6728946b2f53cdebf090bcd1c01627f01fee03295768605caa80bb40a5
-SIZE (bash/bash43-009) = 2413
-SHA256 (bash/bash43-010) = ce05799c0137314c70c7b6ea0477c90e1ac1d52e113344be8e32fa5a55c9f0b7
-SIZE (bash/bash43-010) = 5357
-SHA256 (bash/bash43-011) = 7c63402cdbc004a210f6c1c527b63b13d8bb9ec9c5a43d5c464a9010ff6f7f3b
-SIZE (bash/bash43-011) = 1533
-SHA256 (bash/bash43-012) = 3e1379030b35fbcf314e9e7954538cf4b43be1507142b29efae39eef997b8c12
-SIZE (bash/bash43-012) = 1365
-SHA256 (bash/bash43-013) = bfa8ca5336ab1f5ef988434a4bdedf71604aa8a3659636afa2ce7c7446c42c79
-SIZE (bash/bash43-013) = 2151
-SHA256 (bash/bash43-014) = 5a4d6fa2365b6eb725a9d4966248b5edf7630a4aeb3fa8d526b877972658ac13
-SIZE (bash/bash43-014) = 3533
-SHA256 (bash/bash43-015) = 13293e8a24e003a44d7fe928c6b1e07b444511bed2d9406407e006df28355e8d
-SIZE (bash/bash43-015) = 1894
-SHA256 (bash/bash43-016) = 92d60bcf49f61bd7f1ccb9602bead6f2c9946d79dea0e5ec0589bb3bfa5e0773
-SIZE (bash/bash43-016) = 3674
-SHA256 (bash/bash43-017) = 1267c25c6b5ba57042a7bb6c569a6de02ffd0d29530489a16666c3b8a23e7780
-SIZE (bash/bash43-017) = 1565
-SHA256 (bash/bash43-018) = 7aa8b40a9e973931719d8cc72284a8fb3292b71b522db57a5a79052f021a3d58
-SIZE (bash/bash43-018) = 1315
-SHA256 (bash/bash43-019) = a7a91475228015d676cafa86d2d7aa9c5d2139aa51485b6bbdebfdfbcf0d2d23
-SIZE (bash/bash43-019) = 2610
-SHA256 (bash/bash43-020) = ca5e86d87f178128641fe91f2f094875b8c1eb2de9e0d2e9154f5d5cc0336c98
-SIZE (bash/bash43-020) = 2777
-SHA256 (bash/bash43-021) = 41439f06883e6bd11c591d9d5e9ae08afbc2abd4b935e1d244b08100076520a9
-SIZE (bash/bash43-021) = 1623
-SHA256 (bash/bash43-022) = fd4d47bb95c65863f634c4706c65e1e3bae4ee8460c72045c0a0618689061a88
-SIZE (bash/bash43-022) = 1782
-SHA256 (bash/bash43-023) = 9ac250c7397a8f53dbc84dfe790d2a418fbf1fe090bcece39b4a5c84a2d300d4
-SIZE (bash/bash43-023) = 3414
-SHA256 (bash/bash43-024) = 3b505882a0a6090667d75824fc919524cd44cc3bd89dd08b7c4e622d3f960f6c
-SIZE (bash/bash43-024) = 1909
-SHA256 (bash/bash43-025) = 1e5186f5c4a619bb134a1177d9e9de879f3bb85d9c5726832b03a762a2499251
-SIZE (bash/bash43-025) = 3940
-SHA256 (bash/bash43-026) = 2ecc12201b3ba4273b63af4e9aad2305168cf9babf6d11152796db08724c214d
-SIZE (bash/bash43-026) = 1575
-SHA256 (bash/bash43-027) = 1eb76ad28561d27f7403ff3c76a36e932928a4b58a01b868d663c165f076dabe
-SIZE (bash/bash43-027) = 6889
-SHA256 (bash/bash43-028) = e8b0dbed4724fa7b9bd8ff77d12c7f03da0fbfc5f8251ef5cb8511eb082b469d
-SIZE (bash/bash43-028) = 69606
-SHA256 (bash/bash43-029) = 4cc4a397fe6bc63ecb97d030a4e44258ef2d4e076d0e90c77782968cc43d6292
-SIZE (bash/bash43-029) = 1824
-SHA256 (bash/bash43-030) = 85434f8a2f379d0c49a3ff6d9ffa12c8b157188dd739e556d638217d2a58385b
-SIZE (bash/bash43-030) = 63206
-SHA256 (bash/bash43-031) = cd529f59dd0f2fdd49d619fe34691da6f0affedf87cc37cd460a9f3fe812a61d
-SIZE (bash/bash43-031) = 3689
-SHA256 (bash/bash43-032) = 889357d29a6005b2c3308ca5b6286cb223b5e9c083219e5db3156282dd554f4a
-SIZE (bash/bash43-032) = 1734
-SHA256 (bash/bash43-033) = fb2a7787a13fbe027a7335aca6eb3c21cdbd813e9edc221274b6a9d8692eaa16
-SIZE (bash/bash43-033) = 7038
-SHA256 (bash/bash43-034) = f1694f04f110defe1330a851cc2768e7e57ddd2dfdb0e3e350ca0e3c214ff889
-SIZE (bash/bash43-034) = 2392
-SHA256 (bash/bash43-035) = 370d85e51780036f2386dc18c5efe996eba8e652fc1973f0f4f2ab55a993c1e3
-SIZE (bash/bash43-035) = 1800
-SHA256 (bash/bash43-036) = ac5f82445b36efdb543dbfae64afed63f586d7574b833e9aa9cd5170bc5fd27c
-SIZE (bash/bash43-036) = 1539
-SHA256 (bash/bash43-037) = 33f170dd7400ab3418d749c55c6391b1d161ef2de7aced1873451b3a3fca5813
-SIZE (bash/bash43-037) = 1284
-SHA256 (bash/bash43-038) = adbeaa500ca7a82535f0e88d673661963f8a5fcdc7ad63445e68bf5b49786367
-SIZE (bash/bash43-038) = 2354
-SHA256 (bash/bash43-039) = ab94dced2215541097691f60c3eb323cc28ef2549463e6a5334bbcc1e61e74ec
-SIZE (bash/bash43-039) = 1531
-SHA256 (bash/bash43-040) = 84bb396b9262992ca5424feab6ed3ec39f193ef5c76dfe4a62b551bd8dd9d76b
-SIZE (bash/bash43-040) = 1532
-SHA256 (bash/bash43-041) = 4ec432966e4198524a7e0cd685fe222e96043769c9613e66742ac475db132c1a
-SIZE (bash/bash43-041) = 2362
-SHA256 (bash/bash43-042) = ac219322db2791da87a496ee6e8e5544846494bdaaea2626270c2f73c1044919
-SIZE (bash/bash43-042) = 1535
-SHA256 (bash/bash43-043) = 47a8a3c005b46e25821f4d8f5ccb04c1d653b1c829cb40568d553dc44f7a6180
-SIZE (bash/bash43-043) = 1942
-SHA256 (bash/bash43-044) = 9338820630bf67373b44d8ea68409f65162ea7a47b9b29ace06a0aed12567f99
-SIZE (bash/bash43-044) = 1658
-SHA256 (bash/bash43-045) = ba6ec3978e9eaa1eb3fabdaf3cc6fdf8c4606ac1c599faaeb4e2d69864150023
-SIZE (bash/bash43-045) = 1312
-SHA256 (bash/bash43-046) = b3b456a6b690cd293353f17e22d92a202b3c8bce587ae5f2667c20c9ab6f688f
-SIZE (bash/bash43-046) = 1494
+TIMESTAMP = 1475186489
+SHA256 (bash/bash-4.4.tar.gz) = d86b3392c1202e8ff5a423b302e6284db7f8f435ea9f39b5b1b20fd3ac36dfcb
+SIZE (bash/bash-4.4.tar.gz) = 9377313
diff --git a/shells/bash/files/extrapatch-implicitcd b/shells/bash/files/extrapatch-implicitcd
deleted file mode 100644
index c5a25a2a7603..000000000000
--- a/shells/bash/files/extrapatch-implicitcd
+++ /dev/null
@@ -1,95 +0,0 @@
---- execute_cmd.c.orig 2014-03-02 13:15:12.000000000 -0500
-+++ execute_cmd.c 2014-03-02 13:17:14.000000000 -0500
-@@ -199,6 +199,9 @@
-
- static int execute_intern_function __P((WORD_DESC *, FUNCTION_DEF *));
-
-+/* add an implicit `cd' if the command is the name of a directory */
-+int implicitcd = 0;
-+
- /* Set to 1 if fd 0 was the subject of redirection to a subshell. Global
- so that reader_loop can set it to zero before executing a command. */
- int stdin_redir;
-@@ -4111,6 +4114,20 @@
-
- QUIT;
-
-+ if (implicitcd && interactive_shell && words->next == NULL && func == 0 && builtin == 0)
-+ {
-+ struct stat finfo;
-+
-+ if ((stat (words->word->word, &finfo) == 0) && (S_ISDIR (finfo.st_mode)))
-+ {
-+ this_command_name = "cd";
-+ last_shell_builtin = this_shell_builtin;
-+ this_shell_builtin = builtin_address (this_command_name);
-+ result = (*this_shell_builtin) (words);
-+ goto return_result;
-+ }
-+ }
-+
- /* This command could be a shell builtin or a user-defined function.
- We have already found special builtins by this time, so we do not
- set builtin_is_special. If this is a function or builtin, and we
---- builtins/shopt.def.orig 2014-03-02 13:18:07.000000000 -0500
-+++ builtins/shopt.def 2014-03-02 13:19:22.000000000 -0500
-@@ -83,6 +83,7 @@
- extern int check_window_size;
- extern int glob_ignore_case, match_ignore_case;
- extern int hup_on_exit;
-+extern int implicitcd;
- extern int xpg_echo;
- extern int gnu_error_format;
- extern int check_jobs_at_exit;
-@@ -192,6 +193,7 @@
- { "hostcomplete", &perform_hostname_completion, shopt_enable_hostname_completion },
- #endif
- { "huponexit", &hup_on_exit, (shopt_set_func_t *)NULL },
-+ { "implicitcd", &implicitcd, (shopt_set_func_t *)NULL },
- { "interactive_comments", &interactive_comments, set_shellopts_after_change },
- { "lastpipe", &lastpipe_opt, (shopt_set_func_t *)NULL },
- #if defined (HISTORY)
-@@ -305,6 +307,7 @@
- cdable_vars = mail_warning = 0;
- no_exit_on_failed_exec = print_shift_error = 0;
- check_hashed_filenames = cdspelling = expand_aliases = 0;
-+ implicitcd = 0;
-
- source_uses_path = promptvars = 1;
-
---- doc/bash.1.orig 2014-03-02 13:19:59.000000000 -0500
-+++ doc/bash.1 2014-03-02 13:21:10.000000000 -0500
-@@ -9480,6 +9480,15 @@
- .B SIGHUP
- to all jobs when an interactive login shell exits.
- .TP 8
-+.B implicitcd
-+If this is set, a directory name typed as a command is treated as a
-+request to change to that directory.
-+This behavior is inhibited in non-interactive mode or for command
-+strings with more than one word.
-+Changing directory takes precedence over executing a like-named
-+command, but it is done after alias substitutions.
-+Tilde and variable expansions work as expected.
-+.TP 8
- .B interactive_comments
- If set, allow a word beginning with
- .B #
---- doc/bashref.texi.orig 2014-03-02 13:21:54.000000000 -0500
-+++ doc/bashref.texi 2014-03-02 13:22:31.000000000 -0500
-@@ -5118,6 +5118,15 @@
- If set, Bash will send @code{SIGHUP} to all jobs when an interactive
- login shell exits (@pxref{Signals}).
-
-+@item implicitcd
-+If this is set, a directory name typed as a command is treated as a
-+request to change to that directory.
-+This behavior is inhibited in non-interactive mode or for command
-+strings with more than one word.
-+Changing directory takes precedence over executing a like-named
-+command, but it is done after alias substitutions.
-+Tilde and variable expansions work as expected.
-+
- @item interactive_comments
- Allow a word beginning with @samp{#}
- to cause that word and all remaining characters on that
diff --git a/shells/bash/files/extrapatch-import-functions b/shells/bash/files/extrapatch-import-functions
deleted file mode 100644
index c1ff0dd0f2f0..000000000000
--- a/shells/bash/files/extrapatch-import-functions
+++ /dev/null
@@ -1,66 +0,0 @@
-Based on christos@NetBSD's patch
-
---- shell.c.christos 2014-01-14 08:04:32.000000000 -0500
-+++ shell.c 2014-09-25 16:11:51.000000000 -0400
-@@ -229,6 +229,7 @@
- #else
- int posixly_correct = 0; /* Non-zero means posix.2 superset. */
- #endif
-+int import_functions = IMPORT_FUNCTIONS_DEF; /* Import functions from environment */
-
- /* Some long-winded argument names. These are obviously new. */
- #define Int 1
-@@ -248,6 +249,7 @@
- { "help", Int, &want_initial_help, (char **)0x0 },
- { "init-file", Charp, (int *)0x0, &bashrc_file },
- { "login", Int, &make_login_shell, (char **)0x0 },
-+ { "import-functions", Int, &import_functions, (char **)0x0 },
- { "noediting", Int, &no_line_editing, (char **)0x0 },
- { "noprofile", Int, &no_profile, (char **)0x0 },
- { "norc", Int, &no_rc, (char **)0x0 },
-
---- variables.c.orig 2014-09-28 11:15:53.189768951 -0500
-+++ variables.c 2014-09-28 11:27:07.250722694 -0500
-@@ -110,6 +110,7 @@ extern time_t shell_start_time;
- extern int assigning_in_environment;
- extern int executing_builtin;
- extern int funcnest_max;
-+extern int import_functions;
-
- #if defined (READLINE)
- extern int no_line_editing;
-@@ -328,6 +329,7 @@ initialize_shell_variables (env, privmod
- char *name, *string, *temp_string;
- int c, char_index, string_index, string_length, ro;
- SHELL_VAR *temp_var;
-+ int skipped_import;
-
- create_variable_tables ();
-
-@@ -352,9 +354,12 @@ initialize_shell_variables (env, privmod
-
- temp_var = (SHELL_VAR *)NULL;
-
-+ skipped_import = 0;
-+reval:
-+
- /* If exported function, define it now. Don't import functions from
- the environment in privileged mode. */
-- if (privmode == 0 && read_but_dont_execute == 0 &&
-+ if (skipped_import == 0 && privmode == 0 && read_but_dont_execute == 0 &&
- STREQN (BASHFUNC_PREFIX, name, BASHFUNC_PREFLEN) &&
- STREQ (BASHFUNC_SUFFIX, name + char_index - BASHFUNC_SUFFLEN) &&
- STREQN ("() {", string, 4))
-@@ -367,6 +372,12 @@ initialize_shell_variables (env, privmod
- tname = name + BASHFUNC_PREFLEN; /* start of func name */
- tname[namelen] = '\0'; /* now tname == func name */
-
-+ if (!import_functions && !interactive_shell) {
-+ skipped_import = 1;
-+ report_error (_("Skipping importing function definition for `%s': --import-functions required."), tname);
-+ goto reval;
-+ }
-+
- string_length = strlen (string);
- temp_string = (char *)xmalloc (namelen + string_length + 2);
-
diff --git a/shells/bash/files/patch-config-top.h b/shells/bash/files/patch-config-top.h
index 7ad15c78c59a..08f330f61fb5 100644
--- a/shells/bash/files/patch-config-top.h
+++ b/shells/bash/files/patch-config-top.h
@@ -1,6 +1,6 @@
---- config-top.h.orig 2014-03-02 13:36:24.000000000 -0500
-+++ config-top.h 2014-03-02 13:38:13.000000000 -0500
-@@ -59,18 +59,18 @@
+--- config-top.h.orig 2016-05-19 18:34:02 UTC
++++ config-top.h
+@@ -63,18 +63,18 @@
/* The default value of the PATH variable. */
#ifndef DEFAULT_PATH_VALUE
#define DEFAULT_PATH_VALUE \
diff --git a/shells/bash/files/patch-doc_Makefile.in b/shells/bash/files/patch-doc_Makefile.in
index ef9ff11b4b4d..cb4f37662857 100644
--- a/shells/bash/files/patch-doc_Makefile.in
+++ b/shells/bash/files/patch-doc_Makefile.in
@@ -1,6 +1,6 @@
---- doc/Makefile.in.orig 2014-03-02 13:39:04.000000000 -0500
-+++ doc/Makefile.in 2014-03-02 13:39:56.000000000 -0500
-@@ -167,7 +167,7 @@
+--- doc/Makefile.in.orig 2015-12-07 00:55:56 UTC
++++ doc/Makefile.in
+@@ -175,7 +175,7 @@ pdf: ${PDFFILES}
bashref.dvi: $(BASHREF_FILES) $(HSUSER) $(RLUSER)
${SET_TEXINPUTS} $(TEXI2DVI) $(srcdir)/bashref.texi || { ${RM} $@ ; exit 1; }
@@ -8,14 +8,14 @@
+bash.info: $(BASHREF_FILES) $(HSUSER) $(RLUSER)
$(MAKEINFO) --no-split -I$(TEXINPUTDIR) $(srcdir)/bashref.texi
- # can also use:
-@@ -175,9 +175,6 @@
+ # experimental
+@@ -188,9 +188,6 @@ bashref.pdf: $(BASHREF_FILES) $(HSUSER)
bashref.html: $(BASHREF_FILES) $(HSUSER) $(RLUSER)
- $(TEXI2HTML) -menu -monolithic -I $(TEXINPUTDIR) $(srcdir)/bashref.texi
+ $(MAKEINFO) --html --no-split -I$(TEXINPUTDIR) $(srcdir)/bashref.texi
-bash.info: bashref.info
- ${SHELL} ${INFOPOST} < $(srcdir)/bashref.info > $@ ; \
-
bash.txt: bash.1
bash.ps: bash.1
- bash.html: bash.1 $(MAN2HTML)
+ bash.html: bash.1
diff --git a/shells/bash/files/patch-doc_bash.1 b/shells/bash/files/patch-doc_bash.1
index 7aad7f51aa2f..9fb720f4d0c6 100644
--- a/shells/bash/files/patch-doc_bash.1
+++ b/shells/bash/files/patch-doc_bash.1
@@ -1,6 +1,6 @@
---- doc/bash.1.orig Wed Dec 28 19:44:28 2005
-+++ doc/bash.1 Wed Dec 28 20:03:12 2005
-@@ -1897,7 +1897,7 @@
+--- doc/bash.1.orig 2016-09-29 22:30:30 UTC
++++ doc/bash.1
+@@ -2364,7 +2364,7 @@ The value of this parameter is expanded
.SM
.B PROMPTING
below) and used as the primary prompt string. The default value is
@@ -9,7 +9,7 @@
.TP
.B PS2
The value of this parameter is expanded as with
-@@ -8784,7 +8784,7 @@
+@@ -10556,7 +10556,7 @@ http://tiswww.case.edu/~chet/bash/POSIX
.SH FILES
.PD 0
.TP
diff --git a/shells/bash/files/patch-doc_bashref.texi b/shells/bash/files/patch-doc_bashref.texi
index 65b229afd148..08d80e40a8c9 100644
--- a/shells/bash/files/patch-doc_bashref.texi
+++ b/shells/bash/files/patch-doc_bashref.texi
@@ -1,5 +1,5 @@
---- doc/bashref.texi.orig 2014-03-02 13:40:51.000000000 -0500
-+++ doc/bashref.texi 2014-03-02 13:42:04.000000000 -0500
+--- doc/bashref.texi.orig 2016-09-29 22:30:30 UTC
++++ doc/bashref.texi
@@ -1,6 +1,6 @@
\input texinfo.tex @c -*- texinfo -*-
@c %**start of header
@@ -17,8 +17,8 @@
This is Edition @value{EDITION}, last updated @value{UPDATED},
of @cite{The GNU Bash Reference Manual},
-@@ -5299,7 +5299,7 @@
-
+@@ -5443,7 +5443,7 @@ A null directory name may appear as two
+ or trailing colon.
@item PS1
-The primary prompt string. The default value is @samp{\s-\v\$ }.
diff --git a/shells/bash/files/patch-lib_readline_display.c b/shells/bash/files/patch-lib_readline_display.c
index f05f78b72c7d..f057294bc669 100644
--- a/shells/bash/files/patch-lib_readline_display.c
+++ b/shells/bash/files/patch-lib_readline_display.c
@@ -1,11 +1,13 @@
---- lib/readline/display.c.orig 2009-01-04 11:32:32.000000000 -0800
-+++ lib/readline/display.c 2009-03-08 00:51:31.000000000 -0800
-@@ -654,5 +654,8 @@ rl_redisplay ()
- /* inv_lbreaks[i] is where line i starts in the buffer. */
+--- lib/readline/display.c.orig 2016-07-28 18:49:33 UTC
++++ lib/readline/display.c
+@@ -743,7 +743,10 @@ rl_redisplay ()
inv_lbreaks[newlines = 0] = 0;
+ /* lpos is a physical cursor position, so it needs to be adjusted by the
+ number of invisible characters in the prompt, per line */
+ if (local_prompt)
lpos = prompt_physical_chars + modmark;
+ else
+ lpos = 0;
#if defined (HANDLE_MULTIBYTE)
+ memset (line_state_invisible->wrapped_line, 0, line_state_invisible->wbsize * sizeof (int));
diff --git a/shells/bash/pkg-plist b/shells/bash/pkg-plist
index 51cec11e48e3..1025c96f964a 100644
--- a/shells/bash/pkg-plist
+++ b/shells/bash/pkg-plist
@@ -1,6 +1,91 @@
@shell bin/bash
@shell bin/rbash
bin/bashbug
+%%NO_STATIC%%include/bash/alias.h
+%%NO_STATIC%%include/bash/array.h
+%%NO_STATIC%%include/bash/arrayfunc.h
+%%NO_STATIC%%include/bash/assoc.h
+%%NO_STATIC%%include/bash/bashansi.h
+%%NO_STATIC%%include/bash/bashintl.h
+%%NO_STATIC%%include/bash/bashjmp.h
+%%NO_STATIC%%include/bash/bashtypes.h
+%%NO_STATIC%%include/bash/builtins.h
+%%NO_STATIC%%include/bash/builtins/bashgetopt.h
+%%NO_STATIC%%include/bash/builtins/builtext.h
+%%NO_STATIC%%include/bash/builtins/common.h
+%%NO_STATIC%%include/bash/builtins/getopt.h
+%%NO_STATIC%%include/bash/command.h
+%%NO_STATIC%%include/bash/config-bot.h
+%%NO_STATIC%%include/bash/config-top.h
+%%NO_STATIC%%include/bash/config.h
+%%NO_STATIC%%include/bash/conftypes.h
+%%NO_STATIC%%include/bash/dispose_cmd.h
+%%NO_STATIC%%include/bash/error.h
+%%NO_STATIC%%include/bash/externs.h
+%%NO_STATIC%%include/bash/general.h
+%%NO_STATIC%%include/bash/hashlib.h
+%%NO_STATIC%%include/bash/include/ansi_stdlib.h
+%%NO_STATIC%%include/bash/include/chartypes.h
+%%NO_STATIC%%include/bash/include/filecntl.h
+%%NO_STATIC%%include/bash/include/gettext.h
+%%NO_STATIC%%include/bash/include/maxpath.h
+%%NO_STATIC%%include/bash/include/memalloc.h
+%%NO_STATIC%%include/bash/include/ocache.h
+%%NO_STATIC%%include/bash/include/posixdir.h
+%%NO_STATIC%%include/bash/include/posixjmp.h
+%%NO_STATIC%%include/bash/include/posixstat.h
+%%NO_STATIC%%include/bash/include/posixtime.h
+%%NO_STATIC%%include/bash/include/posixwait.h
+%%NO_STATIC%%include/bash/include/shmbchar.h
+%%NO_STATIC%%include/bash/include/shmbutil.h
+%%NO_STATIC%%include/bash/include/shtty.h
+%%NO_STATIC%%include/bash/include/stat-time.h
+%%NO_STATIC%%include/bash/include/stdc.h
+%%NO_STATIC%%include/bash/include/systimes.h
+%%NO_STATIC%%include/bash/include/typemax.h
+%%NO_STATIC%%include/bash/include/unionwait.h
+%%NO_STATIC%%include/bash/jobs.h
+%%NO_STATIC%%include/bash/make_cmd.h
+%%NO_STATIC%%include/bash/pathnames.h
+%%NO_STATIC%%include/bash/quit.h
+%%NO_STATIC%%include/bash/shell.h
+%%NO_STATIC%%include/bash/sig.h
+%%NO_STATIC%%include/bash/siglist.h
+%%NO_STATIC%%include/bash/signames.h
+%%NO_STATIC%%include/bash/subst.h
+%%NO_STATIC%%include/bash/syntax.h
+%%NO_STATIC%%include/bash/unwind_prot.h
+%%NO_STATIC%%include/bash/variables.h
+%%NO_STATIC%%include/bash/version.h
+%%NO_STATIC%%include/bash/xmalloc.h
+%%NO_STATIC%%include/bash/y.tab.h
+%%NO_STATIC%%lib/bash/Makefile.inc
+%%NO_STATIC%%lib/bash/basename
+%%NO_STATIC%%lib/bash/dirname
+%%NO_STATIC%%lib/bash/finfo
+%%NO_STATIC%%lib/bash/head
+%%NO_STATIC%%lib/bash/id
+%%NO_STATIC%%lib/bash/ln
+%%NO_STATIC%%lib/bash/logname
+%%NO_STATIC%%lib/bash/mkdir
+%%NO_STATIC%%lib/bash/mypid
+%%NO_STATIC%%lib/bash/pathchk
+%%NO_STATIC%%lib/bash/print
+%%NO_STATIC%%lib/bash/printenv
+%%NO_STATIC%%lib/bash/push
+%%NO_STATIC%%lib/bash/realpath
+%%NO_STATIC%%lib/bash/rmdir
+%%NO_STATIC%%lib/bash/setpgid
+%%NO_STATIC%%lib/bash/sleep
+%%NO_STATIC%%lib/bash/strftime
+%%NO_STATIC%%lib/bash/sync
+%%NO_STATIC%%lib/bash/tee
+%%NO_STATIC%%lib/bash/truefalse
+%%NO_STATIC%%lib/bash/tty
+%%NO_STATIC%%lib/bash/uname
+%%NO_STATIC%%lib/bash/unlink
+%%NO_STATIC%%lib/bash/whoami
+%%NO_STATIC%%libdata/pkgconfig/bash.pc
man/man1/bash.1.gz
man/man1/bashbug.1.gz
%%NLS%%share/locale/af/LC_MESSAGES/bash.mo
@@ -19,12 +104,13 @@ man/man1/bashbug.1.gz
%%NLS%%share/locale/fr/LC_MESSAGES/bash.mo
%%NLS%%share/locale/ga/LC_MESSAGES/bash.mo
%%NLS%%share/locale/gl/LC_MESSAGES/bash.mo
-%%NLS%%share/locale/hu/LC_MESSAGES/bash.mo
%%NLS%%share/locale/hr/LC_MESSAGES/bash.mo
+%%NLS%%share/locale/hu/LC_MESSAGES/bash.mo
%%NLS%%share/locale/id/LC_MESSAGES/bash.mo
%%NLS%%share/locale/it/LC_MESSAGES/bash.mo
%%NLS%%share/locale/ja/LC_MESSAGES/bash.mo
%%NLS%%share/locale/lt/LC_MESSAGES/bash.mo
+%%NLS%%share/locale/nb/LC_MESSAGES/bash.mo
%%NLS%%share/locale/nl/LC_MESSAGES/bash.mo
%%NLS%%share/locale/pl/LC_MESSAGES/bash.mo
%%NLS%%share/locale/pt_BR/LC_MESSAGES/bash.mo