aboutsummaryrefslogtreecommitdiffstats
path: root/shells
diff options
context:
space:
mode:
authorflz <flz@FreeBSD.org>2005-12-05 18:51:29 +0800
committerflz <flz@FreeBSD.org>2005-12-05 18:51:29 +0800
commit7069354a34915d3f6f76b1ed63ad29b248a589ce (patch)
tree4520f42ecbc2fcf65806cc2aa60435367c5aa850 /shells
parentbc9353d05cf4aa92124df86c5ca933bb252dde81 (diff)
downloadfreebsd-ports-gnome-7069354a34915d3f6f76b1ed63ad29b248a589ce.tar.gz
freebsd-ports-gnome-7069354a34915d3f6f76b1ed63ad29b248a589ce.tar.zst
freebsd-ports-gnome-7069354a34915d3f6f76b1ed63ad29b248a589ce.zip
- Rename WANT_STATIC_BASH to WITH_STATIC_BASH to respect ports semantics.
PR: ports/89772 Submitted by: flz Approved by: maintainer
Diffstat (limited to 'shells')
-rw-r--r--shells/bash/Makefile2
-rw-r--r--shells/bash2/Makefile2
2 files changed, 2 insertions, 2 deletions
diff --git a/shells/bash/Makefile b/shells/bash/Makefile
index f390fc18e339..0551848c7c70 100644
--- a/shells/bash/Makefile
+++ b/shells/bash/Makefile
@@ -56,7 +56,7 @@ CONFIGURE_ARGS= --without-bash-malloc \
--disable-rpath \
--enable-disabled-builtins
-.if defined(WANT_STATIC_BASH) || defined(NO_DYNAMICROOT) || (defined(NOSHARED) && ${NOSHARED:L} != "no")
+.if defined(WITH_STATIC_BASH) || defined(NO_DYNAMICROOT) || (defined(NOSHARED) && ${NOSHARED:L} != "no")
.if !defined(WITHOUT_NLS)
WITHOUT_NLS=yes
.endif
diff --git a/shells/bash2/Makefile b/shells/bash2/Makefile
index 3246b25eab0b..66670090271c 100644
--- a/shells/bash2/Makefile
+++ b/shells/bash2/Makefile
@@ -36,7 +36,7 @@ USE_REINPLACE= yes
WRKSRC= ${WRKDIR}/bash-${PORTVERSION:C/\....$//}
GNU_CONFIGURE= Yes
CONFIGURE_ARGS= --with-installed-readline
-.if defined(WANT_STATIC_BASH) || defined(NO_DYNAMICROOT) || (defined(NOSHARED) && ( ${NOSHARED} != "no" && ${NOSHARED} != "NO" ))
+.if defined(WITH_STATIC_BASH) || defined(NO_DYNAMICROOT) || (defined(NOSHARED) && ( ${NOSHARED} != "no" && ${NOSHARED} != "NO" ))
CONFIGURE_ARGS+= --enable-static-link
.else
CONFIGURE_ARGS+= --enable-static-link=no