aboutsummaryrefslogtreecommitdiffstats
path: root/shells
diff options
context:
space:
mode:
authorvanilla <vanilla@FreeBSD.org>2013-11-06 15:44:16 +0800
committervanilla <vanilla@FreeBSD.org>2013-11-06 15:44:16 +0800
commit8d7a2b88bc857c177037f30fab4075504f9fdcbd (patch)
tree47dfe91ce664958a4511a2423e472f0750ac6729 /shells
parent7fb543c298149cb9d940d523a29c3b16c24fb013 (diff)
downloadfreebsd-ports-gnome-8d7a2b88bc857c177037f30fab4075504f9fdcbd.tar.gz
freebsd-ports-gnome-8d7a2b88bc857c177037f30fab4075504f9fdcbd.tar.zst
freebsd-ports-gnome-8d7a2b88bc857c177037f30fab4075504f9fdcbd.zip
Support STAGEDIR.
Diffstat (limited to 'shells')
-rw-r--r--shells/p5-Term-ShellUI/Makefile10
-rw-r--r--shells/p5-Term-ShellUI/pkg-plist6
2 files changed, 7 insertions, 9 deletions
diff --git a/shells/p5-Term-ShellUI/Makefile b/shells/p5-Term-ShellUI/Makefile
index a13bd15ec12c..db390e47a40a 100644
--- a/shells/p5-Term-ShellUI/Makefile
+++ b/shells/p5-Term-ShellUI/Makefile
@@ -12,21 +12,17 @@ MAINTAINER= perl@FreeBSD.org
COMMENT= Fully-featured shell-like command line environment
BUILD_DEPENDS= p5-ReadLine-Gnu>=0:${PORTSDIR}/devel/p5-ReadLine-Gnu
-RUN_DEPENDS= p5-ReadLine-Gnu>=0:${PORTSDIR}/devel/p5-ReadLine-Gnu
+RUN_DEPENDS:= ${BUILD_DEPENDS}
USES= perl5
USE_PERL5= configure
-MAN3= Term::ShellUI.3 \
- Text::Shellwords::Cursor.3
-
-NO_STAGE= yes
post-install:
.if !defined(NOPORTEXAMPLES)
- @${MKDIR} ${EXAMPLESDIR}/
+ @${MKDIR} ${STAGEDIR}${EXAMPLESDIR}/
@${ECHO_MSG} "===> Installing examples for ${PKGNAME}"
cd ${WRKSRC}/examples/ && ${INSTALL_SCRIPT} \
- fileman-example synopsis synopsis-big tui-sample ${EXAMPLESDIR}/
+ fileman-example synopsis synopsis-big tui-sample ${STAGEDIR}${EXAMPLESDIR}/
.endif
.include <bsd.port.mk>
diff --git a/shells/p5-Term-ShellUI/pkg-plist b/shells/p5-Term-ShellUI/pkg-plist
index 879f43135bd0..45dae0409f09 100644
--- a/shells/p5-Term-ShellUI/pkg-plist
+++ b/shells/p5-Term-ShellUI/pkg-plist
@@ -1,3 +1,5 @@
+%%PERL5_MAN3%%/Term::ShellUI.3.gz
+%%PERL5_MAN3%%/Text::Shellwords::Cursor.3.gz
%%SITE_PERL%%/Term/ShellUI.pm
%%SITE_PERL%%/Text/Shellwords/Cursor.pm
%%SITE_PERL%%/%%PERL_ARCH%%/auto/Term/ShellUI/.packlist
@@ -5,8 +7,8 @@
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/synopsis
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/synopsis-big
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/tui-sample
-%%PORTEXAMPLES%%@dirrm %%EXAMPLESDIR%%
-@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/Term/ShellUI
+%%PORTEXAMPLES%%@dirrmtry %%EXAMPLESDIR%%
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Term/ShellUI
@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Term
@dirrmtry %%SITE_PERL%%/Text/Shellwords
@dirrmtry %%SITE_PERL%%/Text