aboutsummaryrefslogtreecommitdiffstats
path: root/shells
diff options
context:
space:
mode:
authoredwin <edwin@FreeBSD.org>2003-03-30 12:43:13 +0800
committeredwin <edwin@FreeBSD.org>2003-03-30 12:43:13 +0800
commit1040c61a9876bbb3f92602781d6a964b1e07f00f (patch)
tree5058ec62846ffe3011e075a76b4c1e9bdb3914be /shells
parent86a85bdf604898888c89e8f3e15930fae334f8d9 (diff)
downloadfreebsd-ports-gnome-1040c61a9876bbb3f92602781d6a964b1e07f00f.tar.gz
freebsd-ports-gnome-1040c61a9876bbb3f92602781d6a964b1e07f00f.tar.zst
freebsd-ports-gnome-1040c61a9876bbb3f92602781d6a964b1e07f00f.zip
update shells/rc to version 1.7, with readline
PR: ports/48843 Submitted by: Scott Kenney <saken@hotel.rmta.org>
Diffstat (limited to 'shells')
-rw-r--r--shells/rc/Makefile9
-rw-r--r--shells/rc/distinfo2
-rw-r--r--shells/rc/files/patch-aa11
3 files changed, 9 insertions, 13 deletions
diff --git a/shells/rc/Makefile b/shells/rc/Makefile
index 1bb651984cf7..62209feb1346 100644
--- a/shells/rc/Makefile
+++ b/shells/rc/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= rc
-PORTVERSION= 1.6
+PORTVERSION= 1.7
CATEGORIES= shells plan9
MASTER_SITES= http://www.star.le.ac.uk/~tjg/rc/release/ \
ftp://ftp.sys.utoronto.ca/pub/rc/
@@ -14,6 +14,13 @@ MASTER_SITES= http://www.star.le.ac.uk/~tjg/rc/release/ \
MAINTAINER= saken@hotel.rmta.org
COMMENT= A unix incarnation of the plan9 shell
+.if defined(WITH_READLINE)
+CONFIGURE_ARGS+= --with-readline
+.endif
+.if !defined(WITH_READLINE)
+MAKE_ARGS+= CFLAGS="$(CFLAGS) -static"
+.endif
+
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --with-history
MAN1= history.1 rc.1
diff --git a/shells/rc/distinfo b/shells/rc/distinfo
index 312becf7868f..97207d4c07c8 100644
--- a/shells/rc/distinfo
+++ b/shells/rc/distinfo
@@ -1 +1 @@
-MD5 (rc-1.6.tar.gz) = 3b56f0e47e8496ea0363ebc202bcac23
+MD5 (rc-1.7.tar.gz) = 657bb1c1a9aad8c46218185414539293
diff --git a/shells/rc/files/patch-aa b/shells/rc/files/patch-aa
deleted file mode 100644
index aeb20f1f642c..000000000000
--- a/shells/rc/files/patch-aa
+++ /dev/null
@@ -1,11 +0,0 @@
---- Makefile.in.orig Fri Jun 25 10:04:52 1999
-+++ Makefile.in Fri Jun 25 10:05:07 1999
-@@ -109,7 +109,7 @@
- glom.o hash.o heredoc.o input.o lex.o list.o main.o match.o nalloc.o \
- open.o parse.o print.o redir.o signal.o status.o tree.o utils.o var.o \
- wait.o walk.o which.o
--rc_LDFLAGS =
-+rc_LDFLAGS = -static
- mksignal_SOURCES = mksignal.c
- mksignal_OBJECTS = mksignal.o
- mksignal_LDADD = $(LDADD)