aboutsummaryrefslogtreecommitdiffstats
path: root/shells
diff options
context:
space:
mode:
authorbapt <bapt@FreeBSD.org>2016-12-18 20:13:31 +0800
committerbapt <bapt@FreeBSD.org>2016-12-18 20:13:31 +0800
commit0b2bed1670cbb828832e95c054c663015b59ea7e (patch)
treeb8dc7879e5396e953d4a0c8817bf4864a931a93c /shells
parent9389e14b1c4a3a51212be89a4939e420d78d1520 (diff)
downloadfreebsd-ports-gnome-0b2bed1670cbb828832e95c054c663015b59ea7e.tar.gz
freebsd-ports-gnome-0b2bed1670cbb828832e95c054c663015b59ea7e.tar.zst
freebsd-ports-gnome-0b2bed1670cbb828832e95c054c663015b59ea7e.zip
Fix typo in chflags completion
Reported by: adamw
Diffstat (limited to 'shells')
-rw-r--r--shells/zsh/Makefile1
-rw-r--r--shells/zsh/files/patch-Completion_BSD_Command___chflags11
2 files changed, 12 insertions, 0 deletions
diff --git a/shells/zsh/Makefile b/shells/zsh/Makefile
index 2bc60e352513..432a4d869279 100644
--- a/shells/zsh/Makefile
+++ b/shells/zsh/Makefile
@@ -3,6 +3,7 @@
PORTNAME= zsh
DISTVERSION= 5.3
+PORTREVISION= 1
CATEGORIES= shells
MASTER_SITES= http://www.zsh.org/pub/ \
SF \
diff --git a/shells/zsh/files/patch-Completion_BSD_Command___chflags b/shells/zsh/files/patch-Completion_BSD_Command___chflags
new file mode 100644
index 000000000000..801c8e6ddcc6
--- /dev/null
+++ b/shells/zsh/files/patch-Completion_BSD_Command___chflags
@@ -0,0 +1,11 @@
+--- Completion/BSD/Command/_chflags.orig 2016-09-14 19:06:59 UTC
++++ Completion/BSD/Command/_chflags
+@@ -35,7 +35,7 @@ if [[ $OSTYPE = (darwin|dragonfly|freebs
+ fi
+
+ if [[ $OSTYPE = (dragonfly|freebsd)* ]]; then
+- addlfags uunlnk 'user undeletable'
++ addflags uunlnk 'user undeletable'
+ (( EUID )) || addflags sunlnk 'system undeletable'
+ fi
+