aboutsummaryrefslogtreecommitdiffstats
path: root/shells
diff options
context:
space:
mode:
authorobrien <obrien@FreeBSD.org>2011-04-07 01:47:52 +0800
committerobrien <obrien@FreeBSD.org>2011-04-07 01:47:52 +0800
commit3d83da3fd7d2c101d5ace4c1fe27ba196a93a84c (patch)
tree0e940cfac5b8e3a2a9de37c620b421c3bac6cc4c /shells
parent36ef0b8f67e8847157e6d584203fd96b307eca8f (diff)
downloadfreebsd-ports-gnome-3d83da3fd7d2c101d5ace4c1fe27ba196a93a84c.tar.gz
freebsd-ports-gnome-3d83da3fd7d2c101d5ace4c1fe27ba196a93a84c.tar.zst
freebsd-ports-gnome-3d83da3fd7d2c101d5ace4c1fe27ba196a93a84c.zip
Add option to log user history to syslog.
PR: 155780 Submitted by: Alexander Kriventsov <avk@vl.ru>
Diffstat (limited to 'shells')
-rw-r--r--shells/bash/Makefile5
-rw-r--r--shells/bash/options3
2 files changed, 7 insertions, 1 deletions
diff --git a/shells/bash/Makefile b/shells/bash/Makefile
index 40505bdd7926..6a8fd5348672 100644
--- a/shells/bash/Makefile
+++ b/shells/bash/Makefile
@@ -104,6 +104,11 @@ CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS}" \
post-patch:
@${REINPLACE_CMD} -e "s|%%PREFIX%%|${PREFIX}|g" ${WRKSRC}/doc/bash.1
+.if defined(WITH_SYSLOG)
+ @${REINPLACE_CMD} \
+ -e "s|/\*.*#define SYSLOG_HISTORY .*\*/|#define SYSLOG_HISTORY|g" \
+ ${WRKSRC}/config-top.h
+.endif
.if defined(WITHOUT_NLS)
@${REINPLACE_CMD} -e "s|@LIBICONV@||g" ${WRKSRC}/Makefile.in
.endif
diff --git a/shells/bash/options b/shells/bash/options
index 5fb109a83dd5..e470ed66b4cd 100644
--- a/shells/bash/options
+++ b/shells/bash/options
@@ -3,4 +3,5 @@ OPTIONS= IMPLICITCD "Use directory name alone to cd into it" on \
HELP "Install the help files" on \
INST_READL "Use readline from base, otherwise bash's" on \
NLS "National Language Support" on \
- STATIC_BASH "Compile without shared libs" off
+ STATIC_BASH "Compile without shared libs" off \
+ SYSLOG "Compile with syslog support" off