aboutsummaryrefslogtreecommitdiffstats
path: root/shells
diff options
context:
space:
mode:
authorume <ume@FreeBSD.org>2009-05-17 13:12:36 +0800
committerume <ume@FreeBSD.org>2009-05-17 13:12:36 +0800
commit84a04374e69a0fb7dad14892e9df5266751527fb (patch)
treedf2643adb17a3b34f663e135776bb24c7ebf7d8c /shells
parentda2c222b784a9450d5d3c4c742cdd90db5550e85 (diff)
downloadfreebsd-ports-gnome-84a04374e69a0fb7dad14892e9df5266751527fb.tar.gz
freebsd-ports-gnome-84a04374e69a0fb7dad14892e9df5266751527fb.tar.zst
freebsd-ports-gnome-84a04374e69a0fb7dad14892e9df5266751527fb.zip
Add an option to enable GDBM support.
PR: ports/134585 Submitted by: ume Approved by: des (maintainer)
Diffstat (limited to 'shells')
-rw-r--r--shells/zsh/Makefile13
-rw-r--r--shells/zsh/pkg-plist2
2 files changed, 13 insertions, 2 deletions
diff --git a/shells/zsh/Makefile b/shells/zsh/Makefile
index 36fd4db9d325..487d2cabf214 100644
--- a/shells/zsh/Makefile
+++ b/shells/zsh/Makefile
@@ -7,7 +7,7 @@
PORTNAME= zsh
PORTVERSION= 4.3.9
-PORTREVISION= 5
+PORTREVISION= 6
CATEGORIES= shells
MASTER_SITES= SF
.if !defined(NOPORTDOCS)
@@ -32,7 +32,8 @@ CONFIGURE_ARGS= --with-term-lib="ncursesw ncurses" --with-tcsetpgrp \
EXTRA_PATCHES= ${FILESDIR}/extra-patch-bsdtar
-OPTIONS= ZSH_MEM "Enable zsh-mem and zsh-secure-free options" on \
+OPTIONS= ZSH_GDBM "Enable GDBM support" off \
+ ZSH_MEM "Enable zsh-mem and zsh-secure-free options" on \
ZSH_MAILDIR "Enable support for Maildirs in MAIL(PATH)" on \
ZSH_MULTIBYTE "Enable multibyte character support" on \
ZSH_PCRE "Enable PCRE support" off \
@@ -52,6 +53,14 @@ SHELLS= /etc/shells
.include <bsd.port.pre.mk>
+.if defined(WITH_ZSH_GDBM)
+LIB_DEPENDS+= gdbm.3:${PORTSDIR}/databases/gdbm
+PLIST_SUB+= GDBM=""
+.else
+CONFIGURE_ARGS+= --disable-gdbm
+PLIST_SUB+= GDBM="@comment "
+.endif
+
.if defined(WITH_ZSH_PCRE)
CONFIGURE_ARGS+= --enable-pcre
LIB_DEPENDS+= pcre.0:${PORTSDIR}/devel/pcre
diff --git a/shells/zsh/pkg-plist b/shells/zsh/pkg-plist
index 6d6a4dacc93b..44bc340769d2 100644
--- a/shells/zsh/pkg-plist
+++ b/shells/zsh/pkg-plist
@@ -14,6 +14,7 @@ bin/zsh-%%ZSH_VER%%
%%SHARED%%lib/zsh/%%ZSH_VER%%/zsh/computil.so
%%SHARED%%lib/zsh/%%ZSH_VER%%/zsh/curses.so
%%SHARED%%lib/zsh/%%ZSH_VER%%/zsh/datetime.so
+%%GDBM%%%%SHARED%%lib/zsh/%%ZSH_VER%%/zsh/db/gdbm.so
%%SHARED%%lib/zsh/%%ZSH_VER%%/zsh/deltochar.so
%%SHARED%%lib/zsh/%%ZSH_VER%%/zsh/example.so
%%SHARED%%lib/zsh/%%ZSH_VER%%/zsh/files.so
@@ -39,6 +40,7 @@ bin/zsh-%%ZSH_VER%%
%%SHARED%%lib/zsh/%%ZSH_VER%%/zsh/zpty.so
%%SHARED%%lib/zsh/%%ZSH_VER%%/zsh/zselect.so
%%SHARED%%lib/zsh/%%ZSH_VER%%/zsh/zutil.so
+%%GDBM%%%%SHARED%%@dirrm lib/zsh/%%ZSH_VER%%/zsh/db
%%SHARED%%@dirrm lib/zsh/%%ZSH_VER%%/zsh/net
%%SHARED%%@dirrm lib/zsh/%%ZSH_VER%%/zsh
%%SHARED%%@dirrm lib/zsh/%%ZSH_VER%%