aboutsummaryrefslogtreecommitdiffstats
path: root/shells
diff options
context:
space:
mode:
authorkris <kris@FreeBSD.org>2002-05-18 10:59:03 +0800
committerkris <kris@FreeBSD.org>2002-05-18 10:59:03 +0800
commit030f49a304fb565b0e4decace3eed57384e64b99 (patch)
tree87557c187f7a7e9bdc9deb897935f07ee33797c8 /shells
parente2a234b5abc9e22e40c205963762a87e3a21ea86 (diff)
downloadfreebsd-ports-gnome-030f49a304fb565b0e4decace3eed57384e64b99.tar.gz
freebsd-ports-gnome-030f49a304fb565b0e4decace3eed57384e64b99.tar.zst
freebsd-ports-gnome-030f49a304fb565b0e4decace3eed57384e64b99.zip
Move a pre-everything target which displays a message and exits to
a FORBIDDEN tag.
Diffstat (limited to 'shells')
-rw-r--r--shells/zsh-devel/Makefile8
1 files changed, 2 insertions, 6 deletions
diff --git a/shells/zsh-devel/Makefile b/shells/zsh-devel/Makefile
index 6e09fc5f5ad5..895f550497f2 100644
--- a/shells/zsh-devel/Makefile
+++ b/shells/zsh-devel/Makefile
@@ -25,6 +25,8 @@ EXTRACT_ONLY= ${DISTNAME}${EXTRACT_SUFX}
MAINTAINER= shige@FreeBSD.org
+FORBIDDEN= "The main zsh port (ports/shells/zsh) has been upgraded to 4.x. It is highly advised that you use that port instead of this one"
+
USE_AUTOCONF= yes
ZSH_VER= ${PORTVERSION}
@@ -39,12 +41,6 @@ MAN1= zsh.1 zshbuiltins.1 zshcompctl.1 zshexpn.1 zshmisc.1 \
zshzftpsys.1 zshcompsys.1 zshcompwid.1
PLIST_SUB= ZSH_VER="${ZSH_VER}" ZSHFUNC_SUBDIR="${ZSHFUNC_SUBDIR}"
-pre-everything::
- @${ECHO} "The main zsh port (ports/shells/zsh) has been upgraded"
- @${ECHO} "to 4.0.1. It is highly advised that you use that port"
- @${ECHO} "instead of this one."
- @${FALSE}
-
# If you want to build a static binary, uncomment the following line
#LDFLAGS+=-static