aboutsummaryrefslogtreecommitdiffstats
path: root/shells
diff options
context:
space:
mode:
authorobrien <obrien@FreeBSD.org>2003-12-14 15:05:40 +0800
committerobrien <obrien@FreeBSD.org>2003-12-14 15:05:40 +0800
commit7eea08bcc7c3ff4c7a2be187eaf94a3b7461d7cb (patch)
tree76afa7c529f67f93e9275b15cfc7f9f1e4495a36 /shells
parent528c0f0349c5b7fb4ace7d7ec785e7d163d4f6f1 (diff)
downloadfreebsd-ports-gnome-7eea08bcc7c3ff4c7a2be187eaf94a3b7461d7cb.tar.gz
freebsd-ports-gnome-7eea08bcc7c3ff4c7a2be187eaf94a3b7461d7cb.tar.zst
freebsd-ports-gnome-7eea08bcc7c3ff4c7a2be187eaf94a3b7461d7cb.zip
Build bash dynamic unless either WANT_STATIC_BASH or NO_DYNAMICROOT
is defined.
Diffstat (limited to 'shells')
-rw-r--r--shells/bash/Makefile4
-rw-r--r--shells/bash2/Makefile4
-rw-r--r--shells/bash3/Makefile4
3 files changed, 12 insertions, 0 deletions
diff --git a/shells/bash/Makefile b/shells/bash/Makefile
index 32dff6b99482..2393c82f1f86 100644
--- a/shells/bash/Makefile
+++ b/shells/bash/Makefile
@@ -34,7 +34,11 @@ COMMENT= The GNU Bourne Again Shell
WRKSRC= ${WRKDIR}/bash-${PORTVERSION:C/\....$//}
GNU_CONFIGURE= Yes
CONFIGURE_ARGS= --with-installed-readline
+.if defined(WANT_STATIC_BASH) || defined(NO_DYNAMICROOT)
CONFIGURE_ENV= LDFLAGS=-static
+.else
+CONFIGURE_ARGS+= --enable-static-link=no
+.endif
MAN1= bash.1 bashbug.1
.if defined(WITH_NET_REDIRECTIONS)
diff --git a/shells/bash2/Makefile b/shells/bash2/Makefile
index 32dff6b99482..2393c82f1f86 100644
--- a/shells/bash2/Makefile
+++ b/shells/bash2/Makefile
@@ -34,7 +34,11 @@ COMMENT= The GNU Bourne Again Shell
WRKSRC= ${WRKDIR}/bash-${PORTVERSION:C/\....$//}
GNU_CONFIGURE= Yes
CONFIGURE_ARGS= --with-installed-readline
+.if defined(WANT_STATIC_BASH) || defined(NO_DYNAMICROOT)
CONFIGURE_ENV= LDFLAGS=-static
+.else
+CONFIGURE_ARGS+= --enable-static-link=no
+.endif
MAN1= bash.1 bashbug.1
.if defined(WITH_NET_REDIRECTIONS)
diff --git a/shells/bash3/Makefile b/shells/bash3/Makefile
index 32dff6b99482..2393c82f1f86 100644
--- a/shells/bash3/Makefile
+++ b/shells/bash3/Makefile
@@ -34,7 +34,11 @@ COMMENT= The GNU Bourne Again Shell
WRKSRC= ${WRKDIR}/bash-${PORTVERSION:C/\....$//}
GNU_CONFIGURE= Yes
CONFIGURE_ARGS= --with-installed-readline
+.if defined(WANT_STATIC_BASH) || defined(NO_DYNAMICROOT)
CONFIGURE_ENV= LDFLAGS=-static
+.else
+CONFIGURE_ARGS+= --enable-static-link=no
+.endif
MAN1= bash.1 bashbug.1
.if defined(WITH_NET_REDIRECTIONS)