aboutsummaryrefslogtreecommitdiffstats
path: root/shells
diff options
context:
space:
mode:
authorobrien <obrien@FreeBSD.org>2003-03-25 02:57:50 +0800
committerobrien <obrien@FreeBSD.org>2003-03-25 02:57:50 +0800
commit9c22afc8e0aefe123ba817f1b0a9fc95fb7d4043 (patch)
treee94b81e29d9db766c0f28d1d6a604780e12589ad /shells
parent1a72ae64316df98e16ae1181ec42d12fa3f47c13 (diff)
downloadfreebsd-ports-gnome-9c22afc8e0aefe123ba817f1b0a9fc95fb7d4043.tar.gz
freebsd-ports-gnome-9c22afc8e0aefe123ba817f1b0a9fc95fb7d4043.tar.zst
freebsd-ports-gnome-9c22afc8e0aefe123ba817f1b0a9fc95fb7d4043.zip
Support /dev/(tcp|udp)/host/port redirection.
Submitted by: David Yeske <dyeske@yahoo.com>
Diffstat (limited to 'shells')
-rw-r--r--shells/bash/Makefile9
-rw-r--r--shells/bash2/Makefile9
-rw-r--r--shells/bash3/Makefile9
3 files changed, 27 insertions, 0 deletions
diff --git a/shells/bash/Makefile b/shells/bash/Makefile
index 9ffdd87f3520..ae6f97ca9ef1 100644
--- a/shells/bash/Makefile
+++ b/shells/bash/Makefile
@@ -34,6 +34,15 @@ CONFIGURE_ARGS= --with-installed-readline
CONFIGURE_ENV= LDFLAGS=-static
MAN1= bash.1 bashbug.1
+.if defined(WITH_NET_REDIRECTIONS)
+CONFIGURE_ARGS+= --enable-net-redirections
+.endif
+
+pre-extract:
+.if !defined(WITH_NET_REDIRECTIONS)
+ @${ECHO_MSG} "You can enable support for /dev/(tcp|udp)/host/port redirection by defining WITH_NET_REDIRECTIONS."
+.endif
+
post-install:
${CP} /etc/shells /etc/shells.bak
(${GREP} -v ${PREFIX}/bin/bash /etc/shells.bak; ${ECHO_CMD} ${PREFIX}/bin/bash) >/etc/shells
diff --git a/shells/bash2/Makefile b/shells/bash2/Makefile
index 9ffdd87f3520..ae6f97ca9ef1 100644
--- a/shells/bash2/Makefile
+++ b/shells/bash2/Makefile
@@ -34,6 +34,15 @@ CONFIGURE_ARGS= --with-installed-readline
CONFIGURE_ENV= LDFLAGS=-static
MAN1= bash.1 bashbug.1
+.if defined(WITH_NET_REDIRECTIONS)
+CONFIGURE_ARGS+= --enable-net-redirections
+.endif
+
+pre-extract:
+.if !defined(WITH_NET_REDIRECTIONS)
+ @${ECHO_MSG} "You can enable support for /dev/(tcp|udp)/host/port redirection by defining WITH_NET_REDIRECTIONS."
+.endif
+
post-install:
${CP} /etc/shells /etc/shells.bak
(${GREP} -v ${PREFIX}/bin/bash /etc/shells.bak; ${ECHO_CMD} ${PREFIX}/bin/bash) >/etc/shells
diff --git a/shells/bash3/Makefile b/shells/bash3/Makefile
index 9ffdd87f3520..ae6f97ca9ef1 100644
--- a/shells/bash3/Makefile
+++ b/shells/bash3/Makefile
@@ -34,6 +34,15 @@ CONFIGURE_ARGS= --with-installed-readline
CONFIGURE_ENV= LDFLAGS=-static
MAN1= bash.1 bashbug.1
+.if defined(WITH_NET_REDIRECTIONS)
+CONFIGURE_ARGS+= --enable-net-redirections
+.endif
+
+pre-extract:
+.if !defined(WITH_NET_REDIRECTIONS)
+ @${ECHO_MSG} "You can enable support for /dev/(tcp|udp)/host/port redirection by defining WITH_NET_REDIRECTIONS."
+.endif
+
post-install:
${CP} /etc/shells /etc/shells.bak
(${GREP} -v ${PREFIX}/bin/bash /etc/shells.bak; ${ECHO_CMD} ${PREFIX}/bin/bash) >/etc/shells