aboutsummaryrefslogtreecommitdiffstats
path: root/shells
diff options
context:
space:
mode:
authorknu <knu@FreeBSD.org>2002-01-19 19:43:30 +0800
committerknu <knu@FreeBSD.org>2002-01-19 19:43:30 +0800
commit9db8185df0178fc5fa6b7d4ad6760d0cdaa3dbc6 (patch)
tree5cf8f291decaf8ce2d7a8ab50c5d5af6e68ced22 /shells
parent936158a176a0caa133ce620a051a18e8225132d5 (diff)
downloadfreebsd-ports-gnome-9db8185df0178fc5fa6b7d4ad6760d0cdaa3dbc6.tar.gz
freebsd-ports-gnome-9db8185df0178fc5fa6b7d4ad6760d0cdaa3dbc6.tar.zst
freebsd-ports-gnome-9db8185df0178fc5fa6b7d4ad6760d0cdaa3dbc6.zip
Add a patch submitted by the author which fixes a bug I reported where
fd fails to expand a relative symlink in the root directory. Bump PORTREVISION accordingly. Remove an unneeded MASTER_SITE_SUBDIR line.
Diffstat (limited to 'shells')
-rw-r--r--shells/fd/Makefile2
-rw-r--r--shells/fd/files/patch-libc.c13
2 files changed, 14 insertions, 1 deletions
diff --git a/shells/fd/Makefile b/shells/fd/Makefile
index 7149595ad02d..0b9dd5ea8754 100644
--- a/shells/fd/Makefile
+++ b/shells/fd/Makefile
@@ -7,10 +7,10 @@
PORTNAME= fd
PORTVERSION= 1.03u
+PORTREVISION= 1
CATEGORIES= misc
MASTER_SITES= http://hp.vector.co.jp/authors/VA012337/soft/fd/ \
ftp://ftp.vector.co.jp/pack/unix/util/file/filer/fd/
-MASTER_SITE_SUBDIR= steve
DISTNAME= FD-${PORTVERSION}
MAINTAINER= nobu@psrc.isac.co.jp
diff --git a/shells/fd/files/patch-libc.c b/shells/fd/files/patch-libc.c
new file mode 100644
index 000000000000..79c7e0ac01b2
--- /dev/null
+++ b/shells/fd/files/patch-libc.c
@@ -0,0 +1,13 @@
+diff -u ../old/FD-1.03u/libc.c ./libc.c
+--- ../old/FD-1.03u/libc.c Tue Dec 18 00:00:00 2001
++++ ./libc.c Tue Jan 8 12:06:14 2002
+@@ -165,7 +165,8 @@
+ buf[i] = '\0';
+ if (*buf == _SC_) strcpy(resolved, buf);
+ else {
+- *(cp - 1) = '\0';
++ if (cp - 1 > resolved) cp--;
++ *cp = '\0';
+ _realpath2(buf, resolved, rdlink);
+ }
+ }