aboutsummaryrefslogtreecommitdiffstats
path: root/shells
diff options
context:
space:
mode:
authorwen <wen@FreeBSD.org>2010-03-17 14:29:16 +0800
committerwen <wen@FreeBSD.org>2010-03-17 14:29:16 +0800
commitd68b2a95f74d99578f14a252fb5c63a5490bf8a9 (patch)
tree154cc1fedbee668491c44e95e7e4776660220756 /shells
parente6f2c06996b43db31248d2ee408df7163c5d732f (diff)
downloadfreebsd-ports-gnome-d68b2a95f74d99578f14a252fb5c63a5490bf8a9.tar.gz
freebsd-ports-gnome-d68b2a95f74d99578f14a252fb5c63a5490bf8a9.tar.zst
freebsd-ports-gnome-d68b2a95f74d99578f14a252fb5c63a5490bf8a9.zip
- Install documentation into DOCSDIR
PR: ports/144545 Submitted by: Rob Farmer <rfarmer@predatorlabs.net> (maintainer)
Diffstat (limited to 'shells')
-rw-r--r--shells/fish/Makefile10
-rw-r--r--shells/fish/pkg-plist33
2 files changed, 22 insertions, 21 deletions
diff --git a/shells/fish/Makefile b/shells/fish/Makefile
index c87778bf0787..076d834f90df 100644
--- a/shells/fish/Makefile
+++ b/shells/fish/Makefile
@@ -7,7 +7,7 @@
PORTNAME= fish
PORTVERSION= 1.23.1
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= shells
MASTER_SITES= SF
@@ -24,6 +24,7 @@ CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
CONFIGURE_ENV+= CPPFLAGS="${CPPFLAGS}" LIBS="${LDFLAGS}" \
LDFLAGS="${LDFLAGS}"
+CONFIGURE_ARGS= --docdir=${DOCSDIR}
OPTIONS= XSEL "Build with xsel" on \
DOXYGEN "Build docs with doxygen" on
@@ -50,15 +51,14 @@ CONFIGURE_ARGS+= --without-xsel
RUN_DEPENDS= xsel:${PORTSDIR}/x11/xsel-conrad
.endif
-.if defined(WITHOUT_DOXYGEN) || defined(NOPORTDOCS)
-PLIST_SUB+= DOCS="@comment "
+.if defined(WITHOUT_DOXYGEN)
+NOPORTDOCS= yes
.else
BUILD_DEPENDS+= doxygen:${PORTSDIR}/devel/doxygen
-PLIST_SUB+= DOCS=""
.endif
post-patch:
-.if defined(WITHOUT_DOXYGEN) || defined(NOPORTDOCS)
+.if defined(NOPORTDOCS)
@${REINPLACE_CMD} -e 's|$(PROGRAMS) user_doc|$(PROGRAMS)|' \
${WRKSRC}/Makefile.in
@${REINPLACE_CMD} -e 589,593d ${WRKSRC}/Makefile.in
diff --git a/shells/fish/pkg-plist b/shells/fish/pkg-plist
index 9ad6b0fe60b9..37d8bf355092 100644
--- a/shells/fish/pkg-plist
+++ b/shells/fish/pkg-plist
@@ -2,25 +2,25 @@ bin/fish
bin/fish_indent
bin/fish_pager
bin/fishd
-bin/mimedb
bin/seq
+bin/mimedb
bin/set_color
%%ETCDIR%%/config.fish
-%%DOCS%%share/doc/ChangeLog
-%%DOCS%%share/doc/commands.html
-%%DOCS%%share/doc/design.html
-%%DOCS%%share/doc/doc_8h-source.html
-%%DOCS%%share/doc/doxygen.css
-%%DOCS%%share/doc/doxygen.png
-%%DOCS%%share/doc/faq.html
-%%DOCS%%share/doc/files.html
-%%DOCS%%share/doc/index.html
-%%DOCS%%share/doc/license.html
-%%DOCS%%share/doc/pages.html
-%%DOCS%%share/doc/tab_b.gif
-%%DOCS%%share/doc/tab_l.gif
-%%DOCS%%share/doc/tab_r.gif
-%%DOCS%%share/doc/tabs.css
+%%PORTDOCS%%%%DOCSDIR%%/ChangeLog
+%%PORTDOCS%%%%DOCSDIR%%/commands.html
+%%PORTDOCS%%%%DOCSDIR%%/design.html
+%%PORTDOCS%%%%DOCSDIR%%/doc_8h-source.html
+%%PORTDOCS%%%%DOCSDIR%%/doxygen.css
+%%PORTDOCS%%%%DOCSDIR%%/doxygen.png
+%%PORTDOCS%%%%DOCSDIR%%/faq.html
+%%PORTDOCS%%%%DOCSDIR%%/files.html
+%%PORTDOCS%%%%DOCSDIR%%/index.html
+%%PORTDOCS%%%%DOCSDIR%%/license.html
+%%PORTDOCS%%%%DOCSDIR%%/pages.html
+%%PORTDOCS%%%%DOCSDIR%%/tab_b.gif
+%%PORTDOCS%%%%DOCSDIR%%/tab_l.gif
+%%PORTDOCS%%%%DOCSDIR%%/tab_r.gif
+%%PORTDOCS%%%%DOCSDIR%%/tabs.css
%%DATADIR%%/completions/acpi.fish
%%DATADIR%%/completions/adduser.fish
%%DATADIR%%/completions/and.fish
@@ -353,6 +353,7 @@ share/locale/sv/LC_MESSAGES/fish.mo
@dirrm %%DATADIR%%/functions
@dirrm %%DATADIR%%/completions
@dirrm %%DATADIR%%
+@dirrm %%DOCSDIR%%
@dirrm %%ETCDIR%%
@exec cp /etc/shells /etc/shells.bak; (grep -v %D/bin/fish /etc/shells.bak; echo %D/bin/fish) > /etc/shells; rm -f /etc/shells.bak
@unexec cp /etc/shells /etc/shells.bak; (grep -v %D/bin/fish /etc/shells.bak) > /etc/shells; rm -f /etc/shells.bak