aboutsummaryrefslogtreecommitdiffstats
path: root/sysutils/915resolution
diff options
context:
space:
mode:
authorlawrance <lawrance@FreeBSD.org>2006-11-05 17:57:49 +0800
committerlawrance <lawrance@FreeBSD.org>2006-11-05 17:57:49 +0800
commit6c6b95159beff54058612c7f03e9bdd8a3fa3936 (patch)
tree5c62ce8e19f5dbc09536e317a2aaed308f7a4e63 /sysutils/915resolution
parent1690f5197c553484fce301f6c9a862006f0399af (diff)
downloadfreebsd-ports-gnome-6c6b95159beff54058612c7f03e9bdd8a3fa3936.tar.gz
freebsd-ports-gnome-6c6b95159beff54058612c7f03e9bdd8a3fa3936.tar.zst
freebsd-ports-gnome-6c6b95159beff54058612c7f03e9bdd8a3fa3936.zip
Put back ONLY_FOR_ARCHS=i386, this needs some work for 64 bit platforms.
Mark BROKEN on 4.x. Reported by: kris
Diffstat (limited to 'sysutils/915resolution')
-rw-r--r--sysutils/915resolution/Makefile10
1 files changed, 9 insertions, 1 deletions
diff --git a/sysutils/915resolution/Makefile b/sysutils/915resolution/Makefile
index c46f77280eb9..2a47c618b114 100644
--- a/sysutils/915resolution/Makefile
+++ b/sysutils/915resolution/Makefile
@@ -19,6 +19,14 @@ COMMENT= Resolution tool for Intel i915 video cards
PLIST_FILES= bin/915resolution
ALL_TARGET= 915resolution
+ONLY_FOR_ARCHS= i386
+
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} < 500000
+BROKEN= Does not build
+.endif
+
do-build:
cd ${WRKSRC} && \
${CC} ${CFLAGS} 915resolution.c -o 915resolution
@@ -26,4 +34,4 @@ do-build:
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/915resolution ${PREFIX}/bin
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>