aboutsummaryrefslogtreecommitdiffstats
path: root/sysutils/915resolution
diff options
context:
space:
mode:
authorlawrance <lawrance@FreeBSD.org>2006-10-31 15:07:11 +0800
committerlawrance <lawrance@FreeBSD.org>2006-10-31 15:07:11 +0800
commit8cfcd517f05594e14f2b98d3c1bb8b44b5626bc7 (patch)
tree6ebc093583813ac35ba5bcbead00e2f5054ff7c9 /sysutils/915resolution
parent5b6dc9563eda528ca4a151a4bf76997ba5a43c27 (diff)
downloadfreebsd-ports-gnome-8cfcd517f05594e14f2b98d3c1bb8b44b5626bc7.tar.gz
freebsd-ports-gnome-8cfcd517f05594e14f2b98d3c1bb8b44b5626bc7.tar.zst
freebsd-ports-gnome-8cfcd517f05594e14f2b98d3c1bb8b44b5626bc7.zip
Build native nstead of installing a linux binary.
Bump PORTREVISION for this change. PR: ports/104434 Approved by: Remington L <mrl0lz@gmail.com> (maintainer)
Diffstat (limited to 'sysutils/915resolution')
-rw-r--r--sysutils/915resolution/Makefile11
-rw-r--r--sysutils/915resolution/files/patch-915resolution.c90
-rw-r--r--sysutils/915resolution/pkg-descr3
3 files changed, 97 insertions, 7 deletions
diff --git a/sysutils/915resolution/Makefile b/sysutils/915resolution/Makefile
index 9687c18c1562..c46f77280eb9 100644
--- a/sysutils/915resolution/Makefile
+++ b/sysutils/915resolution/Makefile
@@ -6,6 +6,7 @@
PORTNAME= 915resolution
PORTVERSION= 0.5.2
+PORTREVISION= 1
PORTEPOCH= 1
CATEGORIES= sysutils
MASTER_SITES= http://www.geocities.com/stomljen/ \
@@ -15,14 +16,14 @@ MASTER_SITE_SUBDIR= ehaupt
MAINTAINER= MrL0Lz@gmail.com
COMMENT= Resolution tool for Intel i915 video cards
-USE_LINUX= yes
-NO_BUILD= yes
-ONLY_FOR_ARCHS= i386
-
PLIST_FILES= bin/915resolution
+ALL_TARGET= 915resolution
+
+do-build:
+ cd ${WRKSRC} && \
+ ${CC} ${CFLAGS} 915resolution.c -o 915resolution
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/915resolution ${PREFIX}/bin
- ${BRANDELF} -t Linux ${PREFIX}/bin/915resolution
.include <bsd.port.mk>
diff --git a/sysutils/915resolution/files/patch-915resolution.c b/sysutils/915resolution/files/patch-915resolution.c
new file mode 100644
index 000000000000..2ba27437d5c7
--- /dev/null
+++ b/sysutils/915resolution/files/patch-915resolution.c
@@ -0,0 +1,90 @@
+--- 915resolution.c.orig Fri Feb 3 01:28:34 2006
++++ 915resolution.c Sun Oct 15 20:39:56 2006
+@@ -21,8 +21,10 @@
+ #define __USE_GNU
+ #include <string.h>
+ #include <sys/mman.h>
++#include <machine/cpufunc.h>
++#define OUTB(a, b) outb(b, a)
++#define OUTL(a, b) outl(b, a)
+ #include <fcntl.h>
+-#include <sys/io.h>
+ #include <unistd.h>
+ #include <assert.h>
+
+@@ -161,7 +163,8 @@
+ void initialize_system(char * filename) {
+
+ if (!filename) {
+- if (iopl(3) < 0) {
++ FILE* iof = fopen("/dev/io", "r");
++ if (iof == NULL) {
+ perror("Unable to obtain the proper IO permissions");
+ exit(2);
+ }
+@@ -169,7 +172,7 @@
+ }
+
+ cardinal get_chipset_id(void) {
+- outl(0x80000000, 0xcf8);
++ OUTL(0x80000000, 0xcf8);
+ return inl(0xcfc);
+ }
+
+@@ -476,11 +479,11 @@
+ case CT_UNKWN:
+ break;
+ case CT_855GM:
+- outl(0x8000005a, 0xcf8);
++ OUTL(0x8000005a, 0xcf8);
+ map->b1 = inb(0xcfe);
+
+- outl(0x8000005a, 0xcf8);
+- outb(0x33, 0xcfe);
++ OUTL(0x8000005a, 0xcf8);
++ OUTB(0x33, 0xcfe);
+ break;
+ case CT_845G:
+ case CT_865G:
+@@ -488,13 +491,13 @@
+ case CT_915GM:
+ case CT_945G:
+ case CT_945GM:
+- outl(0x80000090, 0xcf8);
++ OUTL(0x80000090, 0xcf8);
+ map->b1 = inb(0xcfd);
+ map->b2 = inb(0xcfe);
+
+- outl(0x80000090, 0xcf8);
+- outb(0x33, 0xcfd);
+- outb(0x33, 0xcfe);
++ OUTL(0x80000090, 0xcf8);
++ OUTB(0x33, 0xcfd);
++ OUTB(0x33, 0xcfe);
+ break;
+ }
+ }
+@@ -526,8 +529,8 @@
+ case CT_UNKWN:
+ break;
+ case CT_855GM:
+- outl(0x8000005a, 0xcf8);
+- outb(map->b1, 0xcfe);
++ OUTL(0x8000005a, 0xcf8);
++ OUTB(map->b1, 0xcfe);
+ break;
+ case CT_845G:
+ case CT_865G:
+@@ -535,9 +538,9 @@
+ case CT_915GM:
+ case CT_945G:
+ case CT_945GM:
+- outl(0x80000090, 0xcf8);
+- outb(map->b1, 0xcfd);
+- outb(map->b2, 0xcfe);
++ OUTL(0x80000090, 0xcf8);
++ OUTB(map->b1, 0xcfd);
++ OUTB(map->b2, 0xcfe);
+ break;
+ }
+ }
diff --git a/sysutils/915resolution/pkg-descr b/sysutils/915resolution/pkg-descr
index 7989dd8d0e2f..e4f67ade978d 100644
--- a/sysutils/915resolution/pkg-descr
+++ b/sysutils/915resolution/pkg-descr
@@ -1,5 +1,4 @@
This is a resolution hack for Intel 915 based video cards. Based on code
-written by Alain Poirer for Linux, modified by Steve Tomljenovic. Binary
-install, source code included.
+written by Alain Poirer for Linux, modified by Steve Tomljenovic.
WWW: http://www.geocities.com/stomljen/