aboutsummaryrefslogtreecommitdiffstats
path: root/sysutils/ansible/Makefile
diff options
context:
space:
mode:
authorkoobs <koobs@FreeBSD.org>2014-12-12 06:17:49 +0800
committerkoobs <koobs@FreeBSD.org>2014-12-12 06:17:49 +0800
commit28ed2047c30b0c0c5c2712559640c3da2713bbd5 (patch)
tree0bf32f35ca8908dcc438923135c731525cab3897 /sysutils/ansible/Makefile
parent442eaad751a20d8e88c35c696adefd7817d22490 (diff)
downloadfreebsd-ports-gnome-28ed2047c30b0c0c5c2712559640c3da2713bbd5.tar.gz
freebsd-ports-gnome-28ed2047c30b0c0c5c2712559640c3da2713bbd5.tar.zst
freebsd-ports-gnome-28ed2047c30b0c0c5c2712559640c3da2713bbd5.zip
sysutils/ansible: Update to 1.8.2
- Update to 1.8.2 - Remove MASTERFILES, DISTFILES (unnecessary with USE_GITHUB) - Update COMMENT - Remove ACCELERATE option, move pycrypto to RUN_DEPENDS While I'm here: - Add LICENSE_FILE - pkg-descr: Strip trailing slash from WWW: URL - GH_PROJECT defaults to ${PORTNAME}, remove it Changes: https://raw.githubusercontent.com/ansible/ansible/v1.8.2/CHANGELOG.md PR: 195557 Submitted by: Nikolai Lifanov <lifanov@mail.lifanov.com> (maintainer)
Diffstat (limited to 'sysutils/ansible/Makefile')
-rw-r--r--sysutils/ansible/Makefile47
1 files changed, 18 insertions, 29 deletions
diff --git a/sysutils/ansible/Makefile b/sysutils/ansible/Makefile
index c79206635ac3..7f4e990a244e 100644
--- a/sysutils/ansible/Makefile
+++ b/sysutils/ansible/Makefile
@@ -2,39 +2,30 @@
# $FreeBSD$
PORTNAME= ansible
-PORTVERSION= 1.7.2
+PORTVERSION= 1.8.2
CATEGORIES= sysutils python
-MASTER_SITES= SF/lifanov-ports-distfiles/sysutils/${PORTNAME}/:icons
-DISTFILES= ${PORTNAME}-${DISTVERSION}${EXTRACT_SUFX} \
- ${PORTNAME}.png:icons
-EXTRACT_ONLY= ${PORTNAME}-${DISTVERSION}${EXTRACT_SUFX}
MAINTAINER= lifanov@mail.lifanov.com
-COMMENT= Simple ssh-based configuration management and orchestration system
+COMMENT= Radically simple IT automation
LICENSE= GPLv3
+LICENSE_FILE= ${WRKSRC}/COPYING
RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}yaml>0:${PORTSDIR}/devel/py-yaml \
+ ${PYTHON_PKGNAMEPREFIX}pycrypto>0:${PORTSDIR}/security/py-pycrypto \
${PYTHON_PKGNAMEPREFIX}paramiko>0:${PORTSDIR}/security/py-paramiko \
${PYTHON_PKGNAMEPREFIX}Jinja2>0:${PORTSDIR}/devel/py-Jinja2
-OPTIONS_DEFINE= ACCELERATE EXAMPLES
-OPTIONS_DEFAULT= ACCELERATE
-
-ACCELERATE_DESC= Enable Accelerated Mode (Uses pycrypto and keyczar)
-ACCELERATE_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}pycrypto>0:${PORTSDIR}/security/py-pycrypto \
- ${PYTHON_PKGNAMEPREFIX}keyczar>0:${PORTSDIR}/security/py-keyczar
+OPTIONS_DEFINE= EXAMPLES
USE_GITHUB= yes
GH_ACCOUNT= ${PORTNAME}
-GH_PROJECT= ${PORTNAME}
GH_TAGNAME= ${GH_COMMIT}
-GH_COMMIT= d3c28fe
+GH_COMMIT= 6f568bd
USES= cpe python:2 shebangfix
USE_PYTHON= autoplist distutils
-SHEBANG_FILES= library/*/* \
- lib/ansible/runner/action_plugins/synchronize.py
+SHEBANG_FILES= lib/ansible/runner/action_plugins/synchronize.py
CPE_VENDOR= ansibleworks
SUB_FILES= pkg-message
@@ -44,24 +35,26 @@ PLIST_FILES+= man/man1/ansible-doc.1.gz \
man/man1/ansible-playbook.1.gz \
man/man1/ansible-pull.1.gz \
man/man1/ansible-vault.1.gz \
- man/man1/ansible.1.gz \
- ${DESKTOPDIR:S,^${PREFIX}/,,}/${PORTNAME}.desktop \
- share/pixmaps/${PORTNAME}.png
+ man/man1/ansible.1.gz
PORTEXAMPLES= ansible.cfg hosts
post-patch:
-.for f in bin/ansible-galaxy docs/man/man1/ansible-playbook.1 \
- docs/man/man1/ansible.1 examples/ansible.cfg \
- examples/hosts lib/ansible/constants.py \
- lib/ansible/playbook/__init__.py lib/ansible/runner/__init__.py \
- library/system/setup
+.for f in bin/ansible-galaxy docs/man/man1/ansible-galaxy.1 \
+ docs/man/man1/ansible-playbook.1 docs/man/man1/ansible.1 \
+ examples/ansible.cfg examples/hosts lib/ansible/constants.py \
+ lib/ansible/module_utils/urls.py lib/ansible/playbook/__init__.py \
+ lib/ansible/runner/__init__.py plugins/README.md \
+ plugins/inventory/cobbler.py plugins/inventory/collins.py \
+ plugins/inventory/nova.py plugins/inventory/spacewalk.py \
+ v2/ansible/constants.py v2/ansible/playbook/role/definition.py
@${REINPLACE_CMD} -e 's|/etc/ansible|${ETCDIR}|' ${WRKSRC}/${f}
.endfor
.for f in docs/man/man1/ansible-playbook.1 docs/man/man1/ansible.1 \
examples/ansible.cfg lib/ansible/constants.py \
- lib/ansible/playbook/__init__.py lib/ansible/runner/__init__.py
+ lib/ansible/playbook/__init__.py lib/ansible/runner/__init__.py \
+ v2/ansible/constants.py
@${REINPLACE_CMD} -e 's|/usr/share/ansible|${DATADIR}|' ${WRKSRC}/${f}
.endfor
@@ -72,9 +65,5 @@ post-install:
@${MKDIR} ${STAGEDIR}${EXAMPLESDIR}
${INSTALL_DATA} ${WRKSRC}/examples/ansible.cfg ${STAGEDIR}${EXAMPLESDIR}
${INSTALL_DATA} ${WRKSRC}/examples/hosts ${STAGEDIR}${EXAMPLESDIR}
- ${INSTALL_DATA} ${_DISTDIR}/${PORTNAME}.png \
- ${STAGEDIR}${PREFIX}/share/pixmaps/
- ${INSTALL_DATA} ${FILESDIR}/${PORTNAME}.desktop \
- ${STAGEDIR}${DESKTOPDIR}
.include <bsd.port.mk>