aboutsummaryrefslogtreecommitdiffstats
path: root/sysutils/ansible/Makefile
diff options
context:
space:
mode:
authorrm <rm@FreeBSD.org>2014-03-03 03:10:50 +0800
committerrm <rm@FreeBSD.org>2014-03-03 03:10:50 +0800
commit7a30df95350fc7a063a56fea4c4628c87080ebc9 (patch)
tree70255424cf5a4c96546ce71a429762b941e665be /sysutils/ansible/Makefile
parent1e6499cdb70a4dceca6870de6ac8260cde81f40d (diff)
downloadfreebsd-ports-gnome-7a30df95350fc7a063a56fea4c4628c87080ebc9.tar.gz
freebsd-ports-gnome-7a30df95350fc7a063a56fea4c4628c87080ebc9.tar.zst
freebsd-ports-gnome-7a30df95350fc7a063a56fea4c4628c87080ebc9.zip
sysutils/ansible: update to 1.5
- update to 1.5 - clarify how to use sysutils/ansible port to control non-FreeBSD systems in pkg-message - remove man3 man pages: they are gone in the upstream distribution - convert to PLIST_FILES - remove NO_ARCH, while here - it has no practical value here - add UPDATING entry, because some changes are not backward compatible Changelog: https://raw.github.com/ansible/ansible/v1.5.0/CHANGELOG.md PR: 187182 Submitted by: Nikolai Lifanov <lifanov@mail.lifanov.com> (maintainer)
Diffstat (limited to 'sysutils/ansible/Makefile')
-rw-r--r--sysutils/ansible/Makefile15
1 files changed, 7 insertions, 8 deletions
diff --git a/sysutils/ansible/Makefile b/sysutils/ansible/Makefile
index cca374c9959a..51765ab79a83 100644
--- a/sysutils/ansible/Makefile
+++ b/sysutils/ansible/Makefile
@@ -1,7 +1,7 @@
# $FreeBSD$
PORTNAME= ansible
-PORTVERSION= 1.4.5
+PORTVERSION= 1.5
CATEGORIES= sysutils python
MASTER_SITES= http://releases.ansible.com/ansible/
@@ -14,8 +14,6 @@ RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}yaml>0:${PORTSDIR}/devel/py-yaml \
${PYTHON_PKGNAMEPREFIX}paramiko>0:${PORTSDIR}/security/py-paramiko \
${PYTHON_PKGNAMEPREFIX}Jinja2>0:${PORTSDIR}/devel/py-Jinja2
-NO_ARCH= yes
-
OPTIONS_DEFINE= ACCELERATE EXAMPLES
OPTIONS_DEFAULT= ACCELERATE
@@ -32,6 +30,10 @@ SHEBANG_FILES= library/*/* \
lib/ansible/runner/action_plugins/synchronize.py
SUB_FILES= pkg-message
+PLIST_FILES+= man/man1/ansible-doc.1.gz \
+ man/man1/ansible-playbook.1.gz \
+ man/man1/ansible-pull.1.gz \
+ man/man1/ansible.1.gz
PORTEXAMPLES= ansible.cfg hosts
@@ -59,11 +61,8 @@ post-install:
@${MKDIR} ${STAGEDIR}${MAN1PREFIX}/man/man1
${INSTALL_MAN} ${WRKSRC}/docs/man/man1/*.1 \
${STAGEDIR}${MAN1PREFIX}/man/man1
- @${MKDIR} ${STAGEDIR}${MAN3PREFIX}/man/man3
- ${INSTALL_MAN} ${WRKSRC}/docs/man/man3/*.3 \
- ${STAGEDIR}${MAN3PREFIX}/man/man3
@${MKDIR} ${STAGEDIR}${EXAMPLESDIR}
- ${CP} ${WRKSRC}/examples/ansible.cfg ${STAGEDIR}${EXAMPLESDIR}
- ${CP} ${WRKSRC}/examples/hosts ${STAGEDIR}${EXAMPLESDIR}
+ ${INSTALL_DATA} ${WRKSRC}/examples/ansible.cfg ${STAGEDIR}${EXAMPLESDIR}
+ ${INSTALL_DATA} ${WRKSRC}/examples/hosts ${STAGEDIR}${EXAMPLESDIR}
.include <bsd.port.mk>