aboutsummaryrefslogtreecommitdiffstats
path: root/sysutils/asr-utils/Makefile
diff options
context:
space:
mode:
authormarcus <marcus@FreeBSD.org>2004-10-04 15:13:16 +0800
committermarcus <marcus@FreeBSD.org>2004-10-04 15:13:16 +0800
commitf42ddef20b993478130341cfd826d0de1b4d41be (patch)
treefbe1861379ea41e249050aad3dfc83ae58e0ae01 /sysutils/asr-utils/Makefile
parent442bf9c7ed8905bd05053842b44ceae95fea8c44 (diff)
downloadfreebsd-ports-gnome-f42ddef20b993478130341cfd826d0de1b4d41be.tar.gz
freebsd-ports-gnome-f42ddef20b993478130341cfd826d0de1b4d41be.tar.zst
freebsd-ports-gnome-f42ddef20b993478130341cfd826d0de1b4d41be.zip
Add a dependency on compat4x if building on 5.X systems or higher.
Reported by: kris Approved by: portmgr (implicit)
Diffstat (limited to 'sysutils/asr-utils/Makefile')
-rw-r--r--sysutils/asr-utils/Makefile8
1 files changed, 7 insertions, 1 deletions
diff --git a/sysutils/asr-utils/Makefile b/sysutils/asr-utils/Makefile
index 2400e1946caf..4856a18c0b30 100644
--- a/sysutils/asr-utils/Makefile
+++ b/sysutils/asr-utils/Makefile
@@ -23,6 +23,12 @@ NO_WRKSUBDIR= yes
USE_XLIB= yes
BINS= dptcom dpteng dptscom dptsig raidutil dptmgr
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} >= 500000
+LIB_DEPENDS+= c.4:${PORTSDIR}/misc/compat4x
+.endif
+
do-build:
${SED} -e 's,%%PREFIX%%,${PREFIX},g' \
${FILESDIR}/dptmgr.sh.in > ${WRKDIR}/dptmgr.sh
@@ -41,4 +47,4 @@ do-install:
${INSTALL_SCRIPT} ${WRKSRC}/libXm.so.1 ${X11BASE}/lib
.endif
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>