aboutsummaryrefslogtreecommitdiffstats
path: root/sysutils/ataidle/Makefile
diff options
context:
space:
mode:
authorsergei <sergei@FreeBSD.org>2004-01-14 22:22:29 +0800
committersergei <sergei@FreeBSD.org>2004-01-14 22:22:29 +0800
commitbc362f78aad3987f398dc65b07ab363cb5905e68 (patch)
tree0e0052b4a8ccefab1da09ba987a87556472c1851 /sysutils/ataidle/Makefile
parente712e1d96dbbf1e0ac5f94947795aba0186fd389 (diff)
downloadfreebsd-ports-gnome-bc362f78aad3987f398dc65b07ab363cb5905e68.tar.gz
freebsd-ports-gnome-bc362f78aad3987f398dc65b07ab363cb5905e68.tar.zst
freebsd-ports-gnome-bc362f78aad3987f398dc65b07ab363cb5905e68.zip
Add ataidle 0.3, utility to set spindown timeout for ATA drives.
ATAidle is a utility to set the power management features of ata hard drives. This includes idle and standby timeouts, APM and acoustic level settings, and it can show details about the installed devices. PR: 61217 Submitted by: Bruce Cran <bruce@cran.org.uk>
Diffstat (limited to 'sysutils/ataidle/Makefile')
-rw-r--r--sysutils/ataidle/Makefile33
1 files changed, 33 insertions, 0 deletions
diff --git a/sysutils/ataidle/Makefile b/sysutils/ataidle/Makefile
new file mode 100644
index 000000000000..2c3d9bf906f5
--- /dev/null
+++ b/sysutils/ataidle/Makefile
@@ -0,0 +1,33 @@
+# New ports collection makefile for: ataidle
+# Date created: 2004-01-11
+# Whom: Bruce Cran <bruce@cran.org.uk>
+#
+# $FreeBSD$
+#
+
+PORTNAME= ataidle
+PORTVERSION= 0.3
+CATEGORIES= sysutils
+MASTER_SITES= ftp://ftp.brucec.homeunix.org/pub/users/brucec/
+
+MAINTAINER= bruce@cran.org.uk
+COMMENT= Utility to set spindown timeout for ATA drives
+
+MAN8= ataidle.8
+DOCS= COPYING ChangeLog README
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/ataidle ${PREFIX}/sbin
+ ${INSTALL_MAN} ${WRKSRC}/ataidle.8 ${MAN8PREFIX}/man/man8
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${DOCSDIR}
+ cd ${WRKSRC} && ${INSTALL_DATA} ${DOCS} ${DOCSDIR}
+.endif
+
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} < 501105
+IGNORE= "requires ATAng, available in 5.1-CURRENT or newer"
+.endif
+
+.include <bsd.port.post.mk>