aboutsummaryrefslogtreecommitdiffstats
path: root/sysutils/bacula-server
diff options
context:
space:
mode:
authoredwin <edwin@FreeBSD.org>2004-12-01 15:45:26 +0800
committeredwin <edwin@FreeBSD.org>2004-12-01 15:45:26 +0800
commit098fc4483177de090fda295589dc0004cc28b983 (patch)
tree23ba593e7cb2ace5d6244dda7edceff9344c2a7f /sysutils/bacula-server
parent0f8189ed3c0881ff2aa2dfb59710975be31a5aae (diff)
downloadfreebsd-ports-gnome-098fc4483177de090fda295589dc0004cc28b983.tar.gz
freebsd-ports-gnome-098fc4483177de090fda295589dc0004cc28b983.tar.zst
freebsd-ports-gnome-098fc4483177de090fda295589dc0004cc28b983.zip
Fix makefile for sysutils/bacula-client.
Approved by: Lars K?ller <lars.koeller@uni-bielefeld.de>
Diffstat (limited to 'sysutils/bacula-server')
-rw-r--r--sysutils/bacula-server/Makefile12
1 files changed, 5 insertions, 7 deletions
diff --git a/sysutils/bacula-server/Makefile b/sysutils/bacula-server/Makefile
index f86202b1deda..444761df1bf9 100644
--- a/sysutils/bacula-server/Makefile
+++ b/sysutils/bacula-server/Makefile
@@ -73,6 +73,7 @@ PLIST_SUB+= BACULA_DIR=${BACULA_DIR}
# Client only or full server version
.if defined(WITH_CLIENT_ONLY)
+CONFFILES= fd
CONFIGURE_ARGS+= --enable-client-only
PORTDOCS= bacula.pdf ReleaseNotes html-manual
PKGDEINSTALL= ${PKGDIR}/pkg-deinstall.client
@@ -99,6 +100,7 @@ PLIST_SUB+= WXCONS="@comment "
.endif
.else
# Server only Options
+CONFFILES= sd dir
.if defined(WITH_MYSQL)
CONFIGURE_ARGS+= --with-mysql=yes
USE_MYSQL= yes
@@ -194,18 +196,14 @@ post-install:
${CHOWN} -R bacula:bacula ${PREFIX}/share/bacula
.endif
# Install leaves existing conf files untouched. Respect this here!
-.if defined(WITH_CLIENT_ONLY)
- for na in fd; do \
-.else
- for na in sd dir; do \
-.endif
+ for na in ${CONFFILES}; do \
if [ -f ${PREFIX}/etc/bacula-$$na.conf.new ]; then \
${ECHO_CMD} "etc/bacula-$$na.conf.new" >> ${TMPPLIST}; \
elif [ -f ${PREFIX}/etc/bacula-$$na.conf ]; then \
${MV} ${PREFIX}/etc/bacula-$$na.conf ${PREFIX}/etc/bacula-$$na.conf.sample; \
${ECHO_CMD} "etc/bacula-$$na.conf.sample" >> ${TMPPLIST}; \
- fi \
- done; \
+ fi; \
+ done
.if !defined(NOPORTDOCS)
${MKDIR} ${DOCSDIR}/html-manual