aboutsummaryrefslogtreecommitdiffstats
path: root/sysutils/bacula2-server
diff options
context:
space:
mode:
authorohauer <ohauer@FreeBSD.org>2010-10-04 04:54:22 +0800
committerohauer <ohauer@FreeBSD.org>2010-10-04 04:54:22 +0800
commit7e3aed567dcebc2ec6418cd436204e87bbc704d2 (patch)
tree938c927aeeb5d16d20b1ae6c96717ca71176db69 /sysutils/bacula2-server
parente3edac033c8bec0a9a28f0e42bff0579ef310534 (diff)
downloadfreebsd-ports-gnome-7e3aed567dcebc2ec6418cd436204e87bbc704d2.tar.gz
freebsd-ports-gnome-7e3aed567dcebc2ec6418cd436204e87bbc704d2.tar.zst
freebsd-ports-gnome-7e3aed567dcebc2ec6418cd436204e87bbc704d2.zip
- update download URL
- deny build if openssl from port is installed (bacula2 does not build with openssl >= 1.0) - bump PORTREVISION PR: 151142 Submitted by: maintainer Approved by: Vaclav Haisman <v.haisman _at_ sh.cvut.cz> (maintainer), glarkin (mentor, implicit)
Diffstat (limited to 'sysutils/bacula2-server')
-rw-r--r--sysutils/bacula2-server/Makefile22
1 files changed, 11 insertions, 11 deletions
diff --git a/sysutils/bacula2-server/Makefile b/sysutils/bacula2-server/Makefile
index a44d16341ff5..9c59918cf616 100644
--- a/sysutils/bacula2-server/Makefile
+++ b/sysutils/bacula2-server/Makefile
@@ -7,25 +7,24 @@
PORTNAME= bacula2
DISTVERSION= 2.4.4
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES?= sysutils
-MASTER_SITES= SF/bacula/bacula/${PORTVERSION}
+MASTER_SITES= SF/bacula/z-older-releases/bacula/${PORTVERSION}
+PKGNAMESUFFIX?= -server
+DISTNAME= bacula-${DISTVERSION}
MAINTAINER= v.haisman@sh.cvut.cz
COMMENT?= The network backup solution (server)
-PKGNAMESUFFIX?= -server
-
CONFLICTS= bacula-server-devel-[0-9]* \
bacula-client-devel-[0-9]* \
bacula-docs-devel-[0-9]* \
bacula-server-[0-9]* \
bacula-client-[0-9]*
-UNIQUENAME?=${PORTNAME}${PKGNAMESUFFIX}
+UNIQUENAME?= ${PORTNAME}${PKGNAMESUFFIX}
-DISTFILES= bacula-${DISTVERSION}.tar.gz
-WRKSRC= ${WRKDIR}/bacula-${DISTVERSION}
+WRKSRC= ${WRKDIR}/bacula-${DISTVERSION}
.if !defined(WITH_BAT)
.if !defined(WITH_CLIENT_ONLY)
@@ -83,7 +82,7 @@ IS_INTERACTIVE= yes
OPTIONS= WXCONSOLE "Build with wxGTK based GUI console: deprecated" off
OPTIONS+= GNOMECONSOLE "Build with GNOME based GUI console: deprecated" off
.elif defined(WITH_BAT)
-OPTIONS=
+OPTIONS=
.else
OPTIONS= SQLITE3 "Use SqLite-3 database instead of SqLite-2" off
OPTIONS+= MYSQL "Use MySQL database instead of SqLite" off
@@ -92,7 +91,7 @@ OPTIONS+= MTX "Install mtx for control of autochanger devices" off
.endif
OPTIONS+= NLS "Native Language Support via gettext utilities" on
-OPTIONS+= OPENSSL "Enable OpenSSL for encrypted communication" off
+OPTIONS+= OPENSSL "Enable Use OpenSSL (broken for version >= 1.0.0)" off
# Prepare if bgnome-console is selected this must be happen before
# include of bsd.port.pre.mk!
@@ -177,8 +176,10 @@ RUN_DEPENDS+= ${LOCALBASE}/sbin/mtx:${PORTSDIR}/misc/mtx
.endif
.endif
-
.if defined(WITH_OPENSSL)
+# bacula2 does not build with openssl from ports
+WITH_OPENSSL_BASE= yes
+.include "${PORTSDIR}/Mk/bsd.openssl.mk"
CONFIGURE_ARGS+= --with-openssl
.endif
@@ -244,7 +245,6 @@ pre-install:
${SH} ${PKGINSTALL} ${PORTNAME} PRE-INSTALL
.endif
-
.if !target(post-install)
post-install:
.if defined(WITH_CLIENT_ONLY)