aboutsummaryrefslogtreecommitdiffstats
path: root/sysutils/binup/Makefile
diff options
context:
space:
mode:
authornovel <novel@FreeBSD.org>2006-02-20 18:03:43 +0800
committernovel <novel@FreeBSD.org>2006-02-20 18:03:43 +0800
commit41f236ffb9b7d377f5586c9471119c2bc7b62efd (patch)
tree5af4f52caa98be4dd61c5c46d06670e5d0f69476 /sysutils/binup/Makefile
parent55484d8f3bdf404f5d08ce7c053a5a652a4ef62d (diff)
downloadfreebsd-ports-gnome-41f236ffb9b7d377f5586c9471119c2bc7b62efd.tar.gz
freebsd-ports-gnome-41f236ffb9b7d377f5586c9471119c2bc7b62efd.tar.zst
freebsd-ports-gnome-41f236ffb9b7d377f5586c9471119c2bc7b62efd.zip
Add binup 1.1, BSDUpdates system update tool.
PR: ports/93259 Submitted by: BSDUpdates <support@bsdupdates.com>
Diffstat (limited to 'sysutils/binup/Makefile')
-rw-r--r--sysutils/binup/Makefile37
1 files changed, 37 insertions, 0 deletions
diff --git a/sysutils/binup/Makefile b/sysutils/binup/Makefile
new file mode 100644
index 000000000000..6c80732e5acf
--- /dev/null
+++ b/sysutils/binup/Makefile
@@ -0,0 +1,37 @@
+# New ports collection makefile for: binup
+# Date created: 2 November 2005
+# Whom: BSDUpdates <support@bsdupdates.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= binup
+PORTVERSION= 1.1
+CATEGORIES= sysutils
+MASTER_SITES= https://bsdupdates.com/binup/version/${PORTVERSION}/
+DISTNAME= binup-${OPSYS}-${OSREL:C/\..*//}-${PORTVERSION}
+
+MAINTAINER= support@bsdupdates.com
+COMMENT= BSDUpdates system update tool
+
+ONLY_FOR_ARCHS= i386
+
+NO_BUILD= yes
+USE_BZIP2= yes
+
+PLIST_FILES= libexec/binup/bspatch-static libexec/binup/pw-static sbin/binup
+PLIST_DIRS= libexec/binup
+
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} < 502010 || ${OSVERSION} >= 700000
+IGNORE= does not support ${OPSYS}-${OSREL} at this time
+.endif
+
+do-install:
+ ${MKDIR} ${PREFIX}/libexec/binup
+ ${INSTALL_PROGRAM} ${WRKSRC}/bspatch-static ${PREFIX}/libexec/binup
+ ${INSTALL_PROGRAM} ${WRKSRC}/pw-static ${PREFIX}/libexec/binup
+ ${INSTALL_PROGRAM} ${WRKSRC}/binup ${PREFIX}/sbin
+
+.include <bsd.port.post.mk>