aboutsummaryrefslogtreecommitdiffstats
path: root/sysutils/bsdstats
diff options
context:
space:
mode:
authorscrappy <scrappy@FreeBSD.org>2006-09-07 12:22:27 +0800
committerscrappy <scrappy@FreeBSD.org>2006-09-07 12:22:27 +0800
commitf1cf8e4aeebd7c1dc36ca1652652db54c35407b5 (patch)
tree884afc3488e6217f3ab1f27dfce6e79275c42fea /sysutils/bsdstats
parenta15c103619fc3eabffbec34013fce8723cf10c51 (diff)
downloadfreebsd-ports-gnome-f1cf8e4aeebd7c1dc36ca1652652db54c35407b5.tar.gz
freebsd-ports-gnome-f1cf8e4aeebd7c1dc36ca1652652db54c35407b5.tar.zst
freebsd-ports-gnome-f1cf8e4aeebd7c1dc36ca1652652db54c35407b5.zip
Apparently Sparc doesn't like using openssl to generate a random value ... it
created a 41 year 'sleep' time for one ... Fix it to use sum instead of openssl
Diffstat (limited to 'sysutils/bsdstats')
-rw-r--r--sysutils/bsdstats/Makefile2
-rw-r--r--sysutils/bsdstats/files/300.statistics8
-rw-r--r--sysutils/bsdstats/files/300.statistics.in8
3 files changed, 13 insertions, 5 deletions
diff --git a/sysutils/bsdstats/Makefile b/sysutils/bsdstats/Makefile
index 5ce32017ebb1..9a8ea12d159a 100644
--- a/sysutils/bsdstats/Makefile
+++ b/sysutils/bsdstats/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= bsdstats
-PORTVERSION= 3.6
+PORTVERSION= 3.7
CATEGORIES= sysutils
DISTFILES=
diff --git a/sysutils/bsdstats/files/300.statistics b/sysutils/bsdstats/files/300.statistics
index e2124faf7b4e..eace85ccf280 100644
--- a/sysutils/bsdstats/files/300.statistics
+++ b/sysutils/bsdstats/files/300.statistics
@@ -1,6 +1,6 @@
#!/bin/sh -
#
-# $FreeBSD: /tmp/pcvs/ports/sysutils/bsdstats/files/Attic/300.statistics,v 1.19 2006-09-06 00:36:03 scrappy Exp $
+# $FreeBSD: /tmp/pcvs/ports/sysutils/bsdstats/files/Attic/300.statistics,v 1.20 2006-09-07 04:22:27 scrappy Exp $
#
# If there is a global system configuration file, suck it in.
@@ -27,6 +27,10 @@ unset HTTP_USER_AGENT
IFS="
"
+random () {
+ ( ps ax && netstat -a && date ) | sum | cut -c4-5
+}
+
send_devices () {
case $(uname) in
NetBSD | OpenBSD)
@@ -120,7 +124,7 @@ uri_escape () {
do_fetch () {
url="http://$checkin_server/scripts/$1"
- sleep `openssl rand -base64 1 | hexdump -n 1 -e '"%u"'`
+ sleep `random`
case $(uname) in
NetBSD | OpenBSD) /usr/bin/ftp -V -o - "$url" ;;
FreeBSD | *) /usr/bin/fetch -q -o - "$url" ;;
diff --git a/sysutils/bsdstats/files/300.statistics.in b/sysutils/bsdstats/files/300.statistics.in
index bada0e60e2c0..d0da3353ac2c 100644
--- a/sysutils/bsdstats/files/300.statistics.in
+++ b/sysutils/bsdstats/files/300.statistics.in
@@ -1,6 +1,6 @@
#!/bin/sh -
#
-# $FreeBSD: /tmp/pcvs/ports/sysutils/bsdstats/files/300.statistics.in,v 1.19 2006-09-06 00:36:03 scrappy Exp $
+# $FreeBSD: /tmp/pcvs/ports/sysutils/bsdstats/files/300.statistics.in,v 1.20 2006-09-07 04:22:27 scrappy Exp $
#
# If there is a global system configuration file, suck it in.
@@ -27,6 +27,10 @@ unset HTTP_USER_AGENT
IFS="
"
+random () {
+ ( ps ax && netstat -a && date ) | sum | cut -c4-5
+}
+
send_devices () {
case $(uname) in
NetBSD | OpenBSD)
@@ -120,7 +124,7 @@ uri_escape () {
do_fetch () {
url="http://$checkin_server/scripts/$1"
- sleep `openssl rand -base64 1 | hexdump -n 1 -e '"%u"'`
+ sleep `random`
case $(uname) in
NetBSD | OpenBSD) /usr/bin/ftp -V -o - "$url" ;;
FreeBSD | *) /usr/bin/fetch -q -o - "$url" ;;