aboutsummaryrefslogtreecommitdiffstats
path: root/sysutils/cbsd
diff options
context:
space:
mode:
authorkoobs <koobs@FreeBSD.org>2014-07-10 15:39:26 +0800
committerkoobs <koobs@FreeBSD.org>2014-07-10 15:39:26 +0800
commit99c331f997bf9da032c56ef7f0b18a5a6a41cf70 (patch)
tree3ac2ffa17f8f189a07220c5905a842fd2851c872 /sysutils/cbsd
parent3a2f9399ff50b59d70aa44bcf0ddf8a27a5dec9e (diff)
downloadfreebsd-ports-gnome-99c331f997bf9da032c56ef7f0b18a5a6a41cf70.tar.gz
freebsd-ports-gnome-99c331f997bf9da032c56ef7f0b18a5a6a41cf70.tar.zst
freebsd-ports-gnome-99c331f997bf9da032c56ef7f0b18a5a6a41cf70.zip
sysutils/cbsd: Add libsqlite3.so to LIB_DEPENDS
- Add sqlite3 to LIB_DEPENDS - Remove MASTER_SITES, not required when USE_GITHUB=yes - Remove GH_PROJECT, already defaults to ${PORTNAME} - Strip trailing-slash from pkg-descr WWW: URL While I'm here: - Tweak IGNORE message - Tweak pkg-message.in and pkg-deinstall PR: 191772 Submitted by: Oleg Ginzburg <olevole@olevole.ru> (maintainer)
Diffstat (limited to 'sysutils/cbsd')
-rw-r--r--sysutils/cbsd/Makefile10
-rw-r--r--sysutils/cbsd/files/pkg-message.in13
-rw-r--r--sysutils/cbsd/pkg-deinstall49
-rw-r--r--sysutils/cbsd/pkg-descr2
4 files changed, 38 insertions, 36 deletions
diff --git a/sysutils/cbsd/Makefile b/sysutils/cbsd/Makefile
index 3a5525a86635..7702fb6a30b6 100644
--- a/sysutils/cbsd/Makefile
+++ b/sysutils/cbsd/Makefile
@@ -2,10 +2,8 @@
PORTNAME= cbsd
PORTVERSION= 10.0.5
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= sysutils
-MASTER_SITES= http://www.bsdstore.ru/downloads/ \
- GH
MAINTAINER= olevole@olevole.ru
COMMENT= Yet another FreeBSD Jail Management Utility
@@ -15,11 +13,11 @@ LICENSE= BSD2CLAUSE
RUN_DEPENDS= rsync:${PORTSDIR}/net/rsync \
sudo:${PORTSDIR}/security/sudo \
sqlite3:${PORTSDIR}/databases/sqlite3
-LIB_DEPENDS= libssh2.so:${PORTSDIR}/security/libssh2
+LIB_DEPENDS= libssh2.so:${PORTSDIR}/security/libssh2 \
+ libsqlite3.so:${PORTSDIR}/databases/sqlite3
USE_GITHUB= yes
GH_ACCOUNT= olevole
-GH_PROJECT= cbsd
GH_COMMIT= 01f481c
USE_RC_SUBR= cbsdd cbsdrsyncd
@@ -35,7 +33,7 @@ USERS= ${PORTNAME}
GROUPS= ${PORTNAME}
.if ${OSVERSION} < 901000
-IGNORE= does not work on FreeBSD < 9.1
+IGNORE= does not support FreeBSD versions < 9.1
.endif
.if ${OSVERSION} < 902001
diff --git a/sysutils/cbsd/files/pkg-message.in b/sysutils/cbsd/files/pkg-message.in
index 66776710ae83..1d8dd6814113 100644
--- a/sysutils/cbsd/files/pkg-message.in
+++ b/sysutils/cbsd/files/pkg-message.in
@@ -1,14 +1,15 @@
===============================================================================
-cbsd is now installed, but it requires some additional setup.
-For the first time please run:
+cbsd is now installed, but requires additional setup steps:
- env workdir="/path" %%PREFIX%%/cbsd/sudoexec/initenv
+Upon initial installation, run:
-where /path is path for cbsd workdir, e.g.: /usr/jails
+ env workdir="/path" %%PREFIX%%/cbsd/sudoexec/initenv
-For upgrade an existing installation:
+Where /path is the path to the cbsd workdir, e.g.: /usr/jails
- cbsd initenv
+For upgrading an existing installation, run:
+
+ cbsd initenv
===============================================================================
diff --git a/sysutils/cbsd/pkg-deinstall b/sysutils/cbsd/pkg-deinstall
index e5992bdbde7b..3dd7f6f7b0dd 100644
--- a/sysutils/cbsd/pkg-deinstall
+++ b/sysutils/cbsd/pkg-deinstall
@@ -3,29 +3,32 @@ case $2 in
POST-DEINSTALL)
echo
echo "The cbsd package has been deleted."
- echo "If you're *not* upgrading and won't be using it any longer, you may want to"
- echo "check some files in the system which could modify by cbsd and remove this"
- echo "changes for complete deinstall. Specifically:"
- echo
- echo "1) follow records in the /var/cron/tabs/root file:"
- echo "* * * * * /usr/bin/lockf -s -t0 \$workdir/ftmp/periodic_minutes \\"
- echo "/usr/sbin/periodic minutes > /dev/null 2>&1"
- echo "0 * * * * /usr/bin/lockf -s -t0 \$workdir/ftmp/periodic_hourly \\"
- echo "/usr/sbin/periodic hourly > /dev/null 2>&1"
- echo
- echo "2) follow record in the /etc/periodic.conf file:"
- echo "local_periodic=\"/usr/local/etc/periodic \$workdir/etc/periodic\""
- echo
- echo "3) follow records in the /etc/rc.conf file:"
- echo "cbsdrsyncd_enable=\"YES\""
- echo "cbsdrsyncd_flags=\"--config=\$workdir/etc/rsyncd.conf\""
- echo "cbsdd_enable=\"YES\""
- echo "devfs_load_rulesets=\"YES\""
- echo "cbsd_workdir=\"\$workdir\""
- echo "rcshutdown_timeout=\"900\""
- echo "sshd_flags=\"-oPort=22222\""
- echo
- echo "4) /usr/local/etc/sudoers.d/cbsd_sudoers file"
+ echo
+ echo "If you are *not* upgrading this package, you may want to"
+ echo "remove the following to complete the deinstallation process:"
+ echo
+ echo "1) Records in /var/cron/tabs/root"
+ echo
+ echo " * * * * * /usr/bin/lockf -s -t0 \$workdir/ftmp/periodic_minutes \\"
+ echo " /usr/sbin/periodic minutes > /dev/null 2>&1"
+ echo " 0 * * * * /usr/bin/lockf -s -t0 \$workdir/ftmp/periodic_hourly \\"
+ echo " /usr/sbin/periodic hourly > /dev/null 2>&1"
+ echo
+ echo "2) Records in /etc/periodic.conf"
+ echo
+ echo " local_periodic=\"/usr/local/etc/periodic \$workdir/etc/periodic\""
+ echo
+ echo "3) Records in /etc/rc.conf"
+ echo
+ echo " cbsdrsyncd_enable=\"YES\""
+ echo " cbsdrsyncd_flags=\"--config=\$workdir/etc/rsyncd.conf\""
+ echo " cbsdd_enable=\"YES\""
+ echo " devfs_load_rulesets=\"YES\""
+ echo " cbsd_workdir=\"\$workdir\""
+ echo " rcshutdown_timeout=\"900\""
+ echo " sshd_flags=\"-oPort=22222\""
+ echo
+ echo "4) Remove /usr/local/etc/sudoers.d/cbsd_sudoers"
echo
;;
esac
diff --git a/sysutils/cbsd/pkg-descr b/sysutils/cbsd/pkg-descr
index 841db8f7cddd..b392c35c29cb 100644
--- a/sysutils/cbsd/pkg-descr
+++ b/sysutils/cbsd/pkg-descr
@@ -1,3 +1,3 @@
Yet another FreeBSD jail management tool.
-WWW: http://www.bsdstore.ru/
+WWW: http://www.bsdstore.ru