aboutsummaryrefslogtreecommitdiffstats
path: root/sysutils/cdrdao/Makefile
diff options
context:
space:
mode:
authorlinimon <linimon@FreeBSD.org>2018-06-11 09:44:15 +0800
committerlinimon <linimon@FreeBSD.org>2018-06-11 09:44:15 +0800
commit39e31de51fbf694ff20f162572dc22c61f7d1b9d (patch)
treed21fd4ee60da4c705d6bb2d4d0222a7e7af7ef7b /sysutils/cdrdao/Makefile
parent1ddd46af14a4033deba9f651fa531f8aa83ea3f7 (diff)
downloadfreebsd-ports-gnome-39e31de51fbf694ff20f162572dc22c61f7d1b9d.tar.gz
freebsd-ports-gnome-39e31de51fbf694ff20f162572dc22c61f7d1b9d.tar.zst
freebsd-ports-gnome-39e31de51fbf694ff20f162572dc22c61f7d1b9d.zip
Fix port builds for architectures which remain on gcc as the default compiler.
This will primarily help powerpc64. For archs where clang is the default compiler, these changes will have no effect, as the base compiler already has these capabilities (primarily, but not exclusively, c++-11). Tested for no-harm on amd64. While here, pet portlint. Approved by: portmgr (tier-2 blanket)
Diffstat (limited to 'sysutils/cdrdao/Makefile')
-rw-r--r--sysutils/cdrdao/Makefile6
1 files changed, 1 insertions, 5 deletions
diff --git a/sysutils/cdrdao/Makefile b/sysutils/cdrdao/Makefile
index 0ee2053f5e36..34b3cf38d694 100644
--- a/sysutils/cdrdao/Makefile
+++ b/sysutils/cdrdao/Makefile
@@ -13,13 +13,9 @@ COMMENT?= Record CD-R[W]s in disk-at-once mode
LICENSE= GPLv2
-BROKEN_mips= fails to compile: cc1plus: error: unrecognized command line option "-std=c++11"
-BROKEN_mips64= fails to compile: cc1plus: error: unrecognized command line option "-std=c++11"
-BROKEN_powerpc64= fails to compile: cc1plus: error: unrecognized command line option "-std=c++11"
-
+USES= alias compiler:c++11-lang gmake tar:bzip2
GNU_CONFIGURE= yes
USE_CXXSTD= c++11
-USES= alias gmake tar:bzip2
MP3OGG_LIB_DEPENDS= libao.so:audio/libao \
libmad.so:audio/libmad \