aboutsummaryrefslogtreecommitdiffstats
path: root/sysutils/cdrdao
diff options
context:
space:
mode:
authornetchild <netchild@FreeBSD.org>2004-03-06 00:37:33 +0800
committernetchild <netchild@FreeBSD.org>2004-03-06 00:37:33 +0800
commit629567787aae3da46762c60a16b30d5647ae5b8d (patch)
tree108fb9298354e01e9f6dad74e10b458bc88d44e6 /sysutils/cdrdao
parent3356daa1bf4855dd6144f43a953678ae5129c555 (diff)
downloadfreebsd-ports-gnome-629567787aae3da46762c60a16b30d5647ae5b8d.tar.gz
freebsd-ports-gnome-629567787aae3da46762c60a16b30d5647ae5b8d.tar.zst
freebsd-ports-gnome-629567787aae3da46762c60a16b30d5647ae5b8d.zip
Change the progress meter back to not print newlines on update, this
annoying behaviour unintentionally got introduced shortly before 1.1.8 was released. This patch also went into the cdrdao repository. Submitted by: maintainer
Diffstat (limited to 'sysutils/cdrdao')
-rw-r--r--sysutils/cdrdao/Makefile2
-rw-r--r--sysutils/cdrdao/files/patch-dao::dao.cc15
2 files changed, 16 insertions, 1 deletions
diff --git a/sysutils/cdrdao/Makefile b/sysutils/cdrdao/Makefile
index 32161655427f..69f45006a64e 100644
--- a/sysutils/cdrdao/Makefile
+++ b/sysutils/cdrdao/Makefile
@@ -7,7 +7,7 @@
PORTNAME?= cdrdao
PORTVERSION= 1.1.8
-PORTREVISION?= 0
+PORTREVISION?= 1
CATEGORIES= sysutils audio
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= cdrdao
diff --git a/sysutils/cdrdao/files/patch-dao::dao.cc b/sysutils/cdrdao/files/patch-dao::dao.cc
new file mode 100644
index 000000000000..c0ff14ae54c8
--- /dev/null
+++ b/sysutils/cdrdao/files/patch-dao::dao.cc
@@ -0,0 +1,15 @@
+--- dao/dao.cc.orig Thu Feb 12 02:13:31 2004
++++ dao/dao.cc Tue Mar 2 17:22:11 2004
+@@ -388,10 +388,10 @@
+ if (cdr->readBufferCapacity(&totalcap, &availcap)) {
+ writerFill = (int)((1.0 - ((double)availcap / (double)totalcap))
+ * 100.0);
+- message(1, "Wrote %ld of %ld MB (Buffers %3d%% %3d%%).\n",
++ message(1, "Wrote %ld of %ld MB (Buffers %3d%% %3d%%).\r",
+ cnt >> 20, total >> 20, buffFill, writerFill);
+ } else {
+- message(1, "Wrote %ld of %ld MB (Buffer %3d%%).\n",
++ message(1, "Wrote %ld of %ld MB (Buffer %3d%%).\r",
+ cnt >> 20, total >> 20, buffFill);
+ }
+ lastMb = cntMb;