aboutsummaryrefslogtreecommitdiffstats
path: root/sysutils/cdrdao
diff options
context:
space:
mode:
authormarius <marius@FreeBSD.org>2006-05-08 00:47:24 +0800
committermarius <marius@FreeBSD.org>2006-05-08 00:47:24 +0800
commit078b59a68b9f95fc1841541915e11628c92b214f (patch)
treecbd1ea5b677b4634e100f03b2ce7b28aaed4e406 /sysutils/cdrdao
parent2cb2dba136adadeb42826eb8d61448435c3945e4 (diff)
downloadfreebsd-ports-gnome-078b59a68b9f95fc1841541915e11628c92b214f.tar.gz
freebsd-ports-gnome-078b59a68b9f95fc1841541915e11628c92b214f.tar.zst
freebsd-ports-gnome-078b59a68b9f95fc1841541915e11628c92b214f.zip
- Allow this port to be compiled with CC set to something containing a
path component. - Remove obsolete USE_REINPLACE. Approved by: netchild
Diffstat (limited to 'sysutils/cdrdao')
-rw-r--r--sysutils/cdrdao/Makefile10
1 files changed, 6 insertions, 4 deletions
diff --git a/sysutils/cdrdao/Makefile b/sysutils/cdrdao/Makefile
index 9abf8d8945a1..88f40b39403e 100644
--- a/sysutils/cdrdao/Makefile
+++ b/sysutils/cdrdao/Makefile
@@ -20,7 +20,6 @@ BUILD_DEPENDS= ${LOCALBASE}/bin/antlr:${PORTSDIR}/devel/pccts \
${LOCALBASE}/bin/dlg:${PORTSDIR}/devel/pccts
USE_GMAKE= yes
-USE_REINPLACE= yes
GNU_CONFIGURE= yes
MP3OGG_LIB_DEPENDS= ao.3:${PORTSDIR}/audio/libao \
@@ -60,10 +59,13 @@ CONFIGURE_ARGS+= --with-pcctsbin=${LOCALBASE}/bin \
--with-pcctsinc=${LOCALBASE}/include/pccts \
--without-posix-threads --with-scglib=pkg
CONFIGURE_TARGET= --build=${ARCH}-portbld-freebsd${OSREL}
-MAKE_ENV= LANG=C
.include <bsd.port.pre.mk>
+CCOM!= ${BASENAME} ${CC}
+MAKE_ENV= CCOM=${CCOM} LANG=C
+SCSILIBTARGET= ${ARCH}-freebsd-${CCOM}
+
pre-everything::
.if ${PORTNAME} != "gcdmaster" && \
(!defined(WITH_TOC2MP3) || !defined(WITHOUT_MP3OGG))
@@ -82,9 +84,9 @@ pre-everything::
.endif
post-extract:
-.if ${ARCH} != "i386" || ${CC} != "cc"
+.if ${SCSILIBTARGET} != "i386-freebsd-cc"
@${LN} -sf ${WRKSRC}/scsilib/RULES/i386-freebsd-cc.rul \
- ${WRKSRC}/scsilib/RULES/${ARCH}-freebsd-${CC}.rul
+ ${WRKSRC}/scsilib/RULES/${SCSILIBTARGET}.rul
.endif
post-patch: