aboutsummaryrefslogtreecommitdiffstats
path: root/sysutils/ciso
diff options
context:
space:
mode:
authorpav <pav@FreeBSD.org>2010-02-07 23:35:58 +0800
committerpav <pav@FreeBSD.org>2010-02-07 23:35:58 +0800
commit22cb7e603300b26b3a69f81ca6a32918471551fa (patch)
tree7793d9d19beec817cab247309771988b9fc2ad42 /sysutils/ciso
parent431c96335ac2600e3d03ba95d6f5df3799394cc6 (diff)
downloadfreebsd-ports-gnome-22cb7e603300b26b3a69f81ca6a32918471551fa.tar.gz
freebsd-ports-gnome-22cb7e603300b26b3a69f81ca6a32918471551fa.tar.zst
freebsd-ports-gnome-22cb7e603300b26b3a69f81ca6a32918471551fa.zip
- Fix runtime on 64-bit platforms
PR: ports/142711 Submitted by: Jonathan Jacobs <jonathan+freebsd@jsphere.com> Approved by: maintainer timeout (26 days)
Diffstat (limited to 'sysutils/ciso')
-rw-r--r--sysutils/ciso/Makefile2
-rw-r--r--sysutils/ciso/files/patch-ciso.h23
2 files changed, 25 insertions, 0 deletions
diff --git a/sysutils/ciso/Makefile b/sysutils/ciso/Makefile
index ef6699dd463a..1066985a9729 100644
--- a/sysutils/ciso/Makefile
+++ b/sysutils/ciso/Makefile
@@ -7,12 +7,14 @@
PORTNAME= ciso
PORTVERSION= 1.0.0
+PORTREVISION= 1
CATEGORIES= sysutils
MASTER_SITES= http://ciso.tenshu.fr/
MAINTAINER= blttll@gmail.com
COMMENT= A tool to compress ISO images to CSO format
+USE_DOS2UNIX= yes
PLIST_FILES= bin/ciso
.include <bsd.port.mk>
diff --git a/sysutils/ciso/files/patch-ciso.h b/sysutils/ciso/files/patch-ciso.h
new file mode 100644
index 000000000000..7fd25c9a8d7d
--- /dev/null
+++ b/sysutils/ciso/files/patch-ciso.h
@@ -0,0 +1,23 @@
+--- ciso.h.orig 2010-02-07 16:32:56.000000000 +0100
++++ ciso.h 2010-02-07 16:33:38.000000000 +0100
+@@ -19,6 +19,8 @@
+ Copyright 2005 BOOSTER
+ */
+
++#include <stdint.h>
++
+
+ #ifndef __CISO_H__
+ #define __CISO_H__
+@@ -28,9 +30,9 @@
+ typedef struct ciso_header
+ {
+ unsigned char magic[4]; /* +00 : 'C','I','S','O' */
+- unsigned long header_size; /* +04 : header size (==0x18) */
++ uint32_t header_size; /* +04 : header size (==0x18) */
+ unsigned long long total_bytes; /* +08 : number of original data size */
+- unsigned long block_size; /* +10 : number of compressed block size */
++ uint32_t block_size; /* +10 : number of compressed block size */
+ unsigned char ver; /* +14 : version 01 */
+ unsigned char align; /* +15 : align of index value */
+ unsigned char rsv_06[2]; /* +16 : reserved */