aboutsummaryrefslogtreecommitdiffstats
path: root/sysutils/clone
diff options
context:
space:
mode:
authorjgh <jgh@FreeBSD.org>2013-02-08 13:43:07 +0800
committerjgh <jgh@FreeBSD.org>2013-02-08 13:43:07 +0800
commite46880d5ab89df6bc18a26ff8336f615bc34514a (patch)
treeb55d42ae79f4129e1316e150f04b45399a0fb64c /sysutils/clone
parent1918af9f5265f62032470870e7b36adb0a41c29d (diff)
downloadfreebsd-ports-gnome-e46880d5ab89df6bc18a26ff8336f615bc34514a.tar.gz
freebsd-ports-gnome-e46880d5ab89df6bc18a26ff8336f615bc34514a.tar.zst
freebsd-ports-gnome-e46880d5ab89df6bc18a26ff8336f615bc34514a.zip
add new port: sysutils/clone
clone is a file tree cloning tool which runs 3 threads - a scheduler (main), a reader, and a writer thread. Reading and writing occurs in parallel. While this is most beneficial for copying data from one physical disk to another, clone is also very well suited for cloning a file tree to any place on the same disk. Cloning includes the whole directory hierarchy, i.e. sub-directories, files, hard links, symbolic links, attributes (modes, flags, times), extended attributes and access control lists. clone is useful for cloning (thus backing-up) live file systems, and it can also be used in incremental and synchronization mode. clone works on FreeBSD and Mac OS X. clone is very fast, for example, cloning a whole UFS2 file hierarchy on FreeBSD 9.1 of in total 2.3 TBytes of data from one hard disk to another took 7.5 h, so the average transfer rate for all kind of files (very small up to very big ones) was about 89 MByte/s. WWW: https://code.google.com/p/clone/ PR: 175945 Submitted by: cyclaero@gmail.com
Diffstat (limited to 'sysutils/clone')
-rw-r--r--sysutils/clone/Makefile21
-rw-r--r--sysutils/clone/distinfo2
-rw-r--r--sysutils/clone/pkg-descr20
3 files changed, 43 insertions, 0 deletions
diff --git a/sysutils/clone/Makefile b/sysutils/clone/Makefile
new file mode 100644
index 000000000000..ddab3145f0fd
--- /dev/null
+++ b/sysutils/clone/Makefile
@@ -0,0 +1,21 @@
+# $FreeBSD$
+
+PORTNAME= clone
+PORTVERSION= r18
+CATEGORIES= sysutils
+MASTER_SITES= GOOGLE_CODE
+
+MAINTAINER= cyclaero@gmail.com
+COMMENT= File tree cloning tool
+
+LICENSE= BSD
+
+PLIST_FILES= bin/clone
+
+MAN1= clone.1
+
+post-patch-script:
+ @${REINPLACE_CMD} 's|^CC = gcc|CC ?= gcc|' \
+ ${WRKSRC}/Makefile
+
+.include <bsd.port.mk>
diff --git a/sysutils/clone/distinfo b/sysutils/clone/distinfo
new file mode 100644
index 000000000000..76db41f3c03f
--- /dev/null
+++ b/sysutils/clone/distinfo
@@ -0,0 +1,2 @@
+SHA256 (clone-r18.tar.gz) = 0f859fc43332b94c6a8595d2af8a24f7842e3cb2ca5f9f085b393296a4e8a16d
+SIZE (clone-r18.tar.gz) = 20977
diff --git a/sysutils/clone/pkg-descr b/sysutils/clone/pkg-descr
new file mode 100644
index 000000000000..bd8ecc16a656
--- /dev/null
+++ b/sysutils/clone/pkg-descr
@@ -0,0 +1,20 @@
+clone is a file tree cloning tool which runs 3 threads - a scheduler (main), a
+reader, and a writer thread. Reading and writing occurs in parallel. While this
+is most beneficial for copying data from one physical disk to another, clone is
+also very well suited for cloning a file tree to any place on the same disk.
+
+Cloning includes the whole directory hierarchy, i.e. sub-directories, files,
+hard links, symbolic links, attributes (modes, flags, times), extended
+attributes and access control lists.
+
+clone is useful for cloning (thus backing-up) live file systems, and it can
+also be used in incremental and synchronization mode.
+
+clone works on FreeBSD and Mac OS X.
+
+clone is very fast, for example, cloning a whole UFS2 file hierarchy on
+FreeBSD 9.1 of in total 2.3 TBytes of data from one hard disk to another
+took 7.5 h, so the average transfer rate for all kind of files (very small
+up to very big ones) was about 89 MByte/s.
+
+WWW: https://code.google.com/p/clone/