aboutsummaryrefslogtreecommitdiffstats
path: root/sysutils/conky-awesome/Makefile
diff options
context:
space:
mode:
authornovel <novel@FreeBSD.org>2006-05-23 01:01:14 +0800
committernovel <novel@FreeBSD.org>2006-05-23 01:01:14 +0800
commit65079eb6f7fedaf387054eee052829e154681f82 (patch)
treedd6d1cbad4eae7dde07d605ae6a9834a2e184a59 /sysutils/conky-awesome/Makefile
parent3690d7009fc7c944230410e509113e6ca3d89a43 (diff)
downloadfreebsd-ports-gnome-65079eb6f7fedaf387054eee052829e154681f82.tar.gz
freebsd-ports-gnome-65079eb6f7fedaf387054eee052829e154681f82.tar.zst
freebsd-ports-gnome-65079eb6f7fedaf387054eee052829e154681f82.zip
- Update to 1.4.2
- Replace BROKEN with IGNORE since it's not going to be supported on 4.x ever
Diffstat (limited to 'sysutils/conky-awesome/Makefile')
-rw-r--r--sysutils/conky-awesome/Makefile12
1 files changed, 8 insertions, 4 deletions
diff --git a/sysutils/conky-awesome/Makefile b/sysutils/conky-awesome/Makefile
index a46c2f003d10..4b81c2c6b6a1 100644
--- a/sysutils/conky-awesome/Makefile
+++ b/sysutils/conky-awesome/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= conky
-PORTVERSION= 1.4.1
+PORTVERSION= 1.4.2
CATEGORIES= sysutils
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
@@ -16,10 +16,11 @@ COMMENT= An advanced, highly configurable system monitor for X
USE_BZIP2= yes
HAS_CONFIGURE= yes
+USE_ICONV= yes
USE_X_PREFIX= yes
CONFIGURE_ARGS+= --disable-portmon --disable-proc-uptime
-CONFIGURE_ENV+= CFLAGS="${CFLAGS} -I${X11BASE}/include" \
- LDFLAGS="${LDFLAGS} -L${X11BASE}/lib"
+CONFIGURE_ENV+= CFLAGS="${CFLAGS} -I${X11BASE}/include -I${LOCALBASE}/include" \
+ LDFLAGS="${LDFLAGS} -L${X11BASE}/lib -L${LOCALBASE}/lib"
MAN1= conky.1
@@ -68,6 +69,9 @@ pre-everything::
@${ECHO_MSG} "WITHOUT_DOUBLE_BUFFER=yes to disable double buffer support"
@${ECHO_MSG} " "
+post-configure:
+ @${REINPLACE_CMD} -e 's|-lm|-lm -liconv|' ${WRKSRC}/src/Makefile
+
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/src/conky ${PREFIX}/bin
${INSTALL_MAN} ${WRKSRC}/doc/conky.1 ${PREFIX}/man/man1
@@ -89,7 +93,7 @@ post-install:
.include <bsd.port.pre.mk>
.if ${OSVERSION} < 500000
-BROKEN= "Doesn't compile on 4.x"
+IGNORE= not supported on 4.x
.endif
.include <bsd.port.post.mk>