aboutsummaryrefslogtreecommitdiffstats
path: root/sysutils/conky-awesome
diff options
context:
space:
mode:
authornovel <novel@FreeBSD.org>2007-08-20 14:52:59 +0800
committernovel <novel@FreeBSD.org>2007-08-20 14:52:59 +0800
commit3ca7756a3f4d508a85afe9bbd5f47fb030eb3a18 (patch)
treeda0cabac8f49e6130f57e5241d3d7b21f5af3418 /sysutils/conky-awesome
parentc131ac0f379ca4b779f0e3c569049736e3f17f13 (diff)
downloadfreebsd-ports-gnome-3ca7756a3f4d508a85afe9bbd5f47fb030eb3a18.tar.gz
freebsd-ports-gnome-3ca7756a3f4d508a85afe9bbd5f47fb030eb3a18.tar.zst
freebsd-ports-gnome-3ca7756a3f4d508a85afe9bbd5f47fb030eb3a18.zip
Update to 1.4.6.
Diffstat (limited to 'sysutils/conky-awesome')
-rw-r--r--sysutils/conky-awesome/Makefile3
-rw-r--r--sysutils/conky-awesome/distinfo6
-rw-r--r--sysutils/conky-awesome/files/patch-src-freebsd.c24
3 files changed, 19 insertions, 14 deletions
diff --git a/sysutils/conky-awesome/Makefile b/sysutils/conky-awesome/Makefile
index 692ba1aec391..345287f96e51 100644
--- a/sysutils/conky-awesome/Makefile
+++ b/sysutils/conky-awesome/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= conky
-PORTVERSION= 1.4.5
-PORTREVISION= 1
+PORTVERSION= 1.4.6
CATEGORIES= sysutils
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
diff --git a/sysutils/conky-awesome/distinfo b/sysutils/conky-awesome/distinfo
index ffd9cc7046b2..77027c978eb9 100644
--- a/sysutils/conky-awesome/distinfo
+++ b/sysutils/conky-awesome/distinfo
@@ -1,3 +1,3 @@
-MD5 (conky-1.4.5.tar.bz2) = 4625c052852f2919a5e7ce2eb7c31189
-SHA256 (conky-1.4.5.tar.bz2) = beb77ec55399dfa65f76330ba5ff65873028b24f3a768f4780e965d9bc5fd63b
-SIZE (conky-1.4.5.tar.bz2) = 390741
+MD5 (conky-1.4.6.tar.bz2) = fdada1c19d7349de8929414302575983
+SHA256 (conky-1.4.6.tar.bz2) = 31146c36fd0b3cb52e06cd01d25bb8a4c7c77d1fcdd00e9fd15db977af0145de
+SIZE (conky-1.4.6.tar.bz2) = 408742
diff --git a/sysutils/conky-awesome/files/patch-src-freebsd.c b/sysutils/conky-awesome/files/patch-src-freebsd.c
index 1e5c74bf5dc6..b0fe6b78d7a0 100644
--- a/sysutils/conky-awesome/files/patch-src-freebsd.c
+++ b/sysutils/conky-awesome/files/patch-src-freebsd.c
@@ -1,11 +1,17 @@
---- src/freebsd.c.orig Sat Apr 14 20:21:32 2007
-+++ src/freebsd.c Sat Apr 14 20:21:54 2007
-@@ -530,7 +530,7 @@
- snprintf(p_client_buffer, client_buffer_size, p_format,
- (float)((cycles[1] - cycles[0]) / microseconds) / divisor);
- #else
-- get_freq(p_client_buffer, client_buffer_size, p_format, divisor);
-+ get_freq(p_client_buffer, client_buffer_size, p_format, divisor, 1);
+--- src/freebsd.c.orig 2007-08-05 08:48:13.000000000 +0400
++++ src/freebsd.c 2007-08-19 23:15:54.000000000 +0400
+@@ -43,6 +43,14 @@
+ #define FREEBSD_DEBUG
#endif
- }
++#if __FreeBSD_version > 700050
++struct wi_req {
++ u_int16_t wi_len;
++ u_int16_t wi_type;
++ u_int16_t wi_val[WI_MAX_DATALEN];
++};
++#endif
++
+ inline void proc_find_top(struct process **cpu, struct process **mem);
+
+ u_int64_t diskio_prev = 0;