aboutsummaryrefslogtreecommitdiffstats
path: root/sysutils/cpdup
diff options
context:
space:
mode:
authorwxs <wxs@FreeBSD.org>2010-09-26 06:04:19 +0800
committerwxs <wxs@FreeBSD.org>2010-09-26 06:04:19 +0800
commit73b14b6172057eb9f37c6696248ac817a41b51aa (patch)
tree1d4238eee0ed38af3d4619d4faa7c59c0cf6423a /sysutils/cpdup
parent47e1e3167e66555e4c537b11195563ce64ae0e41 (diff)
downloadfreebsd-ports-gnome-73b14b6172057eb9f37c6696248ac817a41b51aa.tar.gz
freebsd-ports-gnome-73b14b6172057eb9f37c6696248ac817a41b51aa.tar.zst
freebsd-ports-gnome-73b14b6172057eb9f37c6696248ac817a41b51aa.zip
Fix off-by-one error.
PR: ports/150618 Submitted by: Oliver Fromme <olli@secnetix.de> Approved by: Gianmarco Giovannelli <gmarco@gufi.org> (maintainer) Obtained from: http://gitweb.dragonflybsd.org/dragonfly.git/commitdiff/704cef5251497a4f675f5554fa763c18fb622a5b
Diffstat (limited to 'sysutils/cpdup')
-rw-r--r--sysutils/cpdup/Makefile1
-rw-r--r--sysutils/cpdup/files/patch-hclink.c11
2 files changed, 12 insertions, 0 deletions
diff --git a/sysutils/cpdup/Makefile b/sysutils/cpdup/Makefile
index 6bbe78e2fd8b..95c981082aaa 100644
--- a/sysutils/cpdup/Makefile
+++ b/sysutils/cpdup/Makefile
@@ -7,6 +7,7 @@
PORTNAME= cpdup
PORTVERSION= 1.17
+PORTREVISION= 1
CATEGORIES= sysutils
MASTER_SITES= http://apollo.backplane.com/FreeSrc/ \
http://utenti.gufi.org/~gmarco/files/distfiles/
diff --git a/sysutils/cpdup/files/patch-hclink.c b/sysutils/cpdup/files/patch-hclink.c
new file mode 100644
index 000000000000..c69fc19c5e56
--- /dev/null
+++ b/sysutils/cpdup/files/patch-hclink.c
@@ -0,0 +1,11 @@
+--- ./hclink.c.orig 2010-09-25 18:01:27.989863475 -0400
++++ ./hclink.c 2010-09-25 18:01:46.138176079 -0400
+@@ -388,7 +388,7 @@
+ hcc_check_space(hctransaction_t trans, struct HCHead *head, int n, int size)
+ {
+ size = HCC_ALIGN(size) + n * sizeof(struct HCLeaf);
+- if (size > HC_BUFSIZE - trans->windex) {
++ if (size >= HC_BUFSIZE - trans->windex) {
+ struct HCHead *whead = (void *)trans->wbuf;
+
+ whead->cmd |= HCF_CONTINUE;