aboutsummaryrefslogtreecommitdiffstats
path: root/sysutils/cpdup
diff options
context:
space:
mode:
authorvs <vs@FreeBSD.org>2006-04-25 23:52:08 +0800
committervs <vs@FreeBSD.org>2006-04-25 23:52:08 +0800
commit7331ef1a96bd51fe591d2f1dd302d768f4df0a41 (patch)
treec45983d32eeff1de2f27310fe8f2f19ba00ebbc6 /sysutils/cpdup
parent8c7e231107c36799035b5d1ffcbca5f15c058cf2 (diff)
downloadfreebsd-ports-gnome-7331ef1a96bd51fe591d2f1dd302d768f4df0a41.tar.gz
freebsd-ports-gnome-7331ef1a96bd51fe591d2f1dd302d768f4df0a41.tar.zst
freebsd-ports-gnome-7331ef1a96bd51fe591d2f1dd302d768f4df0a41.zip
Skip inodes with snapshot flag on (bump PORTREV)
PR: ports/96252 Submitted by: marck@
Diffstat (limited to 'sysutils/cpdup')
-rw-r--r--sysutils/cpdup/Makefile1
-rw-r--r--sysutils/cpdup/files/patch-cpdup.c17
2 files changed, 18 insertions, 0 deletions
diff --git a/sysutils/cpdup/Makefile b/sysutils/cpdup/Makefile
index 4f1e7159d047..6f9dd82539de 100644
--- a/sysutils/cpdup/Makefile
+++ b/sysutils/cpdup/Makefile
@@ -7,6 +7,7 @@
PORTNAME= cpdup
PORTVERSION= 1.05
+PORTREVISION= 1
CATEGORIES= sysutils
MASTER_SITES= http://apollo.backplane.com/FreeBSDPorts/
#MASTER_SITE_SUBDIR= cp
diff --git a/sysutils/cpdup/files/patch-cpdup.c b/sysutils/cpdup/files/patch-cpdup.c
new file mode 100644
index 000000000000..aa5c1fca53ea
--- /dev/null
+++ b/sysutils/cpdup/files/patch-cpdup.c
@@ -0,0 +1,17 @@
+
+$FreeBSD$
+
+--- cpdup.c.orig
++++ cpdup.c
+@@ -321,6 +321,11 @@
+
+ if (lstat(spath, &st1) != 0)
+ return(0);
++#ifdef SF_SNAPSHOT
++ /* skip snapshot files: we cannot handle files larger than file system */
++ if (st1.st_flags & SF_SNAPSHOT)
++ return(0);
++#endif
+ st2.st_mode = 0; /* in case lstat fails */
+ st2.st_flags = 0; /* in case lstat fails */
+ if (dpath && lstat(dpath, &st2) == 0)