aboutsummaryrefslogtreecommitdiffstats
path: root/sysutils/cpu
diff options
context:
space:
mode:
authorperky <perky@FreeBSD.org>2003-11-16 04:17:59 +0800
committerperky <perky@FreeBSD.org>2003-11-16 04:17:59 +0800
commita97ea4720c7a7ee2b790e4e2fab70676ba2ef16c (patch)
treeb4e50de312ba0568663ee687280858f50ffc8bbd /sysutils/cpu
parent7203646bf83b220cee1c0e3eb55e519b12db2a24 (diff)
downloadfreebsd-ports-gnome-a97ea4720c7a7ee2b790e4e2fab70676ba2ef16c.tar.gz
freebsd-ports-gnome-a97ea4720c7a7ee2b790e4e2fab70676ba2ef16c.tar.zst
freebsd-ports-gnome-a97ea4720c7a7ee2b790e4e2fab70676ba2ef16c.zip
Add port for cpu-1.4.2,
an LDAP user management tool written in C and loosely based on FreeBSD's pw(8).
Diffstat (limited to 'sysutils/cpu')
-rw-r--r--sysutils/cpu/Makefile25
-rw-r--r--sysutils/cpu/distinfo1
-rw-r--r--sysutils/cpu/pkg-descr7
-rw-r--r--sysutils/cpu/pkg-plist7
4 files changed, 40 insertions, 0 deletions
diff --git a/sysutils/cpu/Makefile b/sysutils/cpu/Makefile
new file mode 100644
index 000000000000..4ae768878e87
--- /dev/null
+++ b/sysutils/cpu/Makefile
@@ -0,0 +1,25 @@
+# New ports collection makefile for: cpu
+# Date created: 15 November 2003
+# Whom: Hye-Shik Chang <perky@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= cpu
+PORTVERSION= 1.4.2
+CATEGORIES= sysutils
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= cpu
+
+MAINTAINER= perky@FreeBSD.org
+COMMENT= Change Password Utility for LDAP
+
+GNU_CONFIGURE= yes
+USE_OPENLDAP= yes
+INSTALLS_SHLIB= yes
+CONFIGURE_ARGS= --datadir=${PREFIX}/share/cpu --with-ldap=${LOCALBASE}
+
+MAN5= cpu.conf.5
+MAN8= cpu.8 cpu-ldap.8
+
+.include <bsd.port.mk>
diff --git a/sysutils/cpu/distinfo b/sysutils/cpu/distinfo
new file mode 100644
index 000000000000..cb82bb509a13
--- /dev/null
+++ b/sysutils/cpu/distinfo
@@ -0,0 +1 @@
+MD5 (cpu-1.4.2.tar.gz) = cfbad78c8c54faa7143793c2f88b0ce4
diff --git a/sysutils/cpu/pkg-descr b/sysutils/cpu/pkg-descr
new file mode 100644
index 000000000000..79b899743f9c
--- /dev/null
+++ b/sysutils/cpu/pkg-descr
@@ -0,0 +1,7 @@
+CPU is an LDAP user management tool written in C and loosely based
+on FreeBSD's pw(8). The goal of CPU is to be a suitable replacement
+of the useradd/usermod/userdel utilities for administrators using
+an LDAP backend and wishing to have a suite of command line tools
+for doing the administration.
+
+WWW: http://cpu.sourceforge.net/
diff --git a/sysutils/cpu/pkg-plist b/sysutils/cpu/pkg-plist
new file mode 100644
index 000000000000..2b32692db6ec
--- /dev/null
+++ b/sysutils/cpu/pkg-plist
@@ -0,0 +1,7 @@
+bin/cpu
+etc/cpu.conf
+lib/libcputil.a
+lib/libcputil.la
+lib/libcputil.so.0
+%%DATADIR%%/cpu.conf.doc
+%%DATADIR%%/test.ldif