aboutsummaryrefslogtreecommitdiffstats
path: root/sysutils/cpuid
diff options
context:
space:
mode:
authorfernape <fernape@FreeBSD.org>2018-05-24 00:10:05 +0800
committerfernape <fernape@FreeBSD.org>2018-05-24 00:10:05 +0800
commit5402e3a1c835c3a26543f5f145ee1aa647dcc0f2 (patch)
tree4fc974b811fad0733b7ea9968e64da8d654a175b /sysutils/cpuid
parenta903e5d2c09dba9d16fe7ddbd84f32546a591344 (diff)
downloadfreebsd-ports-gnome-5402e3a1c835c3a26543f5f145ee1aa647dcc0f2.tar.gz
freebsd-ports-gnome-5402e3a1c835c3a26543f5f145ee1aa647dcc0f2.tar.zst
freebsd-ports-gnome-5402e3a1c835c3a26543f5f145ee1aa647dcc0f2.zip
Update sysutils/cpuid to 20180419
PR: 227811 Submitted by: pkubaj@anongoth.pl (maintainer) Approved by: tcberner (mentor) Differential Revision: https://reviews.freebsd.org/D15515
Diffstat (limited to 'sysutils/cpuid')
-rw-r--r--sysutils/cpuid/Makefile6
-rw-r--r--sysutils/cpuid/distinfo6
-rw-r--r--sysutils/cpuid/files/patch-cpuid.c30
3 files changed, 27 insertions, 15 deletions
diff --git a/sysutils/cpuid/Makefile b/sysutils/cpuid/Makefile
index 3fefb5845740..d80519b6a2c3 100644
--- a/sysutils/cpuid/Makefile
+++ b/sysutils/cpuid/Makefile
@@ -2,11 +2,11 @@
# $FreeBSD$
PORTNAME= cpuid
-PORTVERSION= 20170122
+DISTVERSION= 20180519
+DISTVERSIONSUFFIX= .src
CATEGORIES= sysutils
MASTER_SITES= http://www.etallen.com/cpuid/
PKGNAMESUFFIX= ${CPUID_SUFFIX}
-DISTNAME= ${PORTNAME}-${PORTVERSION}.src
MAINTAINER= pkubaj@anongoth.pl
COMMENT= Tool to dump x86 CPUID information about the CPU(s)
@@ -20,7 +20,7 @@ ONLY_FOR_ARCHS_REASON= only works with x86 CPUs
USES= gmake perl5
USE_PERL5= build
ALL_TARGET= default
-WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
+WRKSRC= ${WRKDIR}/${PORTNAME}-${DISTVERSION}
# Renamed to avoid conflict with misc/cpuid
CPUID_SUFFIX= -etallen
diff --git a/sysutils/cpuid/distinfo b/sysutils/cpuid/distinfo
index 4c7df2ca422f..e6a9c43f0ec5 100644
--- a/sysutils/cpuid/distinfo
+++ b/sysutils/cpuid/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1500174826
-SHA256 (cpuid-20170122.src.tar.gz) = 667612aae6704341dd10844e97c84c5c5c8700817a5937a3c293b55013bc4865
-SIZE (cpuid-20170122.src.tar.gz) = 80046
+TIMESTAMP = 1526817399
+SHA256 (cpuid-20180519.src.tar.gz) = 967823be36f23cbc972eb0aa882d069c1d155a5978990ac3bcf425e6a2e7ff9a
+SIZE (cpuid-20180519.src.tar.gz) = 84784
diff --git a/sysutils/cpuid/files/patch-cpuid.c b/sysutils/cpuid/files/patch-cpuid.c
index 4eec3c7ede3b..9ff83057649b 100644
--- a/sysutils/cpuid/files/patch-cpuid.c
+++ b/sysutils/cpuid/files/patch-cpuid.c
@@ -1,7 +1,14 @@
---- cpuid.c.orig 2016-11-30 14:34:23 UTC
+--- cpuid.c.orig 2018-04-19 14:15:07 UTC
+++ cpuid.c
-@@ -23,6 +23,8 @@
+@@ -21,17 +21,19 @@
+ #ifdef __linux__
+ #define USE_CPUID_MODULE
#define USE_KERNEL_SCHED_SETAFFINITY
++#include <sys/sysmacros.h>
+ #endif
+
+ #if __GNUC__ * 10000 + __GNUC_MINOR__ * 100 + __GNUC_PATCHLEVEL__ >= 40300
+ #define USE_CPUID_COUNT
#endif
+#define CPUID_MAJOR 0
@@ -9,7 +16,12 @@
#define _GNU_SOURCE
#include <stdio.h>
#include <sys/types.h>
-@@ -34,6 +36,8 @@
+ #include <sys/stat.h>
+-#include <sys/sysmacros.h>
+ #include <fcntl.h>
+ #include <errno.h>
+ #include <unistd.h>
+@@ -39,6 +41,8 @@
#include <string.h>
#include <regex.h>
#include <getopt.h>
@@ -18,7 +30,7 @@
#ifdef USE_CPUID_MODULE
#include <linux/major.h>
-@@ -58,6 +62,7 @@ typedef const char* const ccstring;
+@@ -67,6 +71,7 @@ typedef const char* const ccstring;
#define XSTR(x) STR(x)
@@ -26,7 +38,7 @@
#define MAX(l,r) ((l) > (r) ? (l) : (r))
#define LENGTH(array, type) (sizeof(array) / sizeof(type))
-@@ -6471,11 +6476,16 @@ real_setup(unsigned int cpu,
+@@ -6622,11 +6627,16 @@ real_setup(unsigned int cpu,
int status;
status = syscall(__NR_sched_setaffinity, 0, sizeof(mask), &mask);
#else
@@ -45,9 +57,9 @@
#endif
if (status == -1) {
if (cpu > 0) {
-@@ -6590,11 +6600,14 @@ static int real_get (int cpuid
- : "a" (reg),
+@@ -6749,11 +6759,14 @@ static int real_get (int cpuid
"c" (ecx));
+ #endif
} else {
- off64_t result;
- off64_t offset = ((off64_t)ecx << 32) + reg;
@@ -63,7 +75,7 @@
if (result == -1) {
if (quiet) {
return FALSE;
-@@ -7138,7 +7151,7 @@ main(int argc,
+@@ -7307,7 +7320,7 @@ main(int argc,
};
boolean opt_one_cpu = FALSE;
@@ -72,7 +84,7 @@
boolean opt_kernel = FALSE;
boolean opt_raw = FALSE;
boolean opt_debug = FALSE;
-@@ -7268,7 +7281,8 @@ main(int argc,
+@@ -7437,7 +7450,8 @@ main(int argc,
}
// Default to -i. So use inst unless -k is specified.