aboutsummaryrefslogtreecommitdiffstats
path: root/sysutils/dfc
diff options
context:
space:
mode:
authorbapt <bapt@FreeBSD.org>2012-07-24 19:33:20 +0800
committerbapt <bapt@FreeBSD.org>2012-07-24 19:33:20 +0800
commitd72610c4f401100209502720054d82905220ddec (patch)
treeeb586f5d784451b67a07b64a458af7ae43243442 /sysutils/dfc
parent7503a54ef13265472b342170a18c1a068eeb5955 (diff)
downloadfreebsd-ports-gnome-d72610c4f401100209502720054d82905220ddec.tar.gz
freebsd-ports-gnome-d72610c4f401100209502720054d82905220ddec.tar.zst
freebsd-ports-gnome-d72610c4f401100209502720054d82905220ddec.zip
Use hack to unsetenv SunOS 3.2 TTY compatibility
as this broke the build on 7.x which still have it. Submitted by: pluknet@ (via private mail)
Diffstat (limited to 'sysutils/dfc')
-rw-r--r--sysutils/dfc/Makefile8
-rw-r--r--sysutils/dfc/files/patch-src__util.c13
2 files changed, 14 insertions, 7 deletions
diff --git a/sysutils/dfc/Makefile b/sysutils/dfc/Makefile
index eecc4f648dff..ca0732841d6a 100644
--- a/sysutils/dfc/Makefile
+++ b/sysutils/dfc/Makefile
@@ -33,10 +33,4 @@ CMAKE_ARGS+= -DNLS_ENABLED=false
PLIST_SUB+= NLS="@comment "
.endif
-.include <bsd.port.pre.mk>
-
-.if ${OSVERSION} < 800000
-BROKEN= does not compile on FreeBSD 7.X
-.endif
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/sysutils/dfc/files/patch-src__util.c b/sysutils/dfc/files/patch-src__util.c
new file mode 100644
index 000000000000..5906e4ccace4
--- /dev/null
+++ b/sysutils/dfc/files/patch-src__util.c
@@ -0,0 +1,13 @@
+--- src/util.c.orig 2012-07-24 13:34:08.000000000 +0400
++++ src/util.c 2012-07-24 13:34:29.000000000 +0400
+@@ -48,6 +48,10 @@
+ #include <libintl.h>
+ #endif
+
++#ifdef TIOCGSIZE
++#undef TIOCGSIZE
++#endif
++
+ /*
+ * Return the longest of the two parameters
+ * @a: first element to compare