aboutsummaryrefslogtreecommitdiffstats
path: root/sysutils/duplicity/files
diff options
context:
space:
mode:
authorleeym <leeym@FreeBSD.org>2003-07-03 14:57:30 +0800
committerleeym <leeym@FreeBSD.org>2003-07-03 14:57:30 +0800
commitc31025f40c1312787d3445df20685e0b14b9e37c (patch)
tree28354761567b10b47c0afeec131c7cf537909196 /sysutils/duplicity/files
parent6d225e7e5e2aae1105eb2b6144bed9fc7fe2a9c6 (diff)
downloadfreebsd-ports-gnome-c31025f40c1312787d3445df20685e0b14b9e37c.tar.gz
freebsd-ports-gnome-c31025f40c1312787d3445df20685e0b14b9e37c.tar.zst
freebsd-ports-gnome-c31025f40c1312787d3445df20685e0b14b9e37c.zip
add duplicity-0.4.0
WWW: http://www.nongnu.org/duplicity/ PR: 53235 Submitted by: Gerhard Haering <gh@ghaering.de>
Diffstat (limited to 'sysutils/duplicity/files')
-rw-r--r--sysutils/duplicity/files/patch-setup.py38
1 files changed, 38 insertions, 0 deletions
diff --git a/sysutils/duplicity/files/patch-setup.py b/sysutils/duplicity/files/patch-setup.py
new file mode 100644
index 000000000000..2484a45dd4ee
--- /dev/null
+++ b/sysutils/duplicity/files/patch-setup.py
@@ -0,0 +1,38 @@
+*** /tmp/duplicity-0.4.0/setup.py Sat Nov 30 23:41:29 2002
+--- setup.py Wed Jun 11 20:31:32 2003
+***************
+*** 9,14 ****
+--- 9,18 ----
+ print "Sorry, duplicity requires version 2.2 or later of python"
+ sys.exit(1)
+
++ LOCALBASE = os.environ.get("LOCALBASE", "/usr/local")
++ include_dirs = ['%s/include' % LOCALBASE]
++ library_dirs = ['%s/lib/' % LOCALBASE]
++
+ setup(name="duplicity",
+ version=version_string,
+ description="Untrusted backup using rsync algorithm",
+***************
+*** 19,28 ****
+ package_dir = {"duplicity": "src"},
+ ext_modules = [Extension("duplicity._librsync",
+ ["_librsyncmodule.c"],
+! libraries=["rsync"])],
+! scripts = ['rdiffdir', 'duplicity'],
+! data_files = [('share/man/man1', ['duplicity.1', 'rdiffdir.1']),
+! ('share/doc/duplicity-%s' % version_string,
+! ['COPYING', 'README', 'CHANGELOG'])])
+
+
+--- 23,32 ----
+ package_dir = {"duplicity": "src"},
+ ext_modules = [Extension("duplicity._librsync",
+ ["_librsyncmodule.c"],
+! libraries=["rsync"],
+! include_dirs=include_dirs,
+! library_dirs=library_dirs)],
+! scripts = ['rdiffdir', 'duplicity']
+! )
+
+