aboutsummaryrefslogtreecommitdiffstats
path: root/sysutils/duplicity05/Makefile
diff options
context:
space:
mode:
authorleeym <leeym@FreeBSD.org>2003-07-03 14:57:30 +0800
committerleeym <leeym@FreeBSD.org>2003-07-03 14:57:30 +0800
commitc31025f40c1312787d3445df20685e0b14b9e37c (patch)
tree28354761567b10b47c0afeec131c7cf537909196 /sysutils/duplicity05/Makefile
parent6d225e7e5e2aae1105eb2b6144bed9fc7fe2a9c6 (diff)
downloadfreebsd-ports-gnome-c31025f40c1312787d3445df20685e0b14b9e37c.tar.gz
freebsd-ports-gnome-c31025f40c1312787d3445df20685e0b14b9e37c.tar.zst
freebsd-ports-gnome-c31025f40c1312787d3445df20685e0b14b9e37c.zip
add duplicity-0.4.0
WWW: http://www.nongnu.org/duplicity/ PR: 53235 Submitted by: Gerhard Haering <gh@ghaering.de>
Diffstat (limited to 'sysutils/duplicity05/Makefile')
-rw-r--r--sysutils/duplicity05/Makefile38
1 files changed, 38 insertions, 0 deletions
diff --git a/sysutils/duplicity05/Makefile b/sysutils/duplicity05/Makefile
new file mode 100644
index 000000000000..134d0aee0e5f
--- /dev/null
+++ b/sysutils/duplicity05/Makefile
@@ -0,0 +1,38 @@
+# New ports collection makefile for: duplicity
+# Date created: Wed Jun 11 19:53:46 CEST 2003
+# Whom: Gerhard Häring <gh@ghaering.de>
+#
+# $FreeBSD$
+#
+
+PORTNAME= duplicity
+PORTVERSION= 0.4.0
+CATEGORIES= sysutils
+MASTER_SITES= http://savannah.nongnu.org/download/duplicity/
+DISTNAME= ${PORTNAME}-${PORTVERSION}
+
+MAINTAINER= gh@ghaering.de
+COMMENT= Untrusted backup using rsync algorithm
+
+LIB_DEPENDS= rsync.1:${PORTSDIR}/net/librsync
+RUN_DEPENDS= gpg:${PORTSDIR}/security/gnupg
+
+USE_PYTHON= yes
+USE_PYDISTUTILS= yes
+
+MAN1= duplicity.1 rdiffdir.1
+
+DOCFILES= CHANGELOG COPYING README
+DOCSDIR= ${PREFIX}/share/doc/${PORTNAME}
+
+post-install:
+ ${INSTALL_MAN} ${WRKSRC}/duplicity.1 ${PREFIX}/man/man1
+ ${INSTALL_MAN} ${WRKSRC}/rdiffdir.1 ${PREFIX}/man/man1
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${DOCSDIR}
+.for file in ${DOCFILES}
+ @${INSTALL_DATA} ${WRKSRC}/${file} ${DOCSDIR}
+.endfor
+.endif
+
+.include <bsd.port.mk>