aboutsummaryrefslogtreecommitdiffstats
path: root/sysutils/eroaster
diff options
context:
space:
mode:
authorpav <pav@FreeBSD.org>2003-12-21 09:09:41 +0800
committerpav <pav@FreeBSD.org>2003-12-21 09:09:41 +0800
commit08519f2ebc1e88dcc41ec981630172104eab1e1c (patch)
treeb7fdb45e5022d33962dd8ab562ca45221ea0d605 /sysutils/eroaster
parent5b74bab039de3b4500d3110a60aa73efe3ea0a39 (diff)
downloadfreebsd-ports-gnome-08519f2ebc1e88dcc41ec981630172104eab1e1c.tar.gz
freebsd-ports-gnome-08519f2ebc1e88dcc41ec981630172104eab1e1c.tar.zst
freebsd-ports-gnome-08519f2ebc1e88dcc41ec981630172104eab1e1c.zip
Add eroaster, nice GNOME2 frontent to mkisofs/cdrecord, written using
python bindings. It can write data files, audio CDs from wave/mp3/ogg files, burn ISO and bin/cue images, create ISO images from a CD and copy CDs on the fly (when you have two drives), and blank -RWs. PR: ports/60422 Submitted by: dave <dave@gufi.org>
Diffstat (limited to 'sysutils/eroaster')
-rw-r--r--sysutils/eroaster/Makefile46
-rw-r--r--sysutils/eroaster/distinfo1
-rw-r--r--sysutils/eroaster/files/patch-process.py29
-rw-r--r--sysutils/eroaster/pkg-descr3
-rw-r--r--sysutils/eroaster/pkg-plist95
5 files changed, 174 insertions, 0 deletions
diff --git a/sysutils/eroaster/Makefile b/sysutils/eroaster/Makefile
new file mode 100644
index 000000000000..78f9d95e0270
--- /dev/null
+++ b/sysutils/eroaster/Makefile
@@ -0,0 +1,46 @@
+# New ports collection makefile for: eroaster
+# Date Created: 20 Dic 2003
+# Whom: Davide D'Amico <dave@gufi.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= eroaster
+PORTVERSION= 2.2.0.0.6
+CATEGORIES= sysutils
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE} \
+ http://www.xcdroast.org/download/
+MASTER_SITE_SUBDIR= eroaster
+DISTNAME= ${PORTNAME}-2.2.0-0.6
+
+MAINTAINER= dave@gufi.org
+COMMENT= A GNOME2 frontend to mkisofs/cdrecord
+
+BUILD_DEPENDS= ${PYTHON_SITELIBDIR}/gtk-2.0/gnome/_gnome.so:${PORTSDIR}/x11-toolkits/py-gnome2 \
+ mkisofs:${PORTSDIR}/sysutils/mkisofs \
+ cdrecord:${PORTSDIR}/sysutils/cdrtools
+
+.if defined(WITH_ADDITIONAL_PROGRAMS)
+BUILD_DEPENDS+= bchunk:${PORTSDIR}/sysutils/bchunk \
+ cdrdao:${PORTSDIR}/sysutils/cdrdao \
+ lame:${PORTSDIR}/audio/lame \
+ mpg123:${PORTSDIR}/audio/mpg123 \
+ normalize:${PORTSDIR}/audio/normalize \
+ oggenc:${PORTSDIR}/audio/vorbis-tools \
+ sox:${PORTSDIR}/audio/sox
+.endif
+
+USE_X_PREFIX= yes
+GNU_CONFIGURE= yes
+USE_PYTHON= yes
+USE_REINPLACE= yes
+
+pre-everything::
+ @${ECHO_MSG} "===> You can enable more features by defining WITH_ADDITIONAL_PROGRAMS"
+ @${ECHO_MSG} "===>"
+
+post-patch::
+ @cd ${WRKSRC} && ${RM} process.py.orig
+ @${REINPLACE_CMD} -e 's|share/applets/Utility|share/gnome/apps/Utilities|' ${WRKSRC}/Makefile.in
+
+.include <bsd.port.mk>
diff --git a/sysutils/eroaster/distinfo b/sysutils/eroaster/distinfo
new file mode 100644
index 000000000000..e0ec0cb355ac
--- /dev/null
+++ b/sysutils/eroaster/distinfo
@@ -0,0 +1 @@
+MD5 (eroaster-2.2.0-0.6.tar.gz) = 4abb1569ee495b7ed3ae98c61ab6c7e7
diff --git a/sysutils/eroaster/files/patch-process.py b/sysutils/eroaster/files/patch-process.py
new file mode 100644
index 000000000000..7441f45d0679
--- /dev/null
+++ b/sysutils/eroaster/files/patch-process.py
@@ -0,0 +1,29 @@
+--- process.py.orig Fri Jul 25 23:42:00 2003
++++ process.py Sat Dec 20 11:47:56 2003
+@@ -34,7 +34,7 @@
+ # python -c "import sys;print sys.platform"
+
+ osFamily = {}
+-osFamily[OSTYPEBSD] = ["freebsd4", "bsdos4"]
++osFamily[OSTYPEBSD] = ["freebsd4", "freebsd5", "bsdos4"]
+ osFamily[OSTYPESYSV] = ["linux-i386", "linux2" ]
+ osFamily[OSTYPESUNOSUCB] = ["sunos5"]
+
+@@ -45,6 +45,8 @@
+ osPsParam[OSTYPESUNOSUCB] = "-l %s"
+
+ osPsProcessListParam = {}
++osPsProcessListParam["freebsd4"] = "-ax"
++osPsProcessListParam["freebsd5"] = "-ax"
+ osPsProcessListParam["sunos5"] = "-ef"
+ osPsProcessListParam["linux2"] = "ax"
+ osPsProcessListParam[OSTYPEUNKNOWN] = "ax"
+@@ -98,7 +100,7 @@
+ elif (column == "STAT"):
+ # Status: S, W, N, R, L, <
+ strRegExp = "%s([SWNRL<]+) +" % strRegExp
+- elif (column == "TTY"):
++ elif ((column == "TTY") or (column == "TT")):
+ # TTY: ?, pty/1, console
+ strRegExp = "%s(\?|[\w/]+\d*) +" % strRegExp
+ elif ((column == "CMD") or (column == "COMMAND")):
diff --git a/sysutils/eroaster/pkg-descr b/sysutils/eroaster/pkg-descr
new file mode 100644
index 000000000000..f38ef335d18e
--- /dev/null
+++ b/sysutils/eroaster/pkg-descr
@@ -0,0 +1,3 @@
+Eroaster is a GNOME2/Python based mkisofs/cdrecord front-end.
+You can burn Audio and Data CD-ROMS, ISO and BIN/CUE image files.
+You can use it to extract data and audio tracks, format CD-RW an other.
diff --git a/sysutils/eroaster/pkg-plist b/sysutils/eroaster/pkg-plist
new file mode 100644
index 000000000000..a9a77d0ba203
--- /dev/null
+++ b/sysutils/eroaster/pkg-plist
@@ -0,0 +1,95 @@
+bin/eroaster
+bin/eroaster-applet
+etc/CORBA/servers/eroaster.gnorba
+lib/eroaster/Application.py
+lib/eroaster/ExecutionThread.py
+lib/eroaster/Preferences.py
+lib/eroaster/Preferences.pyc
+lib/eroaster/Project.py
+lib/eroaster/bchunk.py
+lib/eroaster/bchunk.pyc
+lib/eroaster/cdrdao.py
+lib/eroaster/cdrdao.pyc
+lib/eroaster/cdrtools.py
+lib/eroaster/cdrtools.pyc
+lib/eroaster/constants.py
+lib/eroaster/constants.pyc
+lib/eroaster/ecat.py
+lib/eroaster/eroaster.shortcuts
+lib/eroaster/glade/eroaster-prefs.glade
+lib/eroaster/gnometools.py
+lib/eroaster/gnometools.pyc
+lib/eroaster/gtkexcepthook.py
+lib/eroaster/gtkexcepthook.pyc
+lib/eroaster/lame.py
+lib/eroaster/lame.pyc
+lib/eroaster/log4py.py
+lib/eroaster/log4py.pyc
+lib/eroaster/mp3info.py
+lib/eroaster/mp3info.pyc
+lib/eroaster/oggvorbis.py
+lib/eroaster/oggvorbis.pyc
+lib/eroaster/process.py
+lib/eroaster/process.pyc
+lib/eroaster/tools.py
+lib/eroaster/tools.pyc
+lib/eroaster/waitreload.py
+lib/eroaster/xml/eroaster-ui.xml
+share/eroaster/pixmaps/applet-bright.xpm
+share/eroaster/pixmaps/applet-burn.xpm
+share/eroaster/pixmaps/applet.xpm
+share/eroaster/pixmaps/audio.xpm
+share/eroaster/pixmaps/audiocd.xpm
+share/eroaster/pixmaps/autoselect.xpm
+share/eroaster/pixmaps/burn.xpm
+share/eroaster/pixmaps/cancel.xpm
+share/eroaster/pixmaps/cdwriter.xpm
+share/eroaster/pixmaps/close.xpm
+share/eroaster/pixmaps/compressed.xpm
+share/eroaster/pixmaps/copy.xpm
+share/eroaster/pixmaps/copycd.xpm
+share/eroaster/pixmaps/createimage.xpm
+share/eroaster/pixmaps/datacd.xpm
+share/eroaster/pixmaps/doc.xpm
+share/eroaster/pixmaps/folder.xpm
+share/eroaster/pixmaps/gnome-hint.xpm
+share/eroaster/pixmaps/help.xpm
+share/eroaster/pixmaps/image.xpm
+share/eroaster/pixmaps/iso.xpm
+share/eroaster/pixmaps/isoimage.xpm
+share/eroaster/pixmaps/link.xpm
+share/eroaster/pixmaps/master.xpm
+share/eroaster/pixmaps/ok.xpm
+share/eroaster/pixmaps/options.xpm
+share/eroaster/pixmaps/patch.xpm
+share/eroaster/pixmaps/preferences.xpm
+share/eroaster/pixmaps/ps.xpm
+share/eroaster/pixmaps/quit.xpm
+share/eroaster/pixmaps/read.xpm
+share/eroaster/pixmaps/readcd.xpm
+share/eroaster/pixmaps/s2cps.xpm
+share/eroaster/pixmaps/select.xpm
+share/eroaster/pixmaps/selectnone.xpm
+share/eroaster/pixmaps/sound.xpm
+share/eroaster/pixmaps/special.xpm
+share/eroaster/pixmaps/tar.xpm
+share/eroaster/pixmaps/text.xpm
+share/eroaster/pixmaps/unknown.xpm
+share/eroaster/pixmaps/unselect.xpm
+share/eroaster/pixmaps/gnome-dev-cdrom.png
+share/eroaster/pixmaps/gnome-dev-harddisk.png
+share/eroaster/pixmaps/gnome-fs-desktop.png
+share/eroaster/pixmaps/gnome-fs-directory-accept.png
+share/eroaster/pixmaps/gnome-fs-home.png
+share/eroaster/pixmaps/gnome-fs-network.png
+share/eroaster/pixmaps/stock_back-dir.png
+share/eroaster/pixmaps/stock_new-dir.png
+share/eroaster/pixmaps/stock_up-one-dir.png
+share/pixmaps/eroaster.xpm
+share/gnome/apps/Utilities/eroaster.desktop
+share/locale/es/LC_MESSAGES/es.mo
+@dirrm lib/eroaster/glade
+@dirrm lib/eroaster/xml
+@dirrm lib/eroaster
+@dirrm share/eroaster/pixmaps
+@dirrm share/eroaster