aboutsummaryrefslogtreecommitdiffstats
path: root/sysutils/fusefs-encfs
diff options
context:
space:
mode:
authorlwhsu <lwhsu@FreeBSD.org>2009-04-07 20:28:00 +0800
committerlwhsu <lwhsu@FreeBSD.org>2009-04-07 20:28:00 +0800
commit51df588eb495cf67c0b3326d8f5bfac423472de3 (patch)
treefa44163bae9875b9cf88644c5d906792d642b7ec /sysutils/fusefs-encfs
parent575dea33d29759f93c967032d0993e64cbce6967 (diff)
downloadfreebsd-ports-gnome-51df588eb495cf67c0b3326d8f5bfac423472de3.tar.gz
freebsd-ports-gnome-51df588eb495cf67c0b3326d8f5bfac423472de3.tar.zst
freebsd-ports-gnome-51df588eb495cf67c0b3326d8f5bfac423472de3.zip
- Fix building with boost 1.37
PR: ports/132901 Submitted by: amdmi3 Approved by: leeym (maintainer)
Diffstat (limited to 'sysutils/fusefs-encfs')
-rw-r--r--sysutils/fusefs-encfs/files/patch-encfs-FileUtils.cpp10
-rw-r--r--sysutils/fusefs-encfs/files/patch-encfs-Makefile.in11
2 files changed, 21 insertions, 0 deletions
diff --git a/sysutils/fusefs-encfs/files/patch-encfs-FileUtils.cpp b/sysutils/fusefs-encfs/files/patch-encfs-FileUtils.cpp
new file mode 100644
index 000000000000..c92ed6bf34dc
--- /dev/null
+++ b/sysutils/fusefs-encfs/files/patch-encfs-FileUtils.cpp
@@ -0,0 +1,10 @@
+--- encfs/FileUtils.cpp.orig 2008-04-14 03:13:23.000000000 +0400
++++ encfs/FileUtils.cpp 2009-03-21 04:33:29.000000000 +0300
+@@ -61,6 +61,7 @@
+ #include <boost/archive/xml_iarchive.hpp>
+ #include <boost/archive/xml_oarchive.hpp>
+ #include <boost/serialization/split_free.hpp>
++#include <boost/serialization/binary_object.hpp>
+
+ using namespace rel;
+ using namespace rlog;
diff --git a/sysutils/fusefs-encfs/files/patch-encfs-Makefile.in b/sysutils/fusefs-encfs/files/patch-encfs-Makefile.in
new file mode 100644
index 000000000000..40c1d9f8f590
--- /dev/null
+++ b/sysutils/fusefs-encfs/files/patch-encfs-Makefile.in
@@ -0,0 +1,11 @@
+--- encfs/Makefile.in.orig 2008-04-14 04:10:40.000000000 +0400
++++ encfs/Makefile.in 2009-03-21 04:37:08.000000000 +0300
+@@ -279,7 +279,7 @@
+ KDE_OPTIONS = qtonly
+ ALL_INCLUDES = @RLOG_CFLAGS@ @OPENSSL_CFLAGS@ @BOOST_CPPFLAGS@
+ ALL_LDFLAGS = @RLOG_LIBS@ @OPENSSL_LIBS@ @FUSE_LIBS@ \
+- @BOOST_SERIALIZATION_LIB@ $(am__append_2)
++ @BOOST_SERIALIZATION_LIB@ $(am__append_2) -lboost_system
+ INCLUDES = $(all_includes) -I../intl
+ AM_CXXFLAGS = -DRLOG_COMPONENT="encfs" $(ALL_INCLUDES) $(am__append_1)
+ lib_LTLIBRARIES = libencfs.la