aboutsummaryrefslogtreecommitdiffstats
path: root/sysutils/fusefs-libs
diff options
context:
space:
mode:
authorvanilla <vanilla@FreeBSD.org>2008-02-06 09:41:33 +0800
committervanilla <vanilla@FreeBSD.org>2008-02-06 09:41:33 +0800
commitabe48d3728e73ba1a90c00af0c8545ad6b877cbe (patch)
tree75cadd6f85e4a77bfbaffbc70a25cdf6336c5e4d /sysutils/fusefs-libs
parentca0799ec92576f473f68cde61ede175a3ec15b3f (diff)
downloadfreebsd-ports-gnome-abe48d3728e73ba1a90c00af0c8545ad6b877cbe.tar.gz
freebsd-ports-gnome-abe48d3728e73ba1a90c00af0c8545ad6b877cbe.tar.zst
freebsd-ports-gnome-abe48d3728e73ba1a90c00af0c8545ad6b877cbe.zip
Fix "unknown option", and bump version.
Submitted by: Andriy Gapon <avg.@.icyb.net.ua> Approved by: maintainer
Diffstat (limited to 'sysutils/fusefs-libs')
-rw-r--r--sysutils/fusefs-libs/Makefile1
-rw-r--r--sysutils/fusefs-libs/files/patch-lib_helper.c2
2 files changed, 2 insertions, 1 deletions
diff --git a/sysutils/fusefs-libs/Makefile b/sysutils/fusefs-libs/Makefile
index 4a0e3fa85097..fd23784bf3ad 100644
--- a/sysutils/fusefs-libs/Makefile
+++ b/sysutils/fusefs-libs/Makefile
@@ -6,6 +6,7 @@
PORTNAME= fusefs
PORTVERSION= 2.7.2
+PORTREVISION= 1
CATEGORIES= sysutils
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= fuse
diff --git a/sysutils/fusefs-libs/files/patch-lib_helper.c b/sysutils/fusefs-libs/files/patch-lib_helper.c
index a9cfbb98635a..89f46a4595aa 100644
--- a/sysutils/fusefs-libs/files/patch-lib_helper.c
+++ b/sysutils/fusefs-libs/files/patch-lib_helper.c
@@ -53,7 +53,7 @@
- sprintf(subtype_opt, "-osubtype=%s", basename);
- res = fuse_opt_add_arg(args, subtype_opt);
- free(subtype_opt);
-+ sprintf(fsname_opt, "-osubtype=%s", basename);
++ sprintf(fsname_opt, "-ofsname=%s", basename);
+ res = fuse_opt_add_arg(args, fsname_opt);
+ free(fsname_opt);
return res;