aboutsummaryrefslogtreecommitdiffstats
path: root/sysutils/fusefs-mhddfs
diff options
context:
space:
mode:
authoramdmi3 <amdmi3@FreeBSD.org>2010-02-05 08:22:33 +0800
committeramdmi3 <amdmi3@FreeBSD.org>2010-02-05 08:22:33 +0800
commit133f26b25eb9c14ef12d681773a5b3069992faba (patch)
tree208b7c256e01094991e057302932bf1c22e21b93 /sysutils/fusefs-mhddfs
parentfd1f9ea2ed219b1b78509eb41a66d307c54153b6 (diff)
downloadfreebsd-ports-gnome-133f26b25eb9c14ef12d681773a5b3069992faba.tar.gz
freebsd-ports-gnome-133f26b25eb9c14ef12d681773a5b3069992faba.tar.zst
freebsd-ports-gnome-133f26b25eb9c14ef12d681773a5b3069992faba.zip
- Update to 0.1.30
PR: 143561 Submitted by: Oleg Alexeenkov <proler@gmail.com> (maintainer)
Diffstat (limited to 'sysutils/fusefs-mhddfs')
-rw-r--r--sysutils/fusefs-mhddfs/Makefile2
-rw-r--r--sysutils/fusefs-mhddfs/distinfo6
-rw-r--r--sysutils/fusefs-mhddfs/files/patch-src-tools.c57
3 files changed, 4 insertions, 61 deletions
diff --git a/sysutils/fusefs-mhddfs/Makefile b/sysutils/fusefs-mhddfs/Makefile
index 228471e9f963..f3fc5ecb4a41 100644
--- a/sysutils/fusefs-mhddfs/Makefile
+++ b/sysutils/fusefs-mhddfs/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= mhddfs
-PORTVERSION= 0.1.29
+PORTVERSION= 0.1.30
CATEGORIES= sysutils
MASTER_SITES= http://mhddfs.uvw.ru/downloads/
PKGNAMEPREFIX= fusefs-
diff --git a/sysutils/fusefs-mhddfs/distinfo b/sysutils/fusefs-mhddfs/distinfo
index 3dc47269ea83..d696a9b1a831 100644
--- a/sysutils/fusefs-mhddfs/distinfo
+++ b/sysutils/fusefs-mhddfs/distinfo
@@ -1,3 +1,3 @@
-MD5 (mhddfs_0.1.29.tar.gz) = 82491c20c9eb06fc467e70371619cd85
-SHA256 (mhddfs_0.1.29.tar.gz) = 6b5fa0169234dbd0d438bda71a259aefadf2f90a8ff8d43a2089d90eea05ee59
-SIZE (mhddfs_0.1.29.tar.gz) = 36938
+MD5 (mhddfs_0.1.30.tar.gz) = 246b9f18b3f885a00c867779b7af0efc
+SHA256 (mhddfs_0.1.30.tar.gz) = 64dc2a4e0bb573bc55382f96b40e577c4e3d965a88904a95d876109d82333a16
+SIZE (mhddfs_0.1.30.tar.gz) = 36983
diff --git a/sysutils/fusefs-mhddfs/files/patch-src-tools.c b/sysutils/fusefs-mhddfs/files/patch-src-tools.c
deleted file mode 100644
index 86f4a184205f..000000000000
--- a/sysutils/fusefs-mhddfs/files/patch-src-tools.c
+++ /dev/null
@@ -1,57 +0,0 @@
---- src/tools.c.orig 2010-01-11 15:48:46.000000000 +0300
-+++ src/tools.c 2010-01-11 15:53:42.000000000 +0300
-@@ -30,7 +30,10 @@
- #include <fcntl.h>
- #include <sys/types.h>
- #include <dirent.h>
-+
-+#ifndef WITHOUT_XATTR
- #include <attr/xattr.h>
-+#endif
-
- #include "tools.h"
- #include "debug.h"
-@@ -262,11 +265,13 @@
- ftime.modtime = st.st_mtime;
- utime(to, &ftime);
-
-+#ifndef WITHOUT_XATTR
- // extended attributes
- if (copy_xattrs(from, to) == -1)
- mhdd_debug(MHDD_MSG,
- "copy_xattrs: error copying xattrs from %s to %s\n",
- from, to);
-+#endif
-
-
- from = strdup(from);
-@@ -282,6 +287,7 @@
- return ret;
- }
-
-+#ifndef WITHOUT_XATTR
- int copy_xattrs(const char *from, const char *to)
- {
- int listsize=0, attrvalsize=0;
-@@ -350,6 +356,7 @@
- free(listbuf);
- return 0;
- }
-+#endif
-
- char * create_path(const char *dir, const char * file)
- {
-@@ -465,11 +472,13 @@
- strerror(errno));
- }
-
-+#ifndef WITHOUT_XATTR
- // copy extended attributes of parent dir
- if (copy_xattrs(exists, path_parent) == -1)
- mhdd_debug(MHDD_MSG,
- "copy_xattrs: error copying xattrs from %s to %s\n",
- exists, path_parent);
-+#endif
-
- free(exists);
- free(path_parent);