aboutsummaryrefslogtreecommitdiffstats
path: root/sysutils/fusefs-mhddfs
diff options
context:
space:
mode:
authoravl <avl@FreeBSD.org>2009-06-26 20:31:27 +0800
committeravl <avl@FreeBSD.org>2009-06-26 20:31:27 +0800
commit792a7dba88e9b9280c17e25e3823a0c481f19b31 (patch)
tree2afa430bd7fa4c64aba0aec4cc000b8ec76a3de3 /sysutils/fusefs-mhddfs
parent4e0f58255d69785d1c89d10df76c9e2e19d1d9ae (diff)
downloadfreebsd-ports-gnome-792a7dba88e9b9280c17e25e3823a0c481f19b31.tar.gz
freebsd-ports-gnome-792a7dba88e9b9280c17e25e3823a0c481f19b31.tar.zst
freebsd-ports-gnome-792a7dba88e9b9280c17e25e3823a0c481f19b31.zip
mhddfs - Multi HDD [FUSE] File System
File system for unifying several mount points into one This FUSE-based file system allows mount points (or directories) to be combined, simulating a single big volume which can merge several hard drives or remote file systems. It is like unionfs, but can choose the drive with the most free space to create new files on, and can move data transparently between drives. WWW: http://mhddfs.uvw.ru/ PR: ports/136019 Submitted by: Oleg Alexeenkov <proler at gmail.com> Approved by: tabthorpe (mentor)
Diffstat (limited to 'sysutils/fusefs-mhddfs')
-rw-r--r--sysutils/fusefs-mhddfs/Makefile37
-rw-r--r--sysutils/fusefs-mhddfs/distinfo3
-rw-r--r--sysutils/fusefs-mhddfs/files/patch-src-main.c11
-rw-r--r--sysutils/fusefs-mhddfs/pkg-descr10
4 files changed, 61 insertions, 0 deletions
diff --git a/sysutils/fusefs-mhddfs/Makefile b/sysutils/fusefs-mhddfs/Makefile
new file mode 100644
index 000000000000..d20d5e67daec
--- /dev/null
+++ b/sysutils/fusefs-mhddfs/Makefile
@@ -0,0 +1,37 @@
+# New ports collection makefile for: fusefs-mhddfs
+# Date created: 2009-06-25
+# Whom: Oleg Alexeenkov <proler@gmail.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= mhddfs
+PORTVERSION= 0.1.19
+CATEGORIES= sysutils
+MASTER_SITES= http://mhddfs.uvw.ru/downloads/
+PKGNAMEPREFIX= fusefs-
+DISTNAME= ${PORTNAME}_${PORTVERSION}
+
+MAINTAINER= proler@gmail.com
+COMMENT= Multi HDD [FUSE] File System
+
+BUILD_DEPENDS= ${LOCALBASE}/include/fuse.h:${PORTSDIR}/sysutils/fusefs-libs
+RUN_DEPENDS= ${LOCALBASE}/modules/fuse.ko:${PORTSDIR}/sysutils/fusefs-kmod
+
+USE_GMAKE= yes
+WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
+
+MAN1= ${PORTNAME}.1
+PLIST_FILES= bin/${PORTNAME}
+PORTDOCS= README ChangeLog
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${PREFIX}/bin
+ ${INSTALL_MAN} ${WRKSRC}/${MAN1} ${MAN1PREFIX}/man/man1
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/README ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/ChangeLog ${DOCSDIR}
+.endif
+
+.include <bsd.port.mk>
diff --git a/sysutils/fusefs-mhddfs/distinfo b/sysutils/fusefs-mhddfs/distinfo
new file mode 100644
index 000000000000..b52b07549a79
--- /dev/null
+++ b/sysutils/fusefs-mhddfs/distinfo
@@ -0,0 +1,3 @@
+MD5 (mhddfs_0.1.19.tar.gz) = b96fc3bc16ca6c19106e57984c6e02ce
+SHA256 (mhddfs_0.1.19.tar.gz) = aab80796364f9f17659e4cca8e95c0ac026754e15f16b2b46f28b92497fbc631
+SIZE (mhddfs_0.1.19.tar.gz) = 32133
diff --git a/sysutils/fusefs-mhddfs/files/patch-src-main.c b/sysutils/fusefs-mhddfs/files/patch-src-main.c
new file mode 100644
index 000000000000..e08626f567fc
--- /dev/null
+++ b/sysutils/fusefs-mhddfs/files/patch-src-main.c
@@ -0,0 +1,11 @@
+--- src/main.c.orig 2009-06-25 05:11:08.000000000 +0400
++++ src/main.c 2009-06-25 05:23:57.000000000 +0400
+@@ -755,7 +755,7 @@
+ return -errno;
+ }
+
+-#if _POSIX_SYNCHRONIZED_IO + 0 > 0
++#if _POSIX_SYNCHRONIZED_IO + 0 > 0 || defined(__FreeBSD__)
+ #undef HAVE_FDATASYNC
+ #else
+ #define HAVE_FDATASYNC 1
diff --git a/sysutils/fusefs-mhddfs/pkg-descr b/sysutils/fusefs-mhddfs/pkg-descr
new file mode 100644
index 000000000000..12def5fcf8d2
--- /dev/null
+++ b/sysutils/fusefs-mhddfs/pkg-descr
@@ -0,0 +1,10 @@
+mhddfs - Multi HDD [FUSE] File System
+
+File system for unifying several mount points into one
+This FUSE-based file system allows mount points (or directories) to be
+combined, simulating a single big volume which can merge several hard
+drives or remote file systems. It is like unionfs, but can choose the
+drive with the most free space to create new files on, and can move
+data transparently between drives.
+
+WWW: http://mhddfs.uvw.ru/