aboutsummaryrefslogtreecommitdiffstats
path: root/sysutils/gkrellm/Makefile
diff options
context:
space:
mode:
authorume <ume@FreeBSD.org>2000-04-15 00:12:16 +0800
committerume <ume@FreeBSD.org>2000-04-15 00:12:16 +0800
commit2c0d26c721756aad10e1ab2754b3a1eeb0f3045c (patch)
tree44c249cc5b1b04c0e610a78efaa917923a0bf76b /sysutils/gkrellm/Makefile
parent662ce8dfea3f6266610a5990cee5434c934cd5be (diff)
downloadfreebsd-ports-gnome-2c0d26c721756aad10e1ab2754b3a1eeb0f3045c.tar.gz
freebsd-ports-gnome-2c0d26c721756aad10e1ab2754b3a1eeb0f3045c.tar.zst
freebsd-ports-gnome-2c0d26c721756aad10e1ab2754b3a1eeb0f3045c.zip
Update to 0.9.8.
Diffstat (limited to 'sysutils/gkrellm/Makefile')
-rw-r--r--sysutils/gkrellm/Makefile14
1 files changed, 12 insertions, 2 deletions
diff --git a/sysutils/gkrellm/Makefile b/sysutils/gkrellm/Makefile
index dc542efb453c..565efb227d19 100644
--- a/sysutils/gkrellm/Makefile
+++ b/sysutils/gkrellm/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= gkrellm
-PORTVERSION= 0.9.7
+PORTVERSION= 0.9.8
CATEGORIES= sysutils ipv6
MASTER_SITES= http://web.wt.net/~billw/gkrellm/ \
http://people.FreeBSD.org/~ume/gkrellm/
@@ -21,6 +21,7 @@ GTK_CONFIG?= ${X11BASE}/bin/gtk12-config
USE_X_PREFIX= yes
MAKE_ENV= GTK_CONFIG="${GTK_CONFIG}"
+INCLUDES= gkrellm.h gkrellm_public_proto.h gkrellm_private_proto.h
DOCS= COPYRIGHT README Themes
# You should aware that GKrellM must be setuid root to obtain
@@ -44,8 +45,17 @@ BINMODE= 4111
BINMODE= 2111
.endif
+post-patch:
+ @${MV} ${WRKSRC}/gkrellm.h ${WRKSRC}/gkrellm.h.orig
+ @${SED} -e "s^/usr/share/^${PREFIX}/share/^" \
+ ${WRKSRC}/gkrellm.h.orig > ${WRKSRC}/gkrellm.h
+
do-install:
- @${INSTALL_PROGRAM} ${WRKSRC}/gkrellm ${PREFIX}/bin/gkrellm
+ ${INSTALL_PROGRAM} ${WRKSRC}/gkrellm ${PREFIX}/bin/gkrellm
+ @${MKDIR} ${PREFIX}/include/gkrellm
+.for file in ${INCLUDES}
+ ${INSTALL_DATA} ${WRKSRC}/${file} ${PREFIX}/include/gkrellm
+.endfor
.if !defined(NOPORTDOCS)
@${MKDIR} ${PREFIX}/share/doc/gkrellm
.for file in ${DOCS}