aboutsummaryrefslogtreecommitdiffstats
path: root/sysutils/gnome-mount
diff options
context:
space:
mode:
authormarcus <marcus@FreeBSD.org>2007-04-12 00:27:19 +0800
committermarcus <marcus@FreeBSD.org>2007-04-12 00:27:19 +0800
commit87f4ba988f009e3af3dca33f3ae686060fe67aa2 (patch)
tree3653c78dbcecb77a1d53b5a7c249554d6b07cfbc /sysutils/gnome-mount
parent63eba636fce92adcfa59d5d98bd24f3e458bf977 (diff)
downloadfreebsd-ports-gnome-87f4ba988f009e3af3dca33f3ae686060fe67aa2.tar.gz
freebsd-ports-gnome-87f4ba988f009e3af3dca33f3ae686060fe67aa2.tar.zst
freebsd-ports-gnome-87f4ba988f009e3af3dca33f3ae686060fe67aa2.zip
* Update to 0.6
* Fix NTFS mount permissions [1] PR: 111451 [1] Submitted by: "Franz Klammer" <klammer@webonaut.com> [1]
Diffstat (limited to 'sysutils/gnome-mount')
-rw-r--r--sysutils/gnome-mount/Makefile3
-rw-r--r--sysutils/gnome-mount/distinfo6
-rw-r--r--sysutils/gnome-mount/files/patch-gnome-mount.schemas.in10
-rw-r--r--sysutils/gnome-mount/files/patch-src_gnome-mount-properties-view.c81
-rw-r--r--sysutils/gnome-mount/files/patch-src_gnome-mount-properties.c21
-rw-r--r--sysutils/gnome-mount/files/patch-src_gnome-mount.c98
-rw-r--r--sysutils/gnome-mount/pkg-plist15
7 files changed, 24 insertions, 210 deletions
diff --git a/sysutils/gnome-mount/Makefile b/sysutils/gnome-mount/Makefile
index 6be9c4a95637..6c22d6a55b1d 100644
--- a/sysutils/gnome-mount/Makefile
+++ b/sysutils/gnome-mount/Makefile
@@ -7,8 +7,7 @@
#
PORTNAME= gnome-mount
-PORTVERSION= 0.5
-PORTREVISION= 6
+PORTVERSION= 0.6
CATEGORIES= sysutils gnome
MASTER_SITES= http://people.freedesktop.org/~david/dist/
diff --git a/sysutils/gnome-mount/distinfo b/sysutils/gnome-mount/distinfo
index fa1d4818b5bf..94f471d4a73f 100644
--- a/sysutils/gnome-mount/distinfo
+++ b/sysutils/gnome-mount/distinfo
@@ -1,3 +1,3 @@
-MD5 (gnome-mount-0.5.tar.gz) = 76622ff9af0131fc44687aed7204f84f
-SHA256 (gnome-mount-0.5.tar.gz) = f705a44a2534acdae8bae752c54066eb3fc85ce082b3a25a50310f4ad377019b
-SIZE (gnome-mount-0.5.tar.gz) = 408472
+MD5 (gnome-mount-0.6.tar.gz) = d2612aecfa73806e072316033d78b203
+SHA256 (gnome-mount-0.6.tar.gz) = 4169840c49135a58dff6b99445492b74bc751dbb19c9133568ecfbcbf3219cad
+SIZE (gnome-mount-0.6.tar.gz) = 466656
diff --git a/sysutils/gnome-mount/files/patch-gnome-mount.schemas.in b/sysutils/gnome-mount/files/patch-gnome-mount.schemas.in
index d4a0961b4018..8100fb7d39d4 100644
--- a/sysutils/gnome-mount/files/patch-gnome-mount.schemas.in
+++ b/sysutils/gnome-mount/files/patch-gnome-mount.schemas.in
@@ -1,11 +1,11 @@
---- gnome-mount.schemas.in.orig Wed Jun 21 22:45:53 2006
-+++ gnome-mount.schemas.in Sun Dec 31 15:38:28 2006
+--- gnome-mount.schemas.in.orig Tue Apr 10 18:50:12 2007
++++ gnome-mount.schemas.in Wed Apr 11 12:12:20 2007
@@ -6,7 +6,7 @@
<applyto>/system/storage/default_options/vfat/mount_options</applyto>
<type>list</type>
<list_type>string</list_type>
-- <default>[shortname=winnt,uid=]</default>
-+ <default>[longnames,-u=]</default>
+- <default>[shortname=lower,uid=]</default>
++ <default>[longnames,uid=]</default>
<locale name="C">
<short>Default mount options for vfat fs</short>
<long>A list of default mount options for volumes formatted with the vfat file system.</long>
@@ -32,7 +32,7 @@
<type>list</type>
<list_type>string</list_type>
- <default>[umask=222]</default>
-+ <default>[-m=222]</default>
++ <default>[-m=755]</default>
<locale name="C">
<short>Default mount options for ntfs fs</short>
<long>A list of default mount options for volumes formatted with the ntfs file system.</long>
diff --git a/sysutils/gnome-mount/files/patch-src_gnome-mount-properties-view.c b/sysutils/gnome-mount/files/patch-src_gnome-mount-properties-view.c
deleted file mode 100644
index 481e82858656..000000000000
--- a/sysutils/gnome-mount/files/patch-src_gnome-mount-properties-view.c
+++ /dev/null
@@ -1,81 +0,0 @@
---- src/gnome-mount-properties-view.c.orig Mon Aug 14 00:17:22 2006
-+++ src/gnome-mount-properties-view.c Sun Dec 3 02:38:08 2006
-@@ -34,6 +34,7 @@
- #include <sys/time.h>
- #include <string.h>
- #include <gconf/gconf-client.h>
-+#include <libgnomevfs/gnome-vfs-utils.h>
-
- #ifdef __FreeBSD__
- #include <fstab.h>
-@@ -59,6 +60,35 @@ struct _GnomeMountPropertiesViewClass {
- GtkVBoxClass base_class;
- };
-
-+#ifdef __FreeBSD__
-+static struct opt {
-+ int o_opt;
-+ const char *o_name;
-+} optnames[] = {
-+ { MNT_ASYNC, "asynchronous" },
-+ { MNT_EXPORTED, "NFS exported" },
-+ { MNT_LOCAL, "local" },
-+ { MNT_NOATIME, "noatime" },
-+ { MNT_NOEXEC, "noexec" },
-+ { MNT_NOSUID, "nosuid" },
-+ { MNT_NOSYMFOLLOW, "nosymfollow" },
-+ { MNT_QUOTA, "with quotas" },
-+ { MNT_RDONLY, "read-only" },
-+ { MNT_SYNCHRONOUS, "synchronous" },
-+ { MNT_UNION, "union" },
-+ { MNT_NOCLUSTERR, "noclusterr" },
-+ { MNT_NOCLUSTERW, "noclusterw" },
-+ { MNT_SUIDDIR, "suiddir" },
-+ { MNT_SOFTDEP, "soft-updates" },
-+ { MNT_MULTILABEL, "multilabel" },
-+ { MNT_ACLS, "acls" },
-+#ifdef MNT_GJOURNAL
-+ { MNT_GJOURNAL, "gjournal" },
-+#endif
-+ { 0, NULL }
-+};
-+#endif
-+
- G_DEFINE_TYPE (GnomeMountPropertiesView, gm_properties_view, GTK_TYPE_VBOX)
-
- static void
-@@ -445,13 +475,29 @@ static gboolean
- mtab_next (gpointer handle, char **device_file, char **mount_options, char **mount_fstype)
- {
- #ifdef __FreeBSD__
--#error FIXME TODO XXX fix this up for FreeBSD. Thanks.
- struct mtab_handle *mtab = handle;
-
-- if (mtab->iter < mtab->n_mounts)
-- return mtab->mounts[mtab->iter++].f_mntfromname;
-- else
-- return NULL;
-+ if (mtab->iter < mtab->n_mounts) {
-+ struct opt *o;
-+ int flags;
-+ GString *optstr;
-+
-+ optstr = g_string_new("");
-+ flags = mtab->mounts[mtab->iter].f_flags & MNT_VISFLAGMASK;
-+
-+ for (o = optnames; flags && o->o_opt; o++) {
-+ if (flags & o->o_opt) {
-+ g_string_append_printf(optstr, ", %s", o->o_name);
-+ flags &= ~o->o_opt;
-+ }
-+ }
-+ *device_file = mtab->mounts[mtab->iter].f_mntfromname;
-+ *mount_options = g_string_free(optstr, FALSE);
-+ *mount_fstype = mtab->mounts[mtab->iter++].f_fstypename;
-+ return TRUE;
-+ } else {
-+ return FALSE;
-+ }
- #else
- struct mntent *mnt;
-
diff --git a/sysutils/gnome-mount/files/patch-src_gnome-mount-properties.c b/sysutils/gnome-mount/files/patch-src_gnome-mount-properties.c
deleted file mode 100644
index 1f36b1259710..000000000000
--- a/sysutils/gnome-mount/files/patch-src_gnome-mount-properties.c
+++ /dev/null
@@ -1,21 +0,0 @@
---- src/gnome-mount-properties.c.orig Sun Dec 3 02:38:14 2006
-+++ src/gnome-mount-properties.c Sun Dec 3 02:39:27 2006
-@@ -27,6 +27,8 @@
- #include <libhal.h>
- #include <libhal-storage.h>
-
-+#include <gtk/gtk.h>
-+
- #include <libnautilus-extension/nautilus-extension-types.h>
- #include <libnautilus-extension/nautilus-info-provider.h>
- #include <libnautilus-extension/nautilus-property-page-provider.h>
-@@ -202,7 +204,8 @@ gnome_mount_properties_plugin_register_t
- NULL,
- sizeof (GObject),
- 0,
-- (GInstanceInitFunc) NULL
-+ (GInstanceInitFunc) NULL,
-+ (const GTypeValueTable *) NULL
- };
-
- static const GInterfaceInfo property_page_provider_iface_info = {
diff --git a/sysutils/gnome-mount/files/patch-src_gnome-mount.c b/sysutils/gnome-mount/files/patch-src_gnome-mount.c
index 19de73ccd87b..0d4136e5cafd 100644
--- a/sysutils/gnome-mount/files/patch-src_gnome-mount.c
+++ b/sysutils/gnome-mount/files/patch-src_gnome-mount.c
@@ -1,22 +1,5 @@
--- src/gnome-mount.c.orig Sun Sep 17 01:17:54 2006
+++ src/gnome-mount.c Sun Feb 11 01:03:16 2007
-@@ -51,9 +51,14 @@
- #include <libhal.h>
- #include <libhal-storage.h>
-
--#ifndef sun
-+#if !defined(sun) && !defined(__FreeBSD__)
- #include <mntent.h>
--#else
-+#elif defined(__FreeBSD__)
-+#include <fstab.h>
-+#include <sys/param.h>
-+#include <sys/ucred.h>
-+#include <sys/mount.h>
-+#elif defined(sun)
- #include <sys/mnttab.h>
- #endif
-
@@ -380,7 +385,7 @@ show_error_dialog_mount (LibHalVolume *v
} else if (strcmp (error_name, "org.freedesktop.Hal.Device.Volume.AlreadyMounted") == 0) {
@@ -35,84 +18,3 @@
w = NULL;
} else {
-@@ -582,19 +587,24 @@ static char *
- get_mntent_mount_point(const char *device_file)
- {
- char *mount_point;
-+#if! defined(sun) && !defined(__FreeBSD__)
- FILE *f;
--#ifndef sun
- struct mntent mnt;
- struct mntent *mnte;
- char buf[512];
--#else
-+#elif defined(__FreeBSD__)
-+ struct statfs *mounts;
-+ int n_mounts;
-+ int i;
-+#elif defined(sun)
-+ FILE *f;
- struct mnttab mnt;
- struct mnttab mpref = { NULL, NULL, NULL, NULL, NULL };
- #endif
-
- mount_point = NULL;
-
--#ifndef sun
-+#if !defined(sun) && !defined(__FreeBSD__)
- if ((f = setmntent ("/proc/mounts", "r")) != NULL) {
-
- while ((mnte = getmntent_r (f, &mnt, buf, sizeof(buf))) != NULL) {
-@@ -608,7 +618,7 @@ get_mntent_mount_point(const char *devic
- endmntent (f);
- }
-
--#else /* sun */
-+#elif defined(sun) /* sun */
-
- if ((f = fopen(MNTTAB, "r")) != NULL) {
- mpref.mnt_special = (char *)device_file;
-@@ -617,8 +627,13 @@ get_mntent_mount_point(const char *devic
- }
- fclose(f);
- }
--
--#endif /* sun */
-+#elif defined(__FreeBSD__)
-+ n_mounts = getmntinfo(&mounts, MNT_NOWAIT);
-+ for (i = 0; i < n_mounts; i++) {
-+ if (!strcmp(mounts[i].f_mntfromname, device_file))
-+ mount_point = g_strdup (mounts[i].f_mntonname);
-+ }
-+#endif /* sun && __FreeBSD__ */
-
- out:
- return (mount_point);
-@@ -1322,7 +1337,11 @@ volume_mount (const char *udi, LibHalVol
- if (volume == NULL && (mount_options->len == 0)) {
- /* volume from a non-pollable drive, just set uid.. */
-
-+#ifndef __FreeBSD__
- snprintf (uidbuf, sizeof (uidbuf) - 1, "uid=%u", getuid ());
-+#else
-+ snprintf (uidbuf, sizeof (uidbuf) - 1, "-u=%u", getuid ());
-+#endif
- g_ptr_array_add (mount_options, uidbuf);
-
- } else if (((fstype_override != NULL) || (fstype != NULL)) && (mount_options->len == 0)) {
-@@ -1349,9 +1368,15 @@ volume_mount (const char *udi, LibHalVol
- g_debug ("read default option '%s' from gconf strlist key %s", option, key);
-
- /* special workaround to replace "uid=" with "uid=<actual uid of caller>" */
-+#ifndef __FreeBSD__
- if (strcmp (option, "uid=") == 0) {
- g_free (option);
- option = g_strdup_printf ("uid=%u", getuid ());
-+#else
-+ if (strcmp (option, "-u=") == 0) {
-+ g_free (option);
-+ option = g_strdup_printf ("-u=%u", getuid ());
-+#endif
- }
- g_ptr_array_add (mount_options, option);
-
diff --git a/sysutils/gnome-mount/pkg-plist b/sysutils/gnome-mount/pkg-plist
index 685e8a43929e..d785176ee115 100644
--- a/sysutils/gnome-mount/pkg-plist
+++ b/sysutils/gnome-mount/pkg-plist
@@ -6,13 +6,28 @@ lib/nautilus/extensions-1.0/libgnome-mount.la
lib/nautilus/extensions-1.0/libgnome-mount.so
libdata/pkgconfig/gnome-mount.pc
share/gnome/gnome-mount/gnome-mount-properties.glade
+share/locale/ar/LC_MESSAGES/gnome-mount.mo
+share/locale/be/LC_MESSAGES/gnome-mount.mo
+share/locale/ca/LC_MESSAGES/gnome-mount.mo
+share/locale/da/LC_MESSAGES/gnome-mount.mo
+share/locale/dz/LC_MESSAGES/gnome-mount.mo
share/locale/en_GB/LC_MESSAGES/gnome-mount.mo
share/locale/es/LC_MESSAGES/gnome-mount.mo
+share/locale/fi/LC_MESSAGES/gnome-mount.mo
+share/locale/fr/LC_MESSAGES/gnome-mount.mo
+share/locale/hu/LC_MESSAGES/gnome-mount.mo
share/locale/it/LC_MESSAGES/gnome-mount.mo
share/locale/ja/LC_MESSAGES/gnome-mount.mo
share/locale/mk/LC_MESSAGES/gnome-mount.mo
share/locale/nb/LC_MESSAGES/gnome-mount.mo
+share/locale/pt_BR/LC_MESSAGES/gnome-mount.mo
share/locale/ru/LC_MESSAGES/gnome-mount.mo
share/locale/sv/LC_MESSAGES/gnome-mount.mo
share/locale/vi/LC_MESSAGES/gnome-mount.mo
@dirrm share/gnome/gnome-mount
+@dirrm share/locale/dz/LC_MESSAGES
+@dirrm share/locale/dz
+@dirrm share/locale/ca/LC_MESSAGES
+@dirrm share/locale/ca
+@dirrm share/locale/be/LC_MESSAGES
+@dirrm share/locale/be