aboutsummaryrefslogtreecommitdiffstats
path: root/sysutils/gnome-system-tools
diff options
context:
space:
mode:
authoradamw <adamw@FreeBSD.org>2004-05-18 08:11:16 +0800
committeradamw <adamw@FreeBSD.org>2004-05-18 08:11:16 +0800
commit18b11fdff74bf174532338a5fa50405ecab9378a (patch)
treeb8d66a1fdc7201f1b954ac0a7aa47893a5269acf /sysutils/gnome-system-tools
parentb67296b7c9934e90cf4f2e86777346a4aa3df161 (diff)
downloadfreebsd-ports-gnome-18b11fdff74bf174532338a5fa50405ecab9378a.tar.gz
freebsd-ports-gnome-18b11fdff74bf174532338a5fa50405ecab9378a.tar.zst
freebsd-ports-gnome-18b11fdff74bf174532338a5fa50405ecab9378a.zip
Add gnomesystemtools.
Various tools to assist in administration and configuration of a workstation. Included are tools to: * Administer user and group accounts * Change the date, time, and time zone * Set up and configure network interfaces * Modify bootloader settings * Start, stop, and modify system services WWW: http://www.gnome.org/projects/gst/
Diffstat (limited to 'sysutils/gnome-system-tools')
-rw-r--r--sysutils/gnome-system-tools/Makefile27
-rw-r--r--sysutils/gnome-system-tools/distinfo2
-rw-r--r--sysutils/gnome-system-tools/pkg-descr10
-rw-r--r--sysutils/gnome-system-tools/pkg-plist212
4 files changed, 251 insertions, 0 deletions
diff --git a/sysutils/gnome-system-tools/Makefile b/sysutils/gnome-system-tools/Makefile
new file mode 100644
index 000000000000..9dc46a0e8e26
--- /dev/null
+++ b/sysutils/gnome-system-tools/Makefile
@@ -0,0 +1,27 @@
+# New ports collection makefile for: gnomesystemtools
+# Date created: 17 May 2004
+# Whom: Adam Weinberger <adamw@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= gnomesystemtools
+PORTVERSION= 0.33.0
+CATEGORIES= sysutils gnome
+MASTER_SITES= ${MASTER_SITE_GNOME}
+MASTER_SITE_SUBDIR= sources/gnome-system-tools/0.33
+DISTNAME= gnome-system-tools-${PORTVERSION}
+
+MAINTAINER= gnome@FreeBSD.org
+COMMENT= Tools to configure workstations
+
+USE_BZIP2= yes
+USE_GMAKE= yes
+USE_PERL5= yes
+USE_X_PREFIX= yes
+USE_GNOME= gnomehack gnomeprefix gnometarget intlhack lthack libgnomeui
+USE_LIBTOOL_VER=13
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
+ LDFLAGS="-L${LOCALBASE}/lib"
+
+.include <bsd.port.mk>
diff --git a/sysutils/gnome-system-tools/distinfo b/sysutils/gnome-system-tools/distinfo
new file mode 100644
index 000000000000..f41be966f267
--- /dev/null
+++ b/sysutils/gnome-system-tools/distinfo
@@ -0,0 +1,2 @@
+MD5 (gnome-system-tools-0.33.0.tar.bz2) = 08efc3dff61a7a988bc2f8f5da67f4b8
+SIZE (gnome-system-tools-0.33.0.tar.bz2) = 1898103
diff --git a/sysutils/gnome-system-tools/pkg-descr b/sysutils/gnome-system-tools/pkg-descr
new file mode 100644
index 000000000000..b0b69e539b80
--- /dev/null
+++ b/sysutils/gnome-system-tools/pkg-descr
@@ -0,0 +1,10 @@
+Various tools to assist in administration and configuration of a workstation.
+Included are tools to:
+
+ * Administer user and group accounts
+ * Change the date, time, and time zone
+ * Set up and configure network interfaces
+ * Modify bootloader settings
+ * Start, stop, and modify system services
+
+WWW: http://www.gnome.org/projects/gst/
diff --git a/sysutils/gnome-system-tools/pkg-plist b/sysutils/gnome-system-tools/pkg-plist
new file mode 100644
index 000000000000..52c6fa9e5bc2
--- /dev/null
+++ b/sysutils/gnome-system-tools/pkg-plist
@@ -0,0 +1,212 @@
+bin/boot-admin
+bin/network-admin
+bin/services-admin
+bin/time-admin
+bin/users-admin
+etc/X11/sysconfig/boot.desktop
+etc/X11/sysconfig/network.desktop
+etc/X11/sysconfig/services.desktop
+etc/X11/sysconfig/time.desktop
+etc/X11/sysconfig/users.desktop
+etc/gconf/gconf.xml.defaults/apps/%gconf.xml
+etc/gconf/gconf.xml.defaults/apps/gnome-system-tools/%gconf.xml
+etc/gconf/gconf.xml.defaults/apps/gnome-system-tools/boot/%gconf.xml
+etc/gconf/gconf.xml.defaults/apps/gnome-system-tools/global/%gconf.xml
+etc/gconf/gconf.xml.defaults/apps/gnome-system-tools/network/%gconf.xml
+etc/gconf/gconf.xml.defaults/apps/gnome-system-tools/services/%gconf.xml
+etc/gconf/gconf.xml.defaults/apps/gnome-system-tools/time/%gconf.xml
+etc/gconf/gconf.xml.defaults/apps/gnome-system-tools/users/%gconf.xml
+etc/gconf/gconf.xml.defaults/schemas/%gconf.xml
+etc/gconf/gconf.xml.defaults/schemas/apps/%gconf.xml
+etc/gconf/gconf.xml.defaults/schemas/apps/gnome-system-tools/%gconf.xml
+etc/gconf/gconf.xml.defaults/schemas/apps/gnome-system-tools/boot/%gconf.xml
+etc/gconf/gconf.xml.defaults/schemas/apps/gnome-system-tools/global/%gconf.xml
+etc/gconf/gconf.xml.defaults/schemas/apps/gnome-system-tools/network/%gconf.xml
+etc/gconf/gconf.xml.defaults/schemas/apps/gnome-system-tools/services/%gconf.xml
+etc/gconf/gconf.xml.defaults/schemas/apps/gnome-system-tools/time/%gconf.xml
+etc/gconf/gconf.xml.defaults/schemas/apps/gnome-system-tools/users/%gconf.xml
+etc/gconf/schemas/gnome-system-tools.schemas
+libdata/pkgconfig/gnome-system-tools.pc
+libdata/pkgconfig/system-tools-backends.pc
+share/gnome-system-tools/interfaces/boot.glade
+share/gnome-system-tools/interfaces/common.glade
+share/gnome-system-tools/interfaces/disks.glade
+share/gnome-system-tools/interfaces/network.glade
+share/gnome-system-tools/interfaces/services.glade
+share/gnome-system-tools/interfaces/time.glade
+share/gnome-system-tools/interfaces/users.glade
+share/gnome-system-tools/pixmaps/16_ethernet.xpm
+share/gnome-system-tools/pixmaps/16_loopback.xpm
+share/gnome-system-tools/pixmaps/16_plip.xpm
+share/gnome-system-tools/pixmaps/16_ppp.xpm
+share/gnome-system-tools/pixmaps/boot.png
+share/gnome-system-tools/pixmaps/computer.png
+share/gnome-system-tools/pixmaps/conectiva.png
+share/gnome-system-tools/pixmaps/connection-ethernet.png
+share/gnome-system-tools/pixmaps/connection-modem.png
+share/gnome-system-tools/pixmaps/debian.png
+share/gnome-system-tools/pixmaps/fedora.png
+share/gnome-system-tools/pixmaps/freebsd.png
+share/gnome-system-tools/pixmaps/gentoo.png
+share/gnome-system-tools/pixmaps/gnome-dev-cdrom-data.png
+share/gnome-system-tools/pixmaps/gnome-dev-cdrom-mixed.png
+share/gnome-system-tools/pixmaps/irda-16.png
+share/gnome-system-tools/pixmaps/irda-48.png
+share/gnome-system-tools/pixmaps/mandrake.png
+share/gnome-system-tools/pixmaps/nameresolution.png
+share/gnome-system-tools/pixmaps/nameresolution_alias.png
+share/gnome-system-tools/pixmaps/nameresolution_id.png
+share/gnome-system-tools/pixmaps/network.png
+share/gnome-system-tools/pixmaps/openna.png
+share/gnome-system-tools/pixmaps/pld.png
+share/gnome-system-tools/pixmaps/plip-48.png
+share/gnome-system-tools/pixmaps/ppp.png
+share/gnome-system-tools/pixmaps/reading.png
+share/gnome-system-tools/pixmaps/redhat.png
+share/gnome-system-tools/pixmaps/server.png
+share/gnome-system-tools/pixmaps/services.png
+share/gnome-system-tools/pixmaps/settings.png
+share/gnome-system-tools/pixmaps/slackware.png
+share/gnome-system-tools/pixmaps/suse.png
+share/gnome-system-tools/pixmaps/talk-userlist.png
+share/gnome-system-tools/pixmaps/time.png
+share/gnome-system-tools/pixmaps/timezone.png
+share/gnome-system-tools/pixmaps/turbolinux.png
+share/gnome-system-tools/pixmaps/unsupported-distro.png
+share/gnome-system-tools/pixmaps/users-groups.png
+share/gnome-system-tools/pixmaps/users.png
+share/gnome-system-tools/pixmaps/wavelan-16.png
+share/gnome-system-tools/pixmaps/wavelan-48.png
+share/gnome-system-tools/pixmaps/world_map-960.png
+share/gnome/applications/boot.desktop
+share/gnome/applications/network.desktop
+share/gnome/applications/services.desktop
+share/gnome/applications/time.desktop
+share/gnome/applications/users.desktop
+share/locale/am/LC_MESSAGES/gnome-system-tools.mo
+share/locale/az/LC_MESSAGES/gnome-system-tools.mo
+share/locale/bg/LC_MESSAGES/gnome-system-tools.mo
+share/locale/ca/LC_MESSAGES/gnome-system-tools.mo
+share/locale/cs/LC_MESSAGES/gnome-system-tools.mo
+share/locale/cs/LC_MESSAGES/setup-tools-backends.mo
+share/locale/da/LC_MESSAGES/gnome-system-tools.mo
+share/locale/da/LC_MESSAGES/setup-tools-backends.mo
+share/locale/de/LC_MESSAGES/gnome-system-tools.mo
+share/locale/de/LC_MESSAGES/setup-tools-backends.mo
+share/locale/el/LC_MESSAGES/gnome-system-tools.mo
+share/locale/en_CA/LC_MESSAGES/gnome-system-tools.mo
+share/locale/en_CA/LC_MESSAGES/setup-tools-backends.mo
+share/locale/en_GB/LC_MESSAGES/gnome-system-tools.mo
+share/locale/en_GB/LC_MESSAGES/setup-tools-backends.mo
+share/locale/es/LC_MESSAGES/gnome-system-tools.mo
+share/locale/es/LC_MESSAGES/setup-tools-backends.mo
+share/locale/et/LC_MESSAGES/gnome-system-tools.mo
+share/locale/eu/LC_MESSAGES/gnome-system-tools.mo
+share/locale/fr/LC_MESSAGES/gnome-system-tools.mo
+share/locale/ga/LC_MESSAGES/gnome-system-tools.mo
+share/locale/gl/LC_MESSAGES/gnome-system-tools.mo
+share/locale/hr/LC_MESSAGES/gnome-system-tools.mo
+share/locale/hr/LC_MESSAGES/setup-tools-backends.mo
+share/locale/hu/LC_MESSAGES/gnome-system-tools.mo
+share/locale/it/LC_MESSAGES/gnome-system-tools.mo
+share/locale/ja/LC_MESSAGES/gnome-system-tools.mo
+share/locale/ja/LC_MESSAGES/setup-tools-backends.mo
+share/locale/ko/LC_MESSAGES/gnome-system-tools.mo
+share/locale/ko/LC_MESSAGES/setup-tools-backends.mo
+share/locale/lt/LC_MESSAGES/gnome-system-tools.mo
+share/locale/lt/LC_MESSAGES/setup-tools-backends.mo
+share/locale/lv/LC_MESSAGES/gnome-system-tools.mo
+share/locale/mk/LC_MESSAGES/gnome-system-tools.mo
+share/locale/ml/LC_MESSAGES/gnome-system-tools.mo
+share/locale/mn/LC_MESSAGES/gnome-system-tools.mo
+share/locale/ms/LC_MESSAGES/gnome-system-tools.mo
+share/locale/nl/LC_MESSAGES/gnome-system-tools.mo
+share/locale/nl/LC_MESSAGES/setup-tools-backends.mo
+share/locale/nn/LC_MESSAGES/gnome-system-tools.mo
+share/locale/no/LC_MESSAGES/gnome-system-tools.mo
+share/locale/no/LC_MESSAGES/setup-tools-backends.mo
+share/locale/pl/LC_MESSAGES/gnome-system-tools.mo
+share/locale/pl/LC_MESSAGES/setup-tools-backends.mo
+share/locale/pt/LC_MESSAGES/gnome-system-tools.mo
+share/locale/pt/LC_MESSAGES/setup-tools-backends.mo
+share/locale/pt_BR/LC_MESSAGES/gnome-system-tools.mo
+share/locale/pt_BR/LC_MESSAGES/setup-tools-backends.mo
+share/locale/ru/LC_MESSAGES/gnome-system-tools.mo
+share/locale/sk/LC_MESSAGES/gnome-system-tools.mo
+share/locale/sr/LC_MESSAGES/gnome-system-tools.mo
+share/locale/sr/LC_MESSAGES/setup-tools-backends.mo
+share/locale/sr@Latn/LC_MESSAGES/gnome-system-tools.mo
+share/locale/sr@Latn/LC_MESSAGES/setup-tools-backends.mo
+share/locale/sv/LC_MESSAGES/gnome-system-tools.mo
+share/locale/sv/LC_MESSAGES/setup-tools-backends.mo
+share/locale/tr/LC_MESSAGES/gnome-system-tools.mo
+share/locale/uk/LC_MESSAGES/gnome-system-tools.mo
+share/locale/vi/LC_MESSAGES/gnome-system-tools.mo
+share/locale/wa/LC_MESSAGES/gnome-system-tools.mo
+share/locale/zh_CN/LC_MESSAGES/gnome-system-tools.mo
+share/locale/zh_TW/LC_MESSAGES/gnome-system-tools.mo
+share/setup-tool-backends/files/debian_ipchains
+share/setup-tool-backends/scripts/boot-conf
+share/setup-tool-backends/scripts/boot-grub.pl
+share/setup-tool-backends/scripts/boot-lilo.pl
+share/setup-tool-backends/scripts/boot-yaboot.pl
+share/setup-tool-backends/scripts/boot.pl
+share/setup-tool-backends/scripts/debug.pl
+share/setup-tool-backends/scripts/dhcpd-conf
+share/setup-tool-backends/scripts/dhcpd.pl
+share/setup-tool-backends/scripts/disks-conf
+share/setup-tool-backends/scripts/display-conf
+share/setup-tool-backends/scripts/file.pl
+share/setup-tool-backends/scripts/filesys.pl
+share/setup-tool-backends/scripts/font-conf
+share/setup-tool-backends/scripts/font.pl
+share/setup-tool-backends/scripts/general.pl
+share/setup-tool-backends/scripts/guess_system.sh
+share/setup-tool-backends/scripts/internetsharing-conf
+share/setup-tool-backends/scripts/ishare.pl
+share/setup-tool-backends/scripts/media.pl
+share/setup-tool-backends/scripts/memory-conf
+share/setup-tool-backends/scripts/mouse-conf
+share/setup-tool-backends/scripts/network-conf
+share/setup-tool-backends/scripts/network.pl
+share/setup-tool-backends/scripts/package-conf
+share/setup-tool-backends/scripts/parse.pl
+share/setup-tool-backends/scripts/partition.pl
+share/setup-tool-backends/scripts/platform.pl
+share/setup-tool-backends/scripts/print-conf
+share/setup-tool-backends/scripts/print.pl
+share/setup-tool-backends/scripts/replace.pl
+share/setup-tool-backends/scripts/report.pl
+share/setup-tool-backends/scripts/service-list.pl
+share/setup-tool-backends/scripts/service.pl
+share/setup-tool-backends/scripts/services-conf
+share/setup-tool-backends/scripts/share.pl
+share/setup-tool-backends/scripts/shares-conf
+share/setup-tool-backends/scripts/time-conf
+share/setup-tool-backends/scripts/tokenizer.pl
+share/setup-tool-backends/scripts/type1inst
+share/setup-tool-backends/scripts/users-conf
+share/setup-tool-backends/scripts/util.pl
+share/setup-tool-backends/scripts/x.pl
+share/setup-tool-backends/scripts/xml.pl
+@dirrm share/setup-tool-backends/scripts
+@dirrm share/setup-tool-backends/files
+@dirrm share/setup-tool-backends
+@dirrm share/gnome-system-tools/pixmaps
+@dirrm share/gnome-system-tools/interfaces
+@dirrm share/gnome-system-tools
+@dirrm etc/gconf/gconf.xml.defaults/schemas/apps/gnome-system-tools/users
+@dirrm etc/gconf/gconf.xml.defaults/schemas/apps/gnome-system-tools/time
+@dirrm etc/gconf/gconf.xml.defaults/schemas/apps/gnome-system-tools/services
+@dirrm etc/gconf/gconf.xml.defaults/schemas/apps/gnome-system-tools/network
+@dirrm etc/gconf/gconf.xml.defaults/schemas/apps/gnome-system-tools/global
+@dirrm etc/gconf/gconf.xml.defaults/schemas/apps/gnome-system-tools/boot
+@dirrm etc/gconf/gconf.xml.defaults/schemas/apps/gnome-system-tools/
+@dirrm etc/gconf/gconf.xml.defaults/apps/gnome-system-tools/users
+@dirrm etc/gconf/gconf.xml.defaults/apps/gnome-system-tools/time
+@dirrm etc/gconf/gconf.xml.defaults/apps/gnome-system-tools/services
+@dirrm etc/gconf/gconf.xml.defaults/apps/gnome-system-tools/network
+@dirrm etc/gconf/gconf.xml.defaults/apps/gnome-system-tools/global
+@dirrm etc/gconf/gconf.xml.defaults/apps/gnome-system-tools/boot
+@dirrm etc/gconf/gconf.xml.defaults/apps/gnome-system-tools/
+@dirrm etc/X11/sysconfig