aboutsummaryrefslogtreecommitdiffstats
path: root/sysutils/gnome-system-tools
diff options
context:
space:
mode:
authormarcus <marcus@FreeBSD.org>2005-11-05 12:53:48 +0800
committermarcus <marcus@FreeBSD.org>2005-11-05 12:53:48 +0800
commit194069571a0e4c7bad7bce0f33a042d707e9e171 (patch)
treec3c8a6312bab5325147ea9ea2ad87f0cc44a5fec /sysutils/gnome-system-tools
parent232533f87b435da7ed2bac7daeae3e90680d9e1d (diff)
downloadfreebsd-ports-gnome-194069571a0e4c7bad7bce0f33a042d707e9e171.tar.gz
freebsd-ports-gnome-194069571a0e4c7bad7bce0f33a042d707e9e171.tar.zst
freebsd-ports-gnome-194069571a0e4c7bad7bce0f33a042d707e9e171.zip
Presenting GNOME 2.12 for FreeBSD. The release is chock full of bug fixes
and new features. Don't believe me? Then see for yourself at http://www.gnome.org/start/2.12/notes/en/. DO NOT USE portupgrade by itself to upgrade to GNOME 2.12. Instead, use the gnome_upgrade.sh script from http://www.marcuscom.com/downloads/gnome_upgrade212.sh. This script will circumvent some potential pitfalls users can see if they use portupgrade by itself. In keeping with tradition, GNOME 2.12 for FreeBSD comes with a special splash screen. The winner of this release's contest is Dominique Goncalves <dominique.goncalves@gmail.com>. His splash screen was inspired by http://art.gnome.org/contests/2.12-splash/83. The FreeBSD GNOME Team would lank to thank the following users for their contributions to this release: Matthew Luckie <mjl@luckie.org.nz> ade sajd on #freebsd-gnome Caelian on #freebsd-gnome mnag Yasuda Keisuke <kysd@po.harenet.ne.jp> Mark Hobden <markhobden@gmail.com> Sergey Akifyev <asa@agava.com> Andreas Kohn For more information on GNOME on FreeBSD, checkout http://www.FreeBSD.org/gnome/. The 2.12 documentation will be posted shortly.
Diffstat (limited to 'sysutils/gnome-system-tools')
-rw-r--r--sysutils/gnome-system-tools/Makefile17
-rw-r--r--sysutils/gnome-system-tools/distinfo4
-rw-r--r--sysutils/gnome-system-tools/files/patch-src_common_gst-auth.c100
-rw-r--r--sysutils/gnome-system-tools/files/patch-src_common_gst-tool.c21
-rw-r--r--sysutils/gnome-system-tools/files/patch-src_network_location.c11
-rw-r--r--sysutils/gnome-system-tools/pkg-plist25
6 files changed, 147 insertions, 31 deletions
diff --git a/sysutils/gnome-system-tools/Makefile b/sysutils/gnome-system-tools/Makefile
index 1dca8a647c5c..005b91a17f19 100644
--- a/sysutils/gnome-system-tools/Makefile
+++ b/sysutils/gnome-system-tools/Makefile
@@ -3,14 +3,15 @@
# Whom: Adam Weinberger <adamw@FreeBSD.org>
#
# $FreeBSD$
+# $MCom: ports/sysutils/gnomesystemtools/Makefile,v 1.30 2005/09/10 05:52:02 marcus Exp $
#
PORTNAME= gnomesystemtools
-PORTVERSION= 1.2.0
-PORTREVISION= 2
+PORTVERSION= 1.4.0
+PORTREVISION= 1
CATEGORIES= sysutils gnome
MASTER_SITES= ${MASTER_SITE_GNOME}
-MASTER_SITE_SUBDIR= sources/gnome-system-tools/1.2
+MASTER_SITE_SUBDIR= sources/gnome-system-tools/1.4
DISTNAME= gnome-system-tools-${PORTVERSION}
DIST_SUBDIR= gnome2
@@ -25,8 +26,9 @@ USE_GMAKE= yes
USE_X_PREFIX= yes
GNOME_DESKTOP_VERSION=2
USE_GNOME= gnomehack gnomeprefix gnometarget intlhack nautilus2
-USE_LIBTOOL_VER=15
+USE_AUTOTOOLS= libtool:15
INSTALLS_OMF= yes
+CONFIGURE_ARGS= --enable-services
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib"
@@ -34,11 +36,8 @@ GCONF_SCHEMAS= gnome-system-tools.schemas
.include <bsd.port.pre.mk>
-.if ${OSVERSION} >= 500000
-CONFIGURE_ARGS+= --enable-services
-PLIST_SUB+= SERVICES=""
-.else
-PLIST_SUB+= SERVICES="@comment "
+.if ${OSVERSION} < 500000
+IGNORE= Uses symbols not present in 4.X
.endif
.include <bsd.port.post.mk>
diff --git a/sysutils/gnome-system-tools/distinfo b/sysutils/gnome-system-tools/distinfo
index 6eb37fa99a84..e0cb6d350a79 100644
--- a/sysutils/gnome-system-tools/distinfo
+++ b/sysutils/gnome-system-tools/distinfo
@@ -1,2 +1,2 @@
-MD5 (gnome2/gnome-system-tools-1.2.0.tar.bz2) = fbcf8866ecea8b330cbe53cf8b0df55e
-SIZE (gnome2/gnome-system-tools-1.2.0.tar.bz2) = 1780677
+MD5 (gnome2/gnome-system-tools-1.4.0.tar.bz2) = bbc13f526025c4da1607fa640499b6ee
+SIZE (gnome2/gnome-system-tools-1.4.0.tar.bz2) = 1959280
diff --git a/sysutils/gnome-system-tools/files/patch-src_common_gst-auth.c b/sysutils/gnome-system-tools/files/patch-src_common_gst-auth.c
index 9272d918136c..f73b28ae4d10 100644
--- a/sysutils/gnome-system-tools/files/patch-src_common_gst-auth.c
+++ b/sysutils/gnome-system-tools/files/patch-src_common_gst-auth.c
@@ -1,13 +1,105 @@
---- src/common/gst-auth.c.orig Thu Mar 10 14:39:18 2005
-+++ src/common/gst-auth.c Thu Mar 10 14:39:50 2005
-@@ -142,12 +142,12 @@ gst_auth_run_term (GstTool *tool, gchar
+--- src/common/gst-auth.c.orig Mon Aug 8 15:00:01 2005
++++ src/common/gst-auth.c Sat Sep 10 01:47:35 2005
+@@ -55,6 +55,82 @@
+ static int root; /* if we are root, no password is
+ required */
+
++#ifdef __FreeBSD__
++static int
++_forkpty (int *amaster, char *name,
++ struct termios *termp, struct winsize *winp)
++{
++ int master, slave;
++ char *line;
++ pid_t pid;
++
++ master = posix_openpt (O_RDWR);
++ if (master == -1)
++ return (-1);
++
++ if (grantpt (master) == -1)
++ {
++ (void) close (master);
++ return (-1);
++ }
++
++ if (unlockpt (master) == -1)
++ {
++ (void) close (master);
++ return (-1);
++ }
++
++ line = ptsname (master);
++ if (line == NULL)
++ {
++ (void) close (master);
++ return (-1);
++ }
++
++ slave = open (line, O_RDWR);
++ if (slave < 0)
++ {
++ (void) close (master);
++ return (-1);
++ }
++
++ if (amaster)
++ *amaster = master;
++
++ if (name)
++ strcpy (name, line);
++
++ if (termp)
++ (void) tcsetattr(slave, TCSAFLUSH, termp);
++
++ if (winp)
++ (void) ioctl(slave, TIOCSWINSZ, (char *) winp);
++
++ pid = fork ();
++ switch (pid)
++ {
++ case -1:
++ (void) close (slave);
++ (void) close (master);
++ return (-1);
++ case 0:
++ (void) close (master);
++ dup2 (slave, STDIN_FILENO);
++ dup2 (slave, STDOUT_FILENO);
++ dup2 (slave, STDERR_FILENO);
++ return (0);
++ default:
++ (void) close (slave);
++ return (pid);
++ }
++
++ (void) close (master);
++ return (-1);
++}
++#else
++#define _forkpty forkpty
++#endif
++
+ static void
+ gst_auth_display_error_message (GstTool *tool, gchar *primary_text, gchar *secondary_text)
+ {
+@@ -125,7 +201,7 @@ gst_auth_run_term (GstTool *tool, gchar
+ int p[2];
+
+ pipe (p);
+- tool->backend_pid = forkpty (&tool->write_fd, NULL, NULL, NULL);
++ tool->backend_pid = _forkpty (&tool->write_fd, NULL, NULL, NULL);
+
+ if (tool->backend_pid < 0) {
+ gst_auth_display_error_message (tool,
+@@ -142,12 +218,12 @@ gst_auth_run_term (GstTool *tool, gchar
unsetenv("LANG");
unsetenv("LANGUAGE");
- dup2 (p[1], 1);
- dup2 (p[1], 2);
+ dup2 (p[1], STDOUT_FILENO);
-+ /*dup2 (p[1], 2);*/
++ dup2 (p[1], STDERR_FILENO);
close (p[0]);
execv (args[0], args);
diff --git a/sysutils/gnome-system-tools/files/patch-src_common_gst-tool.c b/sysutils/gnome-system-tools/files/patch-src_common_gst-tool.c
index 5134f30e581b..9aaef15031fd 100644
--- a/sysutils/gnome-system-tools/files/patch-src_common_gst-tool.c
+++ b/sysutils/gnome-system-tools/files/patch-src_common_gst-tool.c
@@ -1,6 +1,21 @@
---- src/common/gst-tool.c.orig Thu Mar 10 14:39:54 2005
-+++ src/common/gst-tool.c Thu Mar 10 14:40:00 2005
-@@ -1653,7 +1653,7 @@ poll_backend (GstTool *tool)
+--- src/common/gst-tool.c.orig Tue Jun 21 15:07:05 2005
++++ src/common/gst-tool.c Wed Jul 6 01:28:22 2005
+@@ -598,7 +598,14 @@ gst_tool_kill_backend_cb (GstDirectiveEn
+ if (tool->root_access == ROOT_ACCESS_SIMULATED_DISABLED)
+ tool->root_access = ROOT_ACCESS_SIMULATED;
+
++#if 0
++ /*
++ * We do not need to wait for the tool,
++ * as it will get SIGPIPE anyway.
++ * This waitpid causes problems on FreeBSD.
++ */
+ waitpid (tool->backend_pid, NULL, 0);
++#endif
+ }
+ }
+
+@@ -1655,7 +1662,7 @@ poll_backend (GstTool *tool)
struct pollfd fd;
fd.fd = tool->read_fd;
diff --git a/sysutils/gnome-system-tools/files/patch-src_network_location.c b/sysutils/gnome-system-tools/files/patch-src_network_location.c
deleted file mode 100644
index e2577a6a49e0..000000000000
--- a/sysutils/gnome-system-tools/files/patch-src_network_location.c
+++ /dev/null
@@ -1,11 +0,0 @@
---- src/network/location.c.orig Thu Dec 23 13:16:33 2004
-+++ src/network/location.c Thu Dec 23 13:16:40 2004
-@@ -687,7 +687,7 @@
- static void
- copy_tag_list (xmlNodePtr source, xmlNodePtr dest, const gchar *list[])
- {
-- gchar **string = (gchar **) list;;
-+ gchar **string = (gchar **) list;
- gchar *value;
-
- while (*string)
diff --git a/sysutils/gnome-system-tools/pkg-plist b/sysutils/gnome-system-tools/pkg-plist
index a52125a51fcd..48800800d0e0 100644
--- a/sysutils/gnome-system-tools/pkg-plist
+++ b/sysutils/gnome-system-tools/pkg-plist
@@ -1,5 +1,5 @@
bin/network-admin
-%%SERVICES%%bin/services-admin
+bin/services-admin
bin/shares-admin
bin/time-admin
bin/users-admin
@@ -58,12 +58,13 @@ share/gnome-system-tools/pixmaps/turbolinux.png
share/gnome-system-tools/pixmaps/unsupported-distro.png
share/gnome-system-tools/pixmaps/users-groups.png
share/gnome-system-tools/pixmaps/users.png
+share/gnome-system-tools/pixmaps/vidalinux.png
share/gnome-system-tools/pixmaps/vine.png
share/gnome-system-tools/pixmaps/wavelan-16.png
share/gnome-system-tools/pixmaps/wavelan-48.png
share/gnome-system-tools/pixmaps/world_map-960.png
share/gnome/applications/network.desktop
-%%SERVICES%%share/gnome/applications/services.desktop
+share/gnome/applications/services.desktop
share/gnome/applications/shares.desktop
share/gnome/applications/time.desktop
share/gnome/applications/users.desktop
@@ -77,18 +78,29 @@ share/gnome/help/services-admin/C/figures/service-properties.png
share/gnome/help/services-admin/C/figures/services-tool.png
share/gnome/help/services-admin/C/legal.xml
share/gnome/help/services-admin/C/services-admin.xml
+share/gnome/help/services-admin/nl/figures/service-properties.png
+share/gnome/help/services-admin/nl/figures/services-tool.png
+share/gnome/help/services-admin/nl/legal.xml
+share/gnome/help/services-admin/nl/services-admin.xml
share/gnome/help/time-admin/C/figures/time-map.png
share/gnome/help/time-admin/C/figures/time-servers.png
share/gnome/help/time-admin/C/figures/time-tool.png
share/gnome/help/time-admin/C/legal.xml
share/gnome/help/time-admin/C/time-admin.xml
+share/gnome/help/time-admin/nl/figures/time-map.png
+share/gnome/help/time-admin/nl/figures/time-servers.png
+share/gnome/help/time-admin/nl/figures/time-tool.png
+share/gnome/help/time-admin/nl/legal.xml
+share/gnome/help/time-admin/nl/time-admin.xml
share/gnome/help/users-admin/C/figures/users-tool.png
share/gnome/help/users-admin/C/legal.xml
share/gnome/help/users-admin/C/users-admin.xml
share/gnome/omf/gnome-system-tools/boot-admin-C.omf
share/gnome/omf/gnome-system-tools/network-admin-C.omf
share/gnome/omf/gnome-system-tools/services-admin-C.omf
+share/gnome/omf/gnome-system-tools/services-admin-nl.omf
share/gnome/omf/gnome-system-tools/time-admin-C.omf
+share/gnome/omf/gnome-system-tools/time-admin-nl.omf
share/gnome/omf/gnome-system-tools/users-admin-C.omf
share/locale/am/LC_MESSAGES/gnome-system-tools.mo
share/locale/ar/LC_MESSAGES/gnome-system-tools.mo
@@ -110,6 +122,7 @@ share/locale/fr/LC_MESSAGES/gnome-system-tools.mo
share/locale/ga/LC_MESSAGES/gnome-system-tools.mo
share/locale/gl/LC_MESSAGES/gnome-system-tools.mo
share/locale/gu/LC_MESSAGES/gnome-system-tools.mo
+share/locale/he/LC_MESSAGES/gnome-system-tools.mo
share/locale/hi/LC_MESSAGES/gnome-system-tools.mo
share/locale/hr/LC_MESSAGES/gnome-system-tools.mo
share/locale/hu/LC_MESSAGES/gnome-system-tools.mo
@@ -123,6 +136,8 @@ share/locale/mk/LC_MESSAGES/gnome-system-tools.mo
share/locale/ml/LC_MESSAGES/gnome-system-tools.mo
share/locale/mn/LC_MESSAGES/gnome-system-tools.mo
share/locale/ms/LC_MESSAGES/gnome-system-tools.mo
+share/locale/nb/LC_MESSAGES/gnome-system-tools.mo
+share/locale/ne/LC_MESSAGES/gnome-system-tools.mo
share/locale/nl/LC_MESSAGES/gnome-system-tools.mo
share/locale/nn/LC_MESSAGES/gnome-system-tools.mo
share/locale/no/LC_MESSAGES/gnome-system-tools.mo
@@ -132,6 +147,7 @@ share/locale/pt/LC_MESSAGES/gnome-system-tools.mo
share/locale/pt_BR/LC_MESSAGES/gnome-system-tools.mo
share/locale/ro/LC_MESSAGES/gnome-system-tools.mo
share/locale/ru/LC_MESSAGES/gnome-system-tools.mo
+share/locale/rw/LC_MESSAGES/gnome-system-tools.mo
share/locale/sk/LC_MESSAGES/gnome-system-tools.mo
share/locale/sq/LC_MESSAGES/gnome-system-tools.mo
share/locale/sr/LC_MESSAGES/gnome-system-tools.mo
@@ -143,15 +159,20 @@ share/locale/tr/LC_MESSAGES/gnome-system-tools.mo
share/locale/uk/LC_MESSAGES/gnome-system-tools.mo
share/locale/vi/LC_MESSAGES/gnome-system-tools.mo
share/locale/wa/LC_MESSAGES/gnome-system-tools.mo
+share/locale/xh/LC_MESSAGES/gnome-system-tools.mo
share/locale/zh_CN/LC_MESSAGES/gnome-system-tools.mo
share/locale/zh_TW/LC_MESSAGES/gnome-system-tools.mo
@dirrm share/gnome/omf/gnome-system-tools
@dirrm share/gnome/help/users-admin/C/figures
@dirrm share/gnome/help/users-admin/C
@dirrm share/gnome/help/users-admin
+@dirrm share/gnome/help/time-admin/nl/figures
+@dirrm share/gnome/help/time-admin/nl
@dirrm share/gnome/help/time-admin/C/figures
@dirrm share/gnome/help/time-admin/C
@dirrm share/gnome/help/time-admin
+@dirrm share/gnome/help/services-admin/nl/figures
+@dirrm share/gnome/help/services-admin/nl
@dirrm share/gnome/help/services-admin/C/figures
@dirrm share/gnome/help/services-admin/C
@dirrm share/gnome/help/services-admin