aboutsummaryrefslogtreecommitdiffstats
path: root/sysutils/gnome-system-tools
diff options
context:
space:
mode:
authormarcus <marcus@FreeBSD.org>2004-11-08 06:24:32 +0800
committermarcus <marcus@FreeBSD.org>2004-11-08 06:24:32 +0800
commitfb8541d2d8cfc686242832e1c242a6e16a71f562 (patch)
treeeb4a9f17e9018ff5a01b23a7dcb55603930cc5cf /sysutils/gnome-system-tools
parent9d873617ccf0d009f3c169794dbfcb0741259b2e (diff)
downloadfreebsd-ports-gnome-fb8541d2d8cfc686242832e1c242a6e16a71f562.tar.gz
freebsd-ports-gnome-fb8541d2d8cfc686242832e1c242a6e16a71f562.tar.zst
freebsd-ports-gnome-fb8541d2d8cfc686242832e1c242a6e16a71f562.zip
Presenting GNOME 2.8 for FreeBSD (2.8.1 to be exact).
This release notes detailing all of the new goodies in GNOME 2.8 can be found at http://www.gnome.org/start/2.8/notes/, and the list of what was fixed in GNOME 2.8.1 can be found at http://lists.gnome.org/archives/gnome-announce-list/2004-October/msg00056.html. This release, as well as all of our others, would not have been possible without the great efforts of our FreeBSD GNOME Team. The list of current members can be found at http://www.freebsd.org/gnome/contact.html (including our newest member, Michael Johnson <ahze@FreeBSD.org>). Special thanks also goes out to all of the loyal FreeBSD GNOME users that put up with crashes and hangs to test and debug GNOME on FreeBSD. We would especially like to thank those users that provided patches for GNOME 2.7 and 2.8: Franz Klammer <klammer@webonaut.com> Piotr Smyrak <piotr.smyrak@heron.pl> Radek Kozlowski <radek@raadradd.com> Khairil Yusof <kaeru@pd.jaring.my> Yasuda Keisuke <kysd@po.harenet.ne.jp> Tom McLaughlin <tmclaugh@sdf.lonestar.org> Vladimir Grebenschikov <vova@fbsd.ru> GNOME 2.8 also features a new, FreeBSD-specific splashscreen that was designed by jimmac for GNOME 2.8, then daemonized by Franz Klammer <klammer@webonaut.com> and Radek Kozlowski <radek@raadradd.com>. As with GNOME 2.6, you cannot just "portupgrade" to GNOME 2.8. There is a script provided at http://www.marcuscom.com/downloads/gnome_upgrade28.sh that will aid in the upgrade process. Full documentation on the GNOME 2.8 upgrade is coming following this commit. From all of us at FreeBSD GNOME, ENJOY!
Diffstat (limited to 'sysutils/gnome-system-tools')
-rw-r--r--sysutils/gnome-system-tools/Makefile12
-rw-r--r--sysutils/gnome-system-tools/distinfo4
-rw-r--r--sysutils/gnome-system-tools/files/patch-backends_replace.pl.in34
-rw-r--r--sysutils/gnome-system-tools/pkg-plist9
4 files changed, 54 insertions, 5 deletions
diff --git a/sysutils/gnome-system-tools/Makefile b/sysutils/gnome-system-tools/Makefile
index 63af3b9274af..ea712a90ad50 100644
--- a/sysutils/gnome-system-tools/Makefile
+++ b/sysutils/gnome-system-tools/Makefile
@@ -6,11 +6,11 @@
#
PORTNAME= gnomesystemtools
-PORTVERSION= 0.92.0
-PORTREVISION= 1
+PORTVERSION= 1.0.0
+PORTREVISION= 2
CATEGORIES= sysutils gnome
MASTER_SITES= ${MASTER_SITE_GNOME}
-MASTER_SITE_SUBDIR= sources/gnome-system-tools/0.92
+MASTER_SITE_SUBDIR= sources/gnome-system-tools/1.0
DISTNAME= gnome-system-tools-${PORTVERSION}
DIST_SUBDIR= gnome2
@@ -35,4 +35,10 @@ PLIST_SUB+= SERVICES=""
PLIST_SUB+= SERVICES="@comment "
.endif
+.if ${PERL_LEVEL} < 500600
+post-configure:
+ @${FIND} ${WRKSRC}/backends \( -name "*.pl" -or -name "*-conf" \) | \
+ ${XARGS} ${REINPLACE_CMD} -e 's|@scriptsdir|[@]scriptsdir|g'
+.endif
+
.include <bsd.port.post.mk>
diff --git a/sysutils/gnome-system-tools/distinfo b/sysutils/gnome-system-tools/distinfo
index 3a6b3da6e230..9d0dc16e5062 100644
--- a/sysutils/gnome-system-tools/distinfo
+++ b/sysutils/gnome-system-tools/distinfo
@@ -1,2 +1,2 @@
-MD5 (gnome2/gnome-system-tools-0.92.0.tar.bz2) = 1c2e3ae388e179b669ffa8d293bd17f1
-SIZE (gnome2/gnome-system-tools-0.92.0.tar.bz2) = 2614845
+MD5 (gnome2/gnome-system-tools-1.0.0.tar.bz2) = 7f85cab03aeffdb9c57925fe2be0e001
+SIZE (gnome2/gnome-system-tools-1.0.0.tar.bz2) = 2719276
diff --git a/sysutils/gnome-system-tools/files/patch-backends_replace.pl.in b/sysutils/gnome-system-tools/files/patch-backends_replace.pl.in
new file mode 100644
index 000000000000..7f7cce28ee37
--- /dev/null
+++ b/sysutils/gnome-system-tools/files/patch-backends_replace.pl.in
@@ -0,0 +1,34 @@
+--- backends/replace.pl.in.orig Fri Oct 22 02:41:56 2004
++++ backends/replace.pl.in Fri Oct 22 02:42:48 2004
+@@ -1113,19 +1113,19 @@
+
+ return -1 if (!&gst_replace_interfaces_iface_stanza_locate ($buff, \$line_no, $iface));
+
+- delete $$buff[$line_no];
++ splice @{$buff},$line_no,1;
+ $line_no ++;
+
+ while (&gst_replace_interfaces_get_next_option ($buff, \$line_no) != -1)
+ {
+- delete $$buff[$line_no];
++ splice @{$buff},$line_no,1;
+ $line_no ++;
+ }
+
+ $line_no = 0;
+ if (&gst_replace_interfaces_auto_stanza_locate ($buff, \$line_no, $iface))
+ {
+- delete $$buff[$line_no];
++ splice @{$buff},$line_no,1;
+ }
+
+ &gst_file_buffer_clean ($buff);
+@@ -1663,7 +1663,7 @@
+ }
+ else
+ {
+- delete $$buff[$i];
++ splice @{$buff},$i,1;
+ }
+ }
+ }
diff --git a/sysutils/gnome-system-tools/pkg-plist b/sysutils/gnome-system-tools/pkg-plist
index fabe1da2680f..1ccb07eb14e1 100644
--- a/sysutils/gnome-system-tools/pkg-plist
+++ b/sysutils/gnome-system-tools/pkg-plist
@@ -97,6 +97,8 @@ share/gnome/omf/gnome-system-tools/time-admin-C.omf
share/gnome/omf/gnome-system-tools/users-admin-C.omf
@exec scrollkeeper-install -q %D/share/gnome/omf/gnome-system-tools/users-admin-C.omf 2>/dev/null || /usr/bin/true
share/locale/am/LC_MESSAGES/gnome-system-tools.mo
+share/locale/ar/LC_MESSAGES/gnome-system-tools.mo
+share/locale/ar/LC_MESSAGES/setup-tools-backends.mo
share/locale/az/LC_MESSAGES/gnome-system-tools.mo
share/locale/az/LC_MESSAGES/setup-tools-backends.mo
share/locale/bg/LC_MESSAGES/gnome-system-tools.mo
@@ -104,6 +106,7 @@ share/locale/bn/LC_MESSAGES/setup-tools-backends.mo
share/locale/bn/LC_MESSAGES/gnome-system-tools.mo
share/locale/bs/LC_MESSAGES/setup-tools-backends.mo
share/locale/ca/LC_MESSAGES/gnome-system-tools.mo
+share/locale/ca/LC_MESSAGES/setup-tools-backends.mo
share/locale/cs/LC_MESSAGES/gnome-system-tools.mo
share/locale/cs/LC_MESSAGES/setup-tools-backends.mo
share/locale/da/LC_MESSAGES/gnome-system-tools.mo
@@ -122,6 +125,7 @@ share/locale/et/LC_MESSAGES/gnome-system-tools.mo
share/locale/eu/LC_MESSAGES/gnome-system-tools.mo
share/locale/eu/LC_MESSAGES/setup-tools-backends.mo
share/locale/fi/LC_MESSAGES/gnome-system-tools.mo
+share/locale/fi/LC_MESSAGES/setup-tools-backends.mo
share/locale/fr/LC_MESSAGES/gnome-system-tools.mo
share/locale/ga/LC_MESSAGES/gnome-system-tools.mo
share/locale/gl/LC_MESSAGES/gnome-system-tools.mo
@@ -157,6 +161,8 @@ share/locale/pt/LC_MESSAGES/gnome-system-tools.mo
share/locale/pt/LC_MESSAGES/setup-tools-backends.mo
share/locale/pt_BR/LC_MESSAGES/gnome-system-tools.mo
share/locale/pt_BR/LC_MESSAGES/setup-tools-backends.mo
+share/locale/ro/LC_MESSAGES/gnome-system-tools.mo
+share/locale/ro/LC_MESSAGES/setup-tools-backends.mo
share/locale/ru/LC_MESSAGES/gnome-system-tools.mo
share/locale/sk/LC_MESSAGES/gnome-system-tools.mo
share/locale/sq/LC_MESSAGES/gnome-system-tools.mo
@@ -168,13 +174,16 @@ share/locale/sr@Latn/LC_MESSAGES/setup-tools-backends.mo
share/locale/sv/LC_MESSAGES/gnome-system-tools.mo
share/locale/sv/LC_MESSAGES/setup-tools-backends.mo
share/locale/ta/LC_MESSAGES/gnome-system-tools.mo
+share/locale/ta/LC_MESSAGES/setup-tools-backends.mo
share/locale/tr/LC_MESSAGES/gnome-system-tools.mo
share/locale/uk/LC_MESSAGES/gnome-system-tools.mo
share/locale/uk/LC_MESSAGES/setup-tools-backends.mo
share/locale/vi/LC_MESSAGES/gnome-system-tools.mo
share/locale/wa/LC_MESSAGES/gnome-system-tools.mo
share/locale/zh_CN/LC_MESSAGES/gnome-system-tools.mo
+share/locale/zh_CN/LC_MESSAGES/setup-tools-backends.mo
share/locale/zh_TW/LC_MESSAGES/gnome-system-tools.mo
+share/locale/zh_TW/LC_MESSAGES/setup-tools-backends.mo
share/setup-tool-backends/files/debian_ipchains
share/setup-tool-backends/scripts/boot-conf
share/setup-tool-backends/scripts/boot-grub.pl