aboutsummaryrefslogtreecommitdiffstats
path: root/sysutils/gnomecontrolcenter
diff options
context:
space:
mode:
authorsobomax <sobomax@FreeBSD.org>2002-07-12 01:16:10 +0800
committersobomax <sobomax@FreeBSD.org>2002-07-12 01:16:10 +0800
commitda74e1e2753beef93258c048d602476b4b4dfd7c (patch)
tree38d55d2134664c2fa5ec17aa6dadae38a1ec9e4f /sysutils/gnomecontrolcenter
parent355f300440d2bd9dae6636ba5c8bf4eacacc9567 (diff)
downloadfreebsd-ports-gnome-da74e1e2753beef93258c048d602476b4b4dfd7c.tar.gz
freebsd-ports-gnome-da74e1e2753beef93258c048d602476b4b4dfd7c.tar.zst
freebsd-ports-gnome-da74e1e2753beef93258c048d602476b4b4dfd7c.zip
Convert all core GNOME1 components and some of the most popular GNOME1
apps to bsd.gnomeng.mk. The goal is to make GNOME1 framework more modular, which will allow to use GNOME1 apps with GNOME2 desktop as well as considerably reduce langht of dependency chains for GNOME1 ports (for example after this commit AbiWord's dependency chain was reduced by 7 ports from 57 to only 50, while Gnumeric's - from 60 to 53 and so on). The most of the GNOME1 apps are still not converted, so that lot of work is still ahead. Please report any unusual problems to gnome@FreeBSD.org. Discussed with: marcus Reviewed by: marcus
Diffstat (limited to 'sysutils/gnomecontrolcenter')
-rw-r--r--sysutils/gnomecontrolcenter/Makefile14
-rw-r--r--sysutils/gnomecontrolcenter/files/patch-bn52
-rw-r--r--sysutils/gnomecontrolcenter/files/patch-idl::Makefile.in14
-rw-r--r--sysutils/gnomecontrolcenter/pkg-plist21
4 files changed, 63 insertions, 38 deletions
diff --git a/sysutils/gnomecontrolcenter/Makefile b/sysutils/gnomecontrolcenter/Makefile
index 06b89691fae7..a9fc227cff77 100644
--- a/sysutils/gnomecontrolcenter/Makefile
+++ b/sysutils/gnomecontrolcenter/Makefile
@@ -16,23 +16,17 @@ DIST_SUBDIR= gnome
MAINTAINER= gnome@FreeBSD.org
-LIB_DEPENDS= gnomecanvaspixbuf.1:${PORTSDIR}/graphics/gnomecanvas \
- gnomevfs.0:${PORTSDIR}/devel/gnomevfs
-
USE_BZIP2= yes
USE_X_PREFIX= yes
USE_GMAKE= yes
-USE_GNOMELIBS= yes
-INSTALLS_SHLIB= yes
+USE_GNOMENG= yes
+USE_GNOME= gnomeprefix gnomehack gnomecanvas gnomevfs libcapplet
GNU_CONFIGURE= yes
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LIBS="-L${LOCALBASE}/lib"
-pre-patch:
- @${PERL} -pi -e 's|-lpthread|${PTHREAD_LIBS}|g ; \
+post-patch:
+ @${REINPLACE_CMD} -e 's|-lpthread|${PTHREAD_LIBS}|g ; \
s|DATADIRNAME=lib|DATADIRNAME=share|g' ${WRKSRC}/configure
- @find ${WRKSRC} -name "Makefile.in*" | xargs ${PERL} -pi -e \
- 's|\$\(datadir\)/gnome/|\$\(datadir\)/|g ; \
- s|\$\(datadir\)/locale|\$\(prefix\)/share/locale|g'
.include <bsd.port.mk>
diff --git a/sysutils/gnomecontrolcenter/files/patch-bn b/sysutils/gnomecontrolcenter/files/patch-bn
index 294e18fe95ed..737c98cab630 100644
--- a/sysutils/gnomecontrolcenter/files/patch-bn
+++ b/sysutils/gnomecontrolcenter/files/patch-bn
@@ -1,16 +1,54 @@
---- control-center/Makefile.in.orig Tue Aug 1 22:42:01 2000
-+++ control-center/Makefile.in Tue Aug 1 22:45:47 2000
-@@ -162,3 +162,3 @@
+
+$FreeBSD$
+
+--- control-center/Makefile.in.orig Wed Jul 10 16:48:34 2002
++++ control-center/Makefile.in Wed Jul 10 16:51:37 2002
+@@ -208,7 +208,7 @@
+ sys_in_files = gnomecc.desktop.in
+ sys_DATA = $(sys_in_files:.desktop.in=.desktop)
-confexecdir = $(libdir)
+confexecdir = $(sysconfdir)
confexec_DATA = cappletConf.sh
-@@ -168,3 +168,3 @@
+
+ libcapplet_la_SOURCES = \
+@@ -218,7 +218,7 @@
+ $(CORBA_SRCLIST)
+
-libcapplet_la_LDFLAGS = -version-info 0:0:0 -rpath $(libdir)
+libcapplet_la_LDFLAGS = -version-info 5:0:0
libcapplet_la_LIBADD = $(ORB_LIBS) -lm $(DL_LIB) $(GNORBA_LIBS)
-@@ -590,2 +590,3 @@
- -e 's?\@ORB_LIBS\@?$(ORB_LIBS)?g' \
+
+ libcappletincludedir = $(includedir)/libcapplet1
+@@ -522,12 +522,10 @@
+ check: check-am
+ installcheck-am:
+ installcheck: installcheck-am
+-install-exec-am: install-libLTLIBRARIES install-binPROGRAMS \
+- install-confexecDATA
++install-exec-am: install-binPROGRAMS
+ install-exec: install-exec-am
+
+-install-data-am: install-appiconDATA install-splashDATA install-sysDATA \
+- install-libcappletincludeHEADERS
++install-data-am: install-appiconDATA install-splashDATA install-sysDATA
+ install-data: install-data-am
+
+ install-am: all-am
+@@ -546,7 +544,6 @@
+ $(mkinstalldirs) $(DESTDIR)$(libdir) $(DESTDIR)$(bindir) \
+ $(DESTDIR)$(appicondir) $(DESTDIR)$(confexecdir) \
+ $(DESTDIR)$(splashdir) $(DESTDIR)$(sysdir) \
+- $(DESTDIR)$(libcappletincludedir)
+
+
+ mostlyclean-generic:
+@@ -592,6 +589,7 @@
+ clean-libLTLIBRARIES maintainer-clean-libLTLIBRARIES \
+ uninstall-libLTLIBRARIES install-libLTLIBRARIES mostlyclean-compile \
+ distclean-compile clean-compile maintainer-clean-compile \
+ -e 's?\@VERSION\@?$(VERSION)?g' \
- < $(srcdir)/cappletConf.sh.in > cappletConf.tmp \
+ mostlyclean-libtool distclean-libtool clean-libtool \
+ maintainer-clean-libtool mostlyclean-binPROGRAMS distclean-binPROGRAMS \
+ clean-binPROGRAMS maintainer-clean-binPROGRAMS uninstall-binPROGRAMS \
diff --git a/sysutils/gnomecontrolcenter/files/patch-idl::Makefile.in b/sysutils/gnomecontrolcenter/files/patch-idl::Makefile.in
new file mode 100644
index 000000000000..8bc65dc999aa
--- /dev/null
+++ b/sysutils/gnomecontrolcenter/files/patch-idl::Makefile.in
@@ -0,0 +1,14 @@
+
+$FreeBSD$
+
+--- idl/Makefile.in 2002/07/10 13:49:41 1.1
++++ idl/Makefile.in 2002/07/10 13:50:18
+@@ -251,7 +251,7 @@
+ install-exec-am:
+ install-exec: install-exec-am
+
+-install-data-am: install-gnomeccgnorbaDATA install-idlDATA
++install-data-am: install-gnomeccgnorbaDATA
+ install-data: install-data-am
+
+ install-am: all-am
diff --git a/sysutils/gnomecontrolcenter/pkg-plist b/sysutils/gnomecontrolcenter/pkg-plist
index 851c8c41c64e..bea2205dc885 100644
--- a/sysutils/gnomecontrolcenter/pkg-plist
+++ b/sysutils/gnomecontrolcenter/pkg-plist
@@ -10,11 +10,6 @@ bin/ui-properties
bin/url-properties
bin/wm-properties-capplet
etc/CORBA/servers/gnomecc.gnorba
-etc/cappletConf.sh
-include/libcapplet1/capplet-widget.h
-lib/libcapplet.a
-lib/libcapplet.so
-lib/libcapplet.so.5
share/gnome/apps/Settings/Desktop/.directory
share/gnome/apps/Settings/Desktop/background-properties.desktop
share/gnome/apps/Settings/Desktop/theme-selector.desktop
@@ -130,7 +125,6 @@ share/gnome/help/control-center/eu/stylesheet-images/up.gif
share/gnome/help/control-center/eu/stylesheet-images/warning.gif
share/gnome/help/control-center/eu/topic.dat
share/gnome/help/control-center/eu/usage.html
-share/gnome/idl/control-center.idl
share/gnome/omf/control-center/control-center-C.omf
share/gnome/omf/control-center/control-center-eu.omf
share/gnome/pixmaps/ccsplash.png
@@ -177,7 +171,6 @@ share/locale/uk/LC_MESSAGES/control-center.mo
share/locale/wa/LC_MESSAGES/control-center.mo
share/locale/zh_CN/LC_MESSAGES/control-center.mo
share/locale/zh_TW/LC_MESSAGES/control-center.mo
-@dirrm share/gnome/wm-properties
@dirrm share/gnome/omf/control-center
@dirrm share/gnome/help/control-center/C/stylesheet-images
@dirrm share/gnome/help/control-center/C/figures
@@ -187,20 +180,6 @@ share/locale/zh_TW/LC_MESSAGES/control-center.mo
@dirrm share/gnome/help/control-center/eu
@dirrm share/gnome/help/control-center
@dirrm share/gnome/control-center/UIOptions
-@dirrm share/gnome/control-center/Session
-@dirrm share/gnome/control-center/Peripherals
@dirrm share/gnome/control-center/Multimedia
-@dirrm share/gnome/control-center/Documents
-@dirrm share/gnome/control-center/Desktop
-@dirrm share/gnome/control-center
@dirrm share/gnome/apps/Settings/UIOptions
-@dirrm share/gnome/apps/Settings/Session
-@dirrm share/gnome/apps/Settings/Peripherals
@dirrm share/gnome/apps/Settings/Multimedia
-@dirrm share/gnome/apps/Settings/Documents
-@dirrm share/gnome/apps/Settings/Desktop
-@dirrm share/gnome/apps/Settings
-@dirrm share/gnome/apps
-@dirrm include/libcapplet1
-@dirrm etc/CORBA/servers
-@dirrm etc/CORBA